Roon not playing music anymore

I’m running RoonServer 1.1.102 64 bit on Windows Server Essentials 2012 R2. Roon 1.1.102 64 bit on Windows 10 Home. My client is connected to the server via gigabit Ethernet.

Audio is configured to output to my Rotel RDD-1580 DAC, which is connected via USB. The DAC is also the default audio playback device in Windows so System Output or the DAC should be the same thing. I have the DAC set to use exclusive mode and Windows configured to allow it to be used in exclusive mode. The default output is set to 16 bit 44.1kHz stereo.

Everything was working fine until I tried to play the new Underworld album as 24 bit 96Khz FLAC files. They do not play at all. An animated EQ appears next to a track, the play button at the bottom changes to a pause button, the waveform of the track appears, but it doesn’t start playing - time doesn’t progress, no sound plays. Trying to play 16 bit 44.1kHz FLACs or MP3s after that, nothing plays at all.

Other players (Groove, Zune, Tidal) all play just fine.

Sometimes if I fiddle with toggling the zones between System Output and the DAC I can get audio to play for 3 seconds or so, but it stops right away. Sometimes “System Output” freaks out like it’s skipping over a long playlist and empties and then the DAC zone plays fine. Very confusing.

As soon as I try to play the Underworld tracks (24 bit 96kHz), I’m broken again and nothing plays. These tracks play fine in Groove.

If I try to play the Underworld tracks through the local PC speakers, I get about 2 seconds of music and then nothing.

Anything I can do here?

What happens when you disable exclusive mode?

Does Rotel provide an ASIO driver for USB for the 1580?

I get the same behavior when exclusive mode is disabled.

I can’t get music to play over the internal speakers any better, though. The internal speakers are “Realtek High Definition Audio.”

The Rotel drivers “enable 24-bit/192kHz audio playback.” I don’t know how to tell if it’s an ASIO driver. (

Roon audio config:!603503&authkey=!ABDgXZwKNCaUR-4&v=3&ithint=photo%2Cpng!603504&authkey=!AGsvoizGXvkPreU&v=3&ithint=photo%2Cpng

Windows config:!603505&authkey=!AKeVU34Z55lWuyI&v=3&ithint=photo%2Cpng!603507&authkey=!AGmDrvo8K2W56ZY&v=3&ithint=photo%2Cpng!603508&authkey=!AL6BBNSUE8aiWMY&v=3&ithint=photo%2Cpng

I’m just trying to play 16-bit/44.1kHz MP3s right now and nothing.

Take care,

A few things to try to troubleshoot this:

  • Try using ASIO drivers if they are available from Rotel.
  • Try a few settings permutations:
    • Rotel, Exlcusive Mode On, Event Driven Mode On
    • Rotel, Exclusive Mode On, Event Driven Mode Off
    • Rotel, Exclusive Mode Off
    • See if Roon can play the 96k file through System Output
  • Try making Rotel not the default output in Windows and see if that improves the situation in Roon.

If you are able to get it working with any of the above, it will tell us something about the problem.

@robdarling, lets reach out to Rotel and see if they are interested in sending us gear so we can troubleshoot in-house + better support their devices in the future.

@mike, if this troubleshooting fails, audiag + support pkg are the next step. 1.2 might impact behavior, but I don’t think it will make the problem disappear outright.

1 Like

Is there a way to tell if the drivers Rotel’s supplied are ASIO drivers?

With the zone set to Rotel and it the default output device:

  • Exclusive Mode Off: no playback of MP3, FLAC 16 or FLAC 24.
  • Exclusive Mode On, Event Driven Mode On: no playback of MP3, FLAC 16 or FLAC 24.
  • Exclusive Mode On, Event Driven Mode Off, no playback of MP3, FLAC 16 or FLAC 24.
  • System Output with Rotel as the default audio device: no playback of MP3, FLAC 16 or FLAC 24.
  • System Output with Realtek as the default audio device: 2-5 seconds of playback of MP3 or FLAC 16 - no playback of FLAC 24.

Everything was working for the first 3 days of my trial when I was only playing MP3s and FLAC 16. Now, nothing works. :confused:


In Roon, ASIO and WASAPI drivers show up separately. ASIO drivers have an [ASIO] suffix in the settings screen. Typically the same driver installer installs both (though we have no first-hand experience with this DAC or its drivers to know that for sure).

Since non-96k playback worked before, it sounds like something is stuck in a bad state. For the tests to be meaningful, the things that worked before need to be working again, otherwise we won’t learn anything useful.

Sometimes it’s the DAC needing a power cycle. Roon may need a restart. Machine may need a reboot. Try those things (in that order) until non-96k files are playing again. Once you’re at that point, then proceed with trying the above.

Whatever you did to get things back into a clean state should be done between each test to make sure there aren’t lingering effects from a previous failure.

The goal here is to learn something about the problem by doing some experiments.

I powered off my whole stack - DAC, Amp, PC.

Coming back, I left the DAC off with the PC configured to use the internal speakers as the default. Roon is playing MP3s through the built-in speakers again. FLAC 16 files play - but not consistently. If they don’t play and I restart Roon sometimes they will. Sometimes I only get playback for a few seconds. Switching between the built-in speakers directly and System Output gets me playback.

I just noticed even with the DAC off that I see “ASIO for C-Media USB Device [ASIO]” which I think is the DAC. If I try to enable it while the DAC is off I see “Failed: Audio Device Not Found.” If the DAC is on, it enables.

I’m getting playback on that device - I tried a FLAC 16 and it played for about 10 seconds and then got “stuck” stuttering. I turned off the DAC and turned it back on and Roon crashed. Here is a stack trace:

Application: Roon.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
at Sooloos.Audio.AsioAudioOutputManager+Native.roon_asio_start(IntPtr, Int32, Int32, SamplesHandler, NaturalEndHandler, Int32)
at Sooloos.Audio.AsioAudioOutputManager+ActivatedOutput+<>c__DisplayClass31+<>c__DisplayClass33.b__30()
at Sooloos.Audio.AsioAudioOutputManager+ActivatedOutput+<>c__DisplayClass31.b__2c()
at Sooloos.Audio.AsioThread+<>c__DisplayClass10.b__f()
at Sooloos.Audio.AsioThread._Dispatch(SendOrPostWrapper ByRef)
at Sooloos.Audio.AsioThread._Go()
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.RunSystem.Threading.ContextCallback, System.Object)
at System.Threading.ThreadHelper.ThreadStart()

Winqual info:
Fault bucket 120436711579, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 120367286802

Problem signature:
P1: Roon.exe
P3: 56b00b86
P4: cmuacwoasio64.dll
P6: 50f8c55d
P7: c0000005
P8: 000000000000511f

Sorry, at this point I don’t know how to get back to a clean state consistently. Even with the DAC off/disconnected it’s not really working right.

Other apps continue to play through both the built in speakers and the DAC fine.

That crash is in the ASIO driver itself (i.e. Rotel’s driver has a bug, and it’s crashing Roon).

@mike, when you’re around, lets grab a log where Joe_Coplen powers everything off, then on, then starts Roon and reproduces the problem immediately before dumping a support package.

Hello @Joe_Coplen,

Are you still having this issue after update to 1.2 ? Let us know and will take a deeper look.