Roon not playing music on any device after some time

Core Machine (Operating system/System info/Roon build number)

Synology DS1018+ ROON Core 1.7 build 571

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection for NAS, PC, Marantz, WiFi (Netgear ORBI RBK50) for SONOS

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Marantz SR7012 / SONOS / PC

Description Of Issue

Roon app starts fine on PC and iPad, but as soon as I want to play anything (both music stored on NAS (ripped CD) and TIDAL), the music just does not start. I tried removing and reinstalling the app on the iPhone without succes. I removed ROON Server from the NAS and reinstalled it which solved the issue for a couple of days, but now the same problem reoccurs. Very frustrating! Roon does not play on ANY device: PC, SONOS, Marantz etc. PC and Marantz are connected through ethernet, SONOS through WiFi.

A post was split to a new topic: Roon not playing music on Bluesound after some time

Hi @Arjen_Pasma,

Has this setup worked for you previously or is this a new setup?

Are you seeing any error messages when you start playback? If so, what does the error message show?


I am not sure what you mean. I have one topic: ROON does not play my music. I have described the issue and provided info about my hardware. Can you please be more specific what you need? I followed the guidelines, provided a description of what is not working and what I have tried and specified my hardware. I have seen others have had this issue from the support database but no real solution has been offered so far.

You do indeed, your reply to my post was in a different topic and addressed to a different user. Rather than cloud that other topic I’ve moved your post into your existing one so all the history is together.

@dylan has requested some specific additional questions.

Hi @Arjen_Pasma,

Do you by any chance have Open vSwitch turned on? See:

Hi Dylan, no error messages. If I hit play nothing happens. I can go back into the menu etc. but it just won’t play anything. The setup worked fine until a few weeks ago. After reinstalling it on my Synology NAS it works fine again for some time (days) and then the problem reoccurs.

One thing that has changed in the recent past is that SONOS has updated their app to SONOS S2. Could SONOS be interfering with the ROON App by any chance?

Hi, where can I find this option?

@Arjen_Pasma -

It should be under your Sonology Web Configuration tool. It’s worth a check, but if you have accidentally turned it on, it could be the cause.


Do you have another PC you can try to temporarily have Roon installed on? This would allow us to confirm if the issue is the QNAP or elsewhere in the chain.

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

I removed ROON from my NAS, deleted all files and directories, deleted Roon App from my PC and iPad, cleaned registry. Then I reinstalled the ROON core on my Synology using the 2020 beta version from Now it is working again for now. If it changes I will let you know.

1 Like

Thanks for the update @Arjen_Pasma!
Do let us know if the reinstall permanently resolved the issue

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.