Roon not playing tracks from internal storage

Core Machine (Operating system/System info/Roon build number)

NUC7i7DNB
OS 1.0 (build 227)/ Roon Version 1.7 (build 667)
8Gb Ram, internal storage Adata sdd SU800, 10500 tracks.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router D-Link DSL 3782.
NUC ROCK connected to switch EE 8switch, all connections ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim NDX2 connected to switch (Ethernet)

Description Of Issue

System worked flawlessly since Jan 2020. Few delays ago I noticed that Roon couldn’t play tracks from internal storage. Message saying: ‘playback interrupted because a track failed to load’. A Rock restart cleared this, but only temporarily. Today I could not play from Internal storage at all. Qobuz streaming works OK.

Can you see the internal storage share if go to it via explorer or finder?

Hi Daniel,

Thank you for replying. Yes, I can see all ROCK’s files including the Storage folder. I can also play play tracks from it via laptop.
The files from storage folder also appear in my Roon library. When I press play, I get the message below:

After this message, I can’t play any of the tracks from the Internal storage. Qobuz is still playing OK. As i mentioned, a ROCK re-start clears the problem, but after few minutes (sometimes after full tracks or albums) it occurs again. My files are ripped in WAV format, and I don’t use any DSP.
I am not sure, but I think the issue appeared after the latest Roon update. There were no other changes in my system.
Thank you
Regards
Adrian

Hello @AdinB, and thanks for your report! Do you have an issue playing to system output of your remotes? Can you send me a screenshot of Settings>Storage?

Hi Nuwriy,
Thank you for your response. I only have one remote, my iPad Air (2019).
Following your message I took the following steps:

  1. Enabled iPad as audio endpoint. The internal storage was not accessible at this point as described in my previous post).
  2. Re-started the ROCK (NUC). This time I’ve started from the NUC box by holding the power button down rather than re-start from the ROCK browser page.
  3. Played tracks from Internal Storage on iPad. No issues.
  4. Switched over to NDX2 main endpoint. To my surprise, playing OK for about one hour… and then it stoped at the end of an album.
    After stopping, both endpoints (iPad & NDX2) would not play. Access to Internal Storage was again locked.
    Here is a screenshot of the Settings/Storage
    Thank you for your help.
    Best regards. Adrian

Hello @AdinB, next time you get in this state, I’d like to have you do the following for the QA team:

  1. Reproduce the issue
  2. Reply here with a timestamp of when the issue began and the name of the track displaying the issue
  3. Try to get out of this state (by reboot)
  4. Try to play the same track again after reboot

Hi Nuwriy,

Played tonight from Internal storage starting at 21.08 (UK time). No issues until 22.48, when played stoped at track and time showed below. (No 13, ironically :-))
Rebooted and started playing at 22.53 from the same track, with no issues so far.
Hope this would give some clues towards finding the issue.
Many thanks
Adrian

Thanks for the timestamps, @AdinB! We’ve enabled diagnostics and will review this will the team. We’ll be in touch with their feedback as soon as we can.

Hello @AdinB, and thanks for your patience while our team investigates this issue. I’d like you to try one more test for me. Could you please place some tracks on a USB and try playing them through Roon? Please let me know if this works without issue and I’ll update the team with your findings.

Hi Nuwriy,
Thank you for you message. During the last week I had no issues with Roon… until last night when playing from internal Storage was not possible. (Same message as reported before about track not loading).
Before re-booting ROCK, I accessed Rock Storage folder on my laptop and tried playing the same track via windows media (windows 10). I could not play any track from Rock Storage with error message appearing on the media player.
Next step, I tried copying the album on a USB stick and this also failed, with the following message:


Next step, I re-booted the Rock and after that everything played OK. I could play any track on Roon and laptop (windows media). I also copied the track and album without any issues and played through Roon without problems.

Roon is still playing from internal Storage ok this morning. I usually play about 90% from Qobuz and sometimes switch to internal Storage. It looks like something, sometimes triggers a fault that stops the tracks loading from internal storage. I couldn’t find a pattern for this behaviour. Luckily, although very annoying, it is fixable with a re-boot. It’s worth mentioning that when the internal Storage becomes inaccessible, Roon continues to play from Qobuz without any issues.

Hope this helps.
Thank you for your support,
Best regards
Adrian

That error suggests you might have a hardware issue. It could be the drive or the drive controller.

Hi Daniel,
You were very right! Last night I had to reboot several times and on last one the internal storage SSD failed and deleted all my music in the process!! Luckily I have backups.
I have tried to re-format the SSD through the Rock web interface, but this failed with an error ‘exitcode 6’

I removed the SSD and replaced it with USB Storage, from which Roon plays without an issue so far. I think I’ll stick to USB Storage rather than internal for a while, hopefully this solved the problem.

Many thanks for help.
Best regards
Adrian

2 Likes

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.