Roon not recognising Behringer X32 as audio device

Core Machine (Operating system/System info/Roon build number)

NUC 8i7BEH running ROCK OS Version 1.0 (build 175) stable
Roon Server Software Version 1.6 (build 416) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NUC connected to netgear router via ethernet. Windows 10 desktop i5 16GB ram desktop connected to same router via ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

I have a Behringer X32 mixing console. It has an inbuilt DAC and has analog speakers connected. It is how I listen to music on my windows 10 PC. It is connected to my PC via USB. It has a Behringer ASIO driver.

Description Of Issue

Windows 10 PC sound control panel recognises the Behringer X32 as an audio playback device. I am able to play back music from windows PC using Itunes to Behringer X32.

The problem is that Roon does not recognise the Behringer X32 as an audio device. The Behringer X32 is not shown at all in the Roon settings>audio tab. I am unable to play music through the Behringer X32 using Roon.

What options for the PC does Roon offer you?

None. It shows that there are no devices connected direct to the PC.

A quick read reveals this to be a 32 channel bi directional device. I imagine that requires quite specific support provided by a Windows driver but not recognised in Roon. Let’s see what the support team have to say.

Behringer X32 is an audio mixer … how it works with Roon. Roon is to be an input signal?

Hi @Steven_Booker,

This is certainly strange, there are no audio devices whatsoever, including “System Output”? Can you please share a screenshotof your Settings -> Audio tab if so?

The reason why I ask this - usually when you don’t see any audio devices on that page, it indicates that there is some kind of firewall blocking Roon from performing the device discovery.

I would double check to make sure you have Roon.exe and RAATServer.exe added to your Windows Firewall by using these instructions and also to any additional firewalls you may have on that PC.

Roon.exe and RAATServer.exe can be found by navigating to the Database Location/Application folder path.

Thank you for your replies.
@Maxxim_M Roon is to be output signal for music playback

@noris Please see screenshots attached. Roon.exe and RAAT both approved in firewall for private networks.



Last time I saw a report about an empty device list, a simple reboot of the core was the solution.

@BlackJack Thank you. I have rebooted the NUC and resert the Core OS - but am still not seeing the Behringer X32 as an audio device in Roon >Setup>Audio

If you unplug the x32 and reboot does system output appear?

There is certainly something strange going on because even the other sound card functions present in Windows aren’t showing up in Roon.

@ Ged Hickman - that is a good question. I unplugged the X32 from the PC, rebooted the PC and rebooted the NUC. My windows 10 audio devices control panel is showing the PC on board sound card as an active audio playback device but it is not listed as a device in Roon>setup>audio. Roon is showing that there are no audio devices connected to this computer.

So I then plugged the X32 back in and closed / restarted roon but the X32 is still not showing in Roon.

It looks like the following statement on the Roon FAQ is incorrect: “Any audio devices recognized by the OS will be recognized by Roon, from Built-in Sound to PCI Soundcards to USB DACs”.

Hi Noris, I tried your suggestions but they did not solve the issue. Do you have any further suggestions? Thank you.

Because you already checked the Windows firewall, do you have by any chance another software with integrated firewall on your system?

If you have an unmanaged switch available, even an old fast ethernet switch will do, you could connect the NUC/ROCK and your PC to that switch (and then the switch to the router of course) instead of the router to find out if maybe the router is blocking some traffic.

There’s definitely something strange going on here, as it seems you’re able to connect to the core fine but even the core’s audio devices don’t show up in the screenshot of your Settings|Audio tab.

1 Like

Hi @Steven_Booker,

It looks like some kind of firewall is blocking Roon from operating properly, you should definitely be seeing at least “System Output” listed in Roon Settings -> Audio. I would go ahead and re-add Roon.exe and RAATServer.exe to your Windows Firewall, it looks like it’s there but sometimes Windows Updates can cause issues with the firewall and re-adding it for both Public and Private would be a good step.

Other than that, do you have any other types of firewalls or antivirus apps installed on that PC? McAFee, AVG, Kasperksy, ect? These kinds of antivirus apps also often have their own firewall and you will need to set the same exceptions there as well (or if in doubt if it’s the offending cause, you can try temporarily disabling it).

Each time this behaviour shows it seems to be something to do with firewalls or the like.

Thanks to everyone who tried to help with this. I found the problem was that for some reason the windows firewall was set to public connection even though it was a private network. Deleting and re-adding roon.exe and raatserver.exe as public and private rules in firewall + PC reboot + core reboot did the trick.


Hi @Steven_Booker,

Thanks for the update here and glad to hear that the issue is resolved!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.