Roon not recognising iTunes library

(Neil Perryman) #1

Core Machine (Operating system/System info/Roon build number)
I’ve Roon for about 18 months and a Nucleus for about 12 months I also have my music folders and files on an iMac.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Initially I had a few problems getting everything to work together but it was working well.

However about 2 weeks ago the Nucleus stopped acknowledging the music in my iTunes library.

Has any got any ideas?

(Dylan Caudill) #3

Hi @Neil_Perryman,

Was there any change to your setup around this time? Was there any change to your networking gear, or possibly an update on the Mac?

Can you share a screenshot of Settings > Storage?

(Neil Perryman) #4

Hi Dylan,
Here are a couple of screen shots of my situation, the top one is of
the Storage messages, the 2nd one if from iTunes and where, apparently, my
iTunes music folder is located. I’ve tried to cut and paste this location to the “Add Folder” - “New Folder” in Roon storage but again Roon won’t acknowledge it.
Any help would be appreciated.
Best,
Neil.

(Neil Perryman) #5

Hi again Dylan, Here, also, is a screen shots of when I tried to cut and paste the
iTune Media folder location.

#6

Are you sure that File Sharing is turned on for that folder in the Sharing extension? Are you sure that your DNS still thinks that iMac is named “IMAC-2.local”? I have found using the IP address in place of the name works better.

(Dylan Caudill) #7

Hi @Neil_Perryman,

Based on the first screenshot it appears that Roon isn’t able to access the folder where the iTunes library is located.

I think that moving forward here, the best option is to make sure that the folder on your mac is properly shared and entered into Roon fresh.

First, before making any changes, I recommend making a backup of your Roon database.

Next, follow the instructions in this article to share the Music folder and add it to Roon.

Let me know if you have any questions during this process.

(Neil Perryman) #8

Hi Dylan, I did a Nucleus reboot and that seems to have righted everything,
go figure! Thanks for your help and suggestions, appreciated.
Best, Neil.

(system) closed #9

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.