Roon not recognizing my Mytek Brooklyn ASIO Driver [Resolved]

I keep having issues with Roon not recognizing my Mytek Brooklyn ASIO driver. I have uninstalled Roon and reinstalled it and it will work for a bit. If I restart my computer and restart Roon, it doesn’t recognize my DAC/driver again. Any idea of why this is happening?

I have the same problem. What PC/Mac you are using ? I’m using Mac Mini with Roon core and connect to Mytek Brooklyn via USB. Everytime I plug out the USB cable and plug it back it the Mytek doesn’t show up in Roon Audio output device.

Did this issue ever get resolved? I still can’t get Roon to recognize my Mytek Brooklyn.

All (@James_Holland / @Kyle_Vuong / @patpend) ----- Thank you for the feedback and my sincere apologies for the troubles here.

Moving forward, to help aide in our evaluation of this behavior you’re reporting, may I very kindly ask each of you to please provide a brief but accurate description of your current setups, using this link as a guide. The more detail you can provide us, especially in regard to the device hosting your core, the better.


Hi Eric,
Below is the information as you requested:

Set up:
Mac Mini (late 2012, 2.5ghz, 16gb ram, 500gb SSD) with Roon Core and music library (around 800 albums)
Mytek Brooklyn DAC
Leben CS600 integrated amp
Harbeth SHL5+ speakers
Curious USB cable

Firmware Version:
Roon running latest version
Mytek Brooklyn running latest version
Mac Mini running Sierra latest update

Mac Mini to router via ethernet
Mac Mini to Mytek Brooklyn via Curious USB cable

First time plug in the USB cable from Mac mini to Mytek Brooklyn, it shows up in Roon straight away and working fine.
After that I plug out the USB cable and plug it back in, the Mytek Brooklyn is not showing up in Roon, therefore no output device.
Try turning off and on the Mytek Brooklyn still does not solve the problem.

Hi @Kyle_Vuong — Thank you for touching base with me and providing the requested feedback!

Moving forward, I would like to take a look at your logs to see if we can determine what is causing this behavior with the Mytek Brooklyn. Please reproduce the issue, note the time when the observation(s) is made (very important), and then use the instructions found here to upload us a set of your Roon and RAATServer logs.


FYI: The key to this exercise will be to reproduce the reported behavior and based on your last comment (“Try turning off and on the Mytek Brooklyn still does not solve the problem.”) it sounds like the DAC may not be, being discovered by the application at all currently. Please verify if that is indeed the case.

Hi Eric,
Please find my Logs in below link:
Today I found out one of the strangest thing: I plug in the Curious USB Cable from Mac Mini to Mytek Brooklyn DAC and it doesn’t show up in Roon, then I use a standard cheap USB cable and the Mytek shows up in Roon! (the Curious cable is 10 times more expensive)
So currently I’m using the standard cable and everything works fine. I’m not sure if it’s because of the Curious USB Cable or not. However it works with all previous DACs that I got.

Hi @Kyle_Vuong ---- Thank you for the follow up, confirming that the logs have been received.

Moving forward, it sounds like you may have identified the culprit here, being as the Brooklyn is having no issues with the “standard cheap” USB cable. I know you mentioned that the Curious USB cable had worked with all previous DACs but since making this observations have you tried testing the Curious USB cable again with another device to confirm?


Hi Eric,
Following up with the problem, recently I have sent the Curious cable back to the supplier and they said it’s defected, which is the reason why it’s not working with the Mytek Brooklyn.
They have sent me back a new cable and now it’s working properly. I have just added a Micro Rendu to the system and it sounds amazing… Thank you for your help anyway.

1 Like