Roon not recognizing networked Bluesound devices

When I first downloaded the software I was able to find my Bluesound equipment in settings/audio and use the Roon program. However, the networked items have since disappeared and I am unable to relocate them in Roon. I can use the Bluos app where the equipment is recognized. I am using a windows 10 64 bit machine.

Restart your router and Bluesound devices is always a good idea. Restarting the Roon core also.

1 Like

It’s funny, after doing the same thing a half dozen times it finally worked albeit not without other challenging situations. I’ve had to continue the process to re-sync the endpoints.

1 Like

Hi @Matthew_Pincus ---- Thank you for the report and sorry to hear of the troubles. I wanted to check in to see if you require any more assistance. Please let me know and a member of the support team will be glad to help.


Good morning, Thanks Eric. I have a Bluesound Node 2 and a Bluesound Pulse that I am streaming to. Somehow they are becoming a zone that I cannot ungroup. Sometimes they cut out and when they come back online they are no longer synced. I have unplugged and rebooted these two devices several times. When I connect the Node, the Roon app recognizes it, but when I plug the Pulse in, the two devices automatically group and essentially become one unit that I cannot ungroup.

Are they grouped within your Bluos app?

It seems that I’m going through an endless cycle. They were grouped in Bluos. I ungrouped them and then I had to reboot them to make them visible in Roon again. Right now all seems to work fine. I just hope that nothing changes after I close a program/shut down the computer. I’ve had other issues including constant buffering despite a strong signal which is making me think that I have a weak link somewhere. Possibly one of the Bluesound devices.

I hard wire my Bluesound devices because I can, so don’t know about wireless issues. My only wireless is control from iPad. Glad it’s working now though.

I might need to hardwire these devices. One I can hardwire from an extender, the Node will be more challenging. Unfortunately I only got a couple songs in before I experienced sync issues again. A simple ungrouping and regrouping didn’t do the trick so I think another reboot is coming.

The bizarre thing is that the music both speeds up and slows down and this is when the devices become unsynced.

There is a known sync issue here that is being worked on. Syncing in Blue Os is a temp get around. I expect an update to solve it soon.

I do like Roon but I cannot fully immerse myself in the listening part. Bluesound has been Roon ready for a little over a year now. Have you been dealing with this all along?

I only have Bluesound in secondary zones so it’s not critical for me. I hope it’s sorted by the summer though when I use Bluesound more.

3 posts were split to a new topic: Not all Bluesound devices are appearing in Roon