Roon not sampling above 96kHz on Peachtree Audio nova150 via USB

Core Machine (Operating system/System info/Roon build number)

Windows 10/Roon Version 1.8/Build 764

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

USB Direct to Amp

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Peachtree Audio nova150 amplifier

Description Of Issue

Hello all,

I have an issue I just noticed yesterday, and I’m not sure if it is a Roon issue or something to do with the driver for my amp. I noticed while playing some 24/192 files yesterday that the sample rate was converting from 192 to 96kHz. The DAC in my nova150 is supposed to sample up to 384 kHz. I noticed this when I saw the signal path indicator was a small green circle rather than the bright purple star. This is also happening with the DSD filed I have. I’m not sure if this has always been the case, my library is mostly at 48 or 96kHz.

I reinstalled the driver for the nova150. Looking at the nova150 control panel on my machine, it says that it is sampling at 96 for any files 96 and above. I went to the audio settings, and noticed that in the max sample rate (PCM) dropdown, i do not have an option for 192, only 48 or 96. My question is, does that mean Roon thinks the DAC is only capable of 96kHz or below? If that is the case, is this an issue with the driver, or Roon?

Any help is greatly appreciated.


Sounds like it’s only using USB audio 1 spec on the port which is max 96/24. So likely a windows driver issue as Roon will only support what it gets told the DAC supports.

1 Like

Hmm, Peachtree only had one driver option for my amp on their driver page. Looks like I’ll be sending them an email. Thanks, @CrystalGipsy

It doesnt mention anything about 192/24 for your amp but does for others on their website so I think this seems to be limited to 96/24

It’s buried in the specs on the page for this model. It’s also supposed to do DSD up to 5.6MHz. It was a big selling point for me.


I did have a windows update recently, and though I’m not 100% sure I seem to recall Roon playing 192 before then. Like I said, i had not noticed this until yesterday.

If reach out to them. Check in audio settings in Windows to see what max rate you can set in their.

@Rugby Daniel may be able to assist?


I do have a Peachtree Nova 300, I am using the Peachtree ASIO driver from a windows pc plugged directly into the amp via usb. I am getting 384 PCM and 256 dsd.

I don’t have access at the moment to check the asio settings as the spouse is currently watching thier nightly tv. But, I’ll check it out tomorrow morning as it is my work from home day.


Thanks, @Rugby.

On the back of the unit, there is a USB 1.0 / USB 2.0 select button.

  1. Make sure you are using the USB B input.
  2. Make sure you have the USB button engaged and set to USB 2.0

Excerpt from Manual:

And here is me playing 384

And for good measure DSD256


Thanks a million, @Rugby. I have never noticed that button, and somehow must have bumped it. That’s a mystery for another day. Anyway, that fixed this issue, 192 and DSD are playing fine now. Thanks again!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.