Roon not showing genre images that have been used for other genres [Fixed]

On the main genres page a lot of the genres don’t have images even though there is a banner image on that genre’s overview page. It is like this for anyone else? I would like to know if I am the only one having this issue.

For example: In my collection I have the genre “Avant-Garde Pop”. It has no image on the genres page but when I click on it there is a large image of Billie Eilish, so why is there no image in that brick on the genres page?

Hi @AnimalOnDrums

I’ve passed this along to the team to investigate further. Are you seeing this occur on all remote devices?

Thanks for passing this along. Yes, this appears the same on all remotes.
While trying to figure all this out I encountered a number of other issues related to this and have posted them to keep track of them. This issue has led to many other issues. Please read the other threads I started like What is going on with Genres?. I didn’t want to just pile everything into one thread.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

Hello @AnimalOnDrums ,

I wanted to touch base with some good news, which is that our technical team has been able to reproduce this behavior and we’ve opened up a bug report with our developers.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved.

Thanks again for the report!

1 Like

@noris, sorry for the belated response. Thank you for updating me on this issue. I appreciate it!

1 Like

Yesterday I turned the option to use my Genres back on to see if there were a bunch of genres with missing images. The issue was better than when 1.8 was first launched, but there will still a lot of Genres that were missing images even though they had an image when I clicked on them. I still cannot figure out why some genres show up as blank tiles even though they have images on their main pages while other genres use their images just fine. Any news on this from @support yet?
But moving on, Just now I imported some new albums and a new genre with a blank tile popped up on the genres page. I clicked on it and it caused my iMac remote to crash…Every time I tried to reopen it, it immediately crashes before it can fully start. I tried restarting everything including core, but it did not fix the issue. I now finally have Roon up and running again after completely wiping it from my Mac and installing it. This exact same thing happened when I first upgraded to 1.8.
After a couple of updates why did this have to happen again? I know things take a while but why has this not been fixed yet? It seems like an important bug to want to get fixed. So far I have a new list of about 10-15 genres that I cant use because they appear as blank tiles and will cause a crash. I was told last time this issue is being worked on so is there any information about this yet? I would like to be able to use my own genres but I still can’t.


4 posts were split to a new topic: Genre getting thumbnail but no large image displayed

Hi @AnimalOnDrums ,

I see that the ticket regarding this issue has been resolved, so perhaps something else is going on on your end.

Can you please use these instructions to access your Roon logs and upload a set here?


Hi @noris ,

This issue is definitely not resolved so I don’t know what it is marked as such. I did a completely new erase and installation on my core and my remote after noticing this and it didn’t help anything. Just mentioning it in case it helps. Logs will be uploaded shortly

Hi @AnimalOnDrums ,

This original issue you reported of images failing to appear when used elsewhere should have been fixed in a recent Roon release, it looks like the symptoms are a bit different now, so let’s continue further troubleshooting here: