Roon not working on laptop as control point

Core Machine : NUC i3 Rock latest version

Network Details : Core is connected by ethernet

Audio Devices : older Toshiba i3 laptop running Windows 10 fully updated on a relatively new Samsung SSD

Description of Issue : I am trying to use the laptop strictly as a control point but the Roon APP will no longer run on the laptop. After initial setup it was working pretty well for a while (coupe of months with regular connection issues). Then last week the Roon APP would no longer start. When starting the APP there is a long pause then 2 windows very briefly flash on the screen and then the APP crashes. The first window is white and appears to be blank. The second window also appears to be blank except for a big red “X” drawn diagonally from corner to corner. Immediately after the second window flashes the APP crashes

I have tried restarting Roon Core several times, I have uninstalled and reinstalled Roon on the laptop several times. I have even connected the laptop to my router via ethernet to see if that would work. The laptop has no trouble connecting to my network by wifi and it has no problems running any other programs.

Do you have any suggestions?

Try updating your video drivers with drivers from the manufacturer.

1 Like

Thanks for your suggestion. It seems to have worked! I never would have thought of that. Like I said it is an old laptop and the latest drivers were from 2016 but I installed them and Roon is now running. I can only think that a Windows update must have messed them up. Thanks Again!!!


Unfortunately it looks like the solution was short lived. Roon is once again failing to open on my laptop. I reinstalled the video drivers but this time it didn’t fix the problem.

Does anyone have any other suggestions?

Frustration Vent:
I have never had as much trouble with any other software program, ever, as I have had with Roon. I love the functionality but this is rapidly becoming far more trouble than it is work. I have already purchased a new NUC to run the core and now it looks like I need a new laptop just to function as a control point. I am not sure spending $2,000 for new hardware just to run a single piece of software makes since. I tried Roon after using LMS for years and I never had these kinds of problems with LMS.

Hi james,

What anti virus are you using? Another user had similar issues here:

Thanks for the suggestion. I don’t use any anti virus programs other than the one build into Windows. It’s possible that is the problem and I will investigate that. However, I have a new twist. I removed the SSD and reinstalled the original HDD. It had been out of the laptop for a couple of months so Windows is not up to date. I installed Roon on the HDD and it started right up without problem. I am just guessing here but I suspect that a recent update to Windows is causing the problem and it could be in the virus protection.

1 Like

The most recent Windows update has been known to have issues affecting a lot of different softwares, mostly games, although Roon is built using the same video tech as games, so… Maybe. If it has not been a long time, you might be able to remove the latest Windows Update and verify that that was the issue.

I tried turning off the Windows virus protection and that had no affect. Then I got aggresive and did a clean install of Windows 10. The instillation media was dated Nov 2020. Windows did not do an update as part of the installation. I just installed Roon, made no other changes to Windows at all, and it started right up. I am going to run it like this for awhile and monitor any changes closely. When (if) if fails hopefully that will provide some insight into what is happening.

Thanks again for you help and suggestions.

1 Like

I found out that Win 10 upgrade item KB4033361 made this mess. Uninstall just this one and Roon will work fine again

I did try to warn folk but nobody read it :sob:


Thanks for the info, very helpful!!! I’ll be sure to watch for that update and prevent it.


Sorry, clearly I wasn’t paying close enough attention. :frowning:

It happened last week if you take auto updates

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.