Roon now my only app that can’t cast to Chromecast speakers; the progress bar doesn’t move at all

My Chromecast speakers now work fine with other Android apps (mytuner pro for the radio and MediaMonkey and VLC to play music files on my phone). However, they no longer work with Roon: Roon sees them, but, when I play something, the little histograms to the left of the song name start moving, but the progress bar doesn’t and stays still. If I change the volume, I hear a beep on the speakers (as configured in google home), so there is some kind of connection, but no sound.

Any thoughts on how to troubleshoot this?

So far I have switched the speakers off and on and rebooted the Roon core. I haven’t (yet) reset the speaker as I did that only a few days ago! ( Chromecast vs Sonos vs others: which is the most stable / least buggy? (not asking about audio quality) ). I reset them because they weren’t working with any app; now it’s only Roon that isn’t working.

I have the Roon Core running 1.6 on a Synology DS918+ NAS and use two Androids (a Huawei P20 Pro phone and a Samsung Galaxy Tab s2 8’’) as remote controls, to play music on two Riva Arena Chromecast speakers; the speakers are grouped into one group, are both with clear line of sight to the wifi router and there’s excellent signal in both spots. The NAS is connected to the router via an Ethernet cable. I have tried playing to speaker 1 only, to speaker 2 only, and to the group comprising both - nothing.

Does roon play ok to the phones when you use them as endpoints?

Yes, I forgot to mention it, but I have tried that. It plays OK (and the progress bar moves as it should) when the phone or the tablet is the endpoint; also when the phone is the endpoint but it’s connected to a pair of bluetooth headphones.

Hello @YetAnotherLondoner,

Do you by any chance have Open VSwitch enabled on your Synology? I have sometimes seen this setting cause similar behavior so I would check this first.


I don’t have any virtual machine set up on the Synology, so I suppose no VSwitch.

Yesterday I uninstalled and reinstalled Roon from both Androids - nothing.

This morning, I try again from the phone - nothing (same behaviour: the progress bar doesn’t move).

I try again after 10 minutes: it plays fine!

What the… ? These speakers are proving more temperamental than a toddler. I’m seriously considering returning them and replacing them with Sonos. I seem to be spending more time troubleshooting and resetting them, than actually listening to them.

I’ve got an actual chromecast audio and if I switch it off its really hard to get it recognised again so I have to leave it on all the time.

Hello @YetAnotherLondoner,

Does this issue only happen with the Chromecast speakers or for other endpoints as well? I wonder if you might have some multicast issues, can you please take a look over this guide and let me know if your setup matches our recommendations?


It happens only with my Chromecast speakers. The other endpoints I have tried are the Huawei P20 phone, the Samsung Galaxy Tab S2 8’’, a Dell laptop and a desktop PC , and I can play music just fine from all of these. The Huawei could play music even when it couldn’t cast it to the Chromecast speakers.

I have read the guide you linked and enabled ‘multicast routing’ on my Asus router, hoping it will help.

I would have never though of that because the setting is in the IPTV tab, and I don’t have any IPTV service enabled (my broadbrand provider offers it but I’m not interested).

The Chromecast speakers support only 2.4Ghz, but so does Sonos anyway.

Hi @YetAnotherLondoner

Roon does use multicast even though it is primarily associated with IPTV, multicast is useful for device discovery and if multicast is failing it could explain the issue at hand so do let me know if it helps here.


Yesterday I enabled multicast routing on the Asus router. This morning it wasn’t working, again. I was using my Huawei phone and trying to play on a Google group of two Chromecast speakers; again, the progress bar stayed still and no music was played.

The Mytuner radio app played music to the same Chromecast group just fine.

So I checked Roon’s settings on the phone. Roon listed the Chromecast group twice (under settings – audio), but both groups were shown with the same IP. Has this happened to anyone else? With other phones, too? Shall I file a tech support ticket or is this post enough?

Playing to each of the speaker worked fine, but I could play to only one of the two groups. Disabling one of the groups meant I couldn’t cast to the other one! What the … ?

I went back to the Mytuner radio app to doublecheck: it listed the group only once, not twice.

I have no idea if the bug is in Roon, in Huawei, in Chromecast or what, but it’s quite annoying!

Hello @YetAnotherLondoner,

Thanks for letting me know that the Chromecast was listed twice. I have seen as similar report to yours so I have notified the QA team of this behavior and they are currently trying to reproduce this in-hous, this thread works just fine for the report.

I will be sure to let you know once I hear any updates from QA but you may want to try setting your Chromecast devices to having IP address reservation in your router and see if that helps.


Thanks. May I ask if this has ever happened with Sonos, too?

Hi @YetAnotherLondoner,

I have only seen reports for this behavior on Chromecast devices and not Sonos devices. If you experience this issue with Sonos let me know and we can take a look at what’s going on.