Roon NUC cant see SSD

That was my error. NUC 10.
corrected my original above.

Ah, OK - you had me worried there for a moment… :slightly_smiling_face:

Back to your question - you seem to think that the external USB drive will show up on the Web Administration page? It doesn’t - only an internal SATA drive in a NUC will show up there.

ha, sorry. not sure why I had 11 in my head.

I know it won’t show up on the Admin page, just adding that it worked. it was also visible in Finder.
When installed the new internal 1TB SSD isn’t showing up on either the Admin page or Finder.

I suspect I might have a bad SSD but that’s rare so I’m trying to double verify. I just ditched my old drives so I don’t have another to test with.

Maybe I should start a new thread but, for now:
I exchanged the
WD Blue 1TB SSD
for a
WD Blue 1TB HDD.
Still is not showing up on the ROCK Admin Page.


I do have an old NAS header that I plugged the first SSD into, it did not show up in Finder.
I plugged the new HDD into it and it was visible in Finder.

Storage in this case is a placeholder. If the internal SSD/HDD was recognised, it would show as Storage/InternalStorage and if an external USB drive was attached, it would show up as Storage/<some long name>

Perhaps you could use the Mac to re-format the drive (as exFAT), and then try it in the NUC?

Did that and then thought maybe the NAS header might have changed how it was formatted so I found a 2.5 USB enclosure, installed the drive in that and ran Repair, then formatted in exFAT. Still no joy on the internal HDD.
I’m wondering if there is a BIOS quirk. Searching Intel’s NUC support it usually points to ‘update bios’ as the solution.

Reconnected the USB-C external drive, it is visible and working.

There is a BIOS setting to disable the SATA port in the NUC I believe. Check it out here:

https://www.intel.com/content/www/us/en/support/articles/000006028/intel-nuc.html

1 Like

What board are you using John. I’ve just built a NUC8v7PNB into a Akasa Plato as I had the board lying around. It’s a bit of a faff around bios settings as it needs 0040 before you can install the latest 0047. Normally Load Optimised Defaults and a Save and Exit should see you good. Under Onboard settings you should be able to see both the M.2 and onboard SATA controller enabled in the Bios.

NUC10i7FNH1 David.
I just checked the BIOS: Advanced - Storage - SATA Controller - Enabled.
I left the HDD installed overnight hoping the NUC would give up and recognize it. : )
Still no joy.


The drive details should pop up there like the M.2 drive does. Have you got and tried another SATA cable. Is it running the latest bios and is it
mentioned anywhere in the BIOS Release Notes (you’ll find these on the Intel website where the BIOS download is).

Oops, posted from the wrong account :wink: Ruling out really daft things, you have the SATA Power cable plugged in and the right way around right ?

I’ll double check the bios.
I have a USB-SATA cable on order but I’ll dig around the house to see if I can find a SATA cable.

Keep us updated. From your bios screen shot earlier, it’s showing the SATA port is enabled, but it can’t see anything hanging off of it. You can see that from the [Not Installed] message, that line should tell you [WD Blue SATA SSD] or similar.

1 Like

This morning I re-seated the SATA cable. I was optimistic here because it didn’t appear to be fully seated.

Updated the BIOS to the latest: 0057

Still not showing an installed HDD.

Bummer, I trust you have still got a replacement SATA cable on order. It’s rare, but in the few years we’ve been the service center for Roon I think I can remember 3 or 4 faulty SATA cables. If you have any old SATA drive hanging around cd/hdd you can test to see if that identifies itself on your current cable. If a new cable doesn’t sort it then oddly odd. I assume you are set to Legacy Boot and not UEFI if you are running ROCK on it.

Worth pinging the question to WD Support as well. There might be a drive firmware update or something we are missing. I doubt it, but it’s always worth attacking on multiple fronts. Very odd behaviour.

Also, worth trying the old flatten the CMOS trick as well, it means popping the board out again, disconnecting the CMOS battery on the bottom, leave it off overnight. Re-attach and re-fit the next day and do an F9 to load optimal settings and see where you go from there. I’ll do a whole post in one go one day :wink:

So, after ALL of that I found the FFC ribbon was installed wrong. From the factory it was backwards in the connector.
Here is the resource to verify. FFC SATA

An huge “Thank You” to everyone for the help.

4 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.