Roon Nucleus + Auralic Vega G2 - tracks sounds as whitenoise distortion

I’ve Original Nucleus with internal SSD. Lately, I’ve noticed during random play over 12 hours. Some tracks sounds as white noise distortion. Sometimes if I skiped the track, it stops. And ok, if I play the same track again. Now, it won’t stop unless I reboot Nucleus.
Has anyone experienced this and reasons why?

Hi @Ayodele_Akande,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does this issue occur for all endpoints?

Is it always specific media that seems to cause this issue or does the content that is playing not matter?

Main System: Gryphon Diablo 300, Auralic Vega G2, Roon Nucleus installed 2T SSD, Monitor Audio PL300 mk 2. Clearaudio TT, Tape decks etc. All power via Isotek power conditional.

Connection: USB from Nucleus to Auralic.

Network: BT Router into Netgear 8 Switch - Chord ethernet cables. All connections to system are hard wire. (Wifi only for control app).

Endpoints: Vega G2, Raspberry Pi/Hifiberry HAT, Bluesound Soundbar. Problem exist on Vega G2 because i play it virtually all the time.

I can conclude it happens whenever Roon Radio is cueing up songs/tracks. It happens both on my music and Qobuz. Never happen when I’m selecting different playlists or when i cue up sets of albums,

Other information: Additional to stock psu, I have Teddy Pardo psu and MCRU psu. The problem exist on all them.

Also, it can happen every week or sometimes once a month - i suppose it depends on my listening habits.


Hi @Ayodele_Akande,

Does this issue only happen when you’re playing tracks of one sample rate and then switch to a different sample rate? Any patterns to the file format - for example it only occurs when playing MQA or MP3s and not FLAC?

What does your Signal Path look like when this issue occurs? Also, would you be able to record a short video or audio sample that shows the issue?

No difference on sample rate -i think.
All my files should be FLAC - i do not have MP3 or MQA

Signal Path? i don’t understand.

By the way, the distortion is either pure white noise or tracks playing distorted.

In the 2 days - it is affected tracks are from Qobuz.

Ive recorded the sound but how do i attach files to this thread

Hi @Ayodele_Akande,

Yes, please share a screenshot of your Signal Path when this issue occurs, you can find the signal path by clicking on the “star” icon next to the track name, example:

Can you upload the recording to Dropbox / Google Drive / Your preferred upload service and paste a link to it here?

practically un playable now. Used to be occasional. However, ive reverted to listening via Ethernet cable streaming to Vega G2.

Hi @Ayodele_Akande,

I’ve tried to open the links you’ve posted, but it appears I need access.
Once you have granted access, please let me know and I’ll re-check.

Permission given to open the files

Hi @Ayodele_Akande,

Thanks for sending that sample video over. I have been discussing this with our hardware team and they have confirmed that this is a known issue for the Auralic Vega G2 on the USB input. We would suggest that you use Roon Ready for communication or reach out directly to Auralic to troubleshoot the USB input further.

Hi Noris,
Thanks, i will contact Auralic…
But, by “use Roon Ready for communication”, you mean by streaming through ethernet cable?.

Hello @Ayodele_Akande,

Yes, in this scenario “Roon Ready” = Ethernet streaming.


Here is a reply from a member on Auralic community:

I had what I believe is this identical issue and I heard that exact white noise sound on occasion when I was feeding the VEGA G2’s USB input with my Melco N1Z/1 after I added a LEO GX Master Clock to the system.

With the assistance of @Xuanqian, it was determined that the likely cause was the Melco switching sampling rates (e.g., 16/44.1k to 24/96k) faster than than the VEGA G2/LEO GX combo could react.

The problem was solved by changing a setting in the Melco called “USB-DAC: Precision Start Latency.” The Melco had been set at 1.5 seconds. I adjusted the Melco’s Precision Start Latency setting from 1.5 seconds to 3.0 seconds, and the static noise problem seemed to disappear.

(Shortly thereafter, I reconfigured the system so that the Melco feeds the VEGA G2 via Ethernet, and the VEGA G2’s USB input is now fed via an ARIES G2.)

So, if your Roon Nucleus (or Roon itself) has a setting analogous to the Melco’s “Precision Start Latency,” try adjusting it to something in the vicinity of 3.0 seconds.

Good luck, and please let us know if/when the issue resolves.

From Auralic CEO;

VEGA G2 was not designed to connect to Roon server via USB input, it should use network input working as RoonReady endpoint.

I guess this conclude/resolve the problem. I found it quite annoying though but i cant do anything about it.

Thank you for your support and prompt responses.

Hi @Ayodele_Akande,

Thanks for the follow-up here. It looks like Auralic provided the answer regarding this issue and in this case, you should use the network input for the connection to the VEGA. I’m marking this thread as [solved], but f you have any other Roon issues, do let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.