Roon Nucleus/BlueSound integration

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus (Build 1.7-571) controlled by iPhone XS, iPad or a MacBook Pro (Build 1.7-571)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Synology RT2600ac (SRM 1.2.3-8017 Update 4) - ethernet to Roon Nucleus, WiFi to the BlueSound devices

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound: Node 2, Node 2i, Pulse Flex 2, Pulse Flex 2i; Chord Qutest - USB from Roon Nucleus

Description Of Issue

I’ve had this setup for a couple years and using Roon to control and group the BlueSOUND devices has worked pretty much flawlessly. However, since the last Roon and BlueSound updates, the vast majority of the time that I try to control or group the BlueSound devices, I get a message in orange saying “TIDAL media is loading slowly. This may indicate a networking or connectivity problem”. When I try to play a file from the Nucleus it says something similar: “An audio file is loading slowly. This may indicate a networking or connectivity problem”. This does not occur all of the time, but most of the time when I try to either control or group the Bluesound devices from Roon. Playing files and streaming from only the Roon Nucleus works fine. Using the BluOS app controls and groups the BlueSound devices just fine. I just did a Speedtest on the internet, and a download speed of 140 Mbps and an upload speed of 6 Mbps were reported. All other uses of the internet/intranet appear to be fine.


2 posts were split to a new topic: Problem with Bluesound and Roon

Hi @Steve_Kerns,

Just to confirm, playing to the Chord never exhibits this issue, correct? Does the same behavior occur if you connect the Bluesound via Ethernet?

Yes, the Roon Nucleus->Chord works fine. I will try a BlueSound device via ethernet tomorrow morning


I grouped the BlueSound Node 2i connected to the network via ethernet to the Nucleus a half dozen times and it worked each time.

1 Like

Hi @Steve_Kerns,

Since this issue does not occur when using Ethernet, we would suggest to keep using Ethernet-based communication with your Node 2i. It is possible that you have WiFi channel congestion, this can happen when there are too many routers/access points trying to use the same wireless channels for communication.

Using ethernet is not an option. As you can see from my original post, I have 4 Bluesound devices and none are located in a place where I can use ethernet. I have used Roon+Bluesound for several years, and I have had this exact same setup since November 2018, and nothing like this has ever occurred until the last update.

I’ll also add that right now, I have the house to myself - no wife or daughters at the moment. I looked at the “Traffic Control” on the Synology Router, and the only devices connect to the wireless network are my MacBook, iPhone, iPad, a security camera, and my 4 BlueSound devices, so I don’t think network congestion is the issue.

I’m seeing other posts on this forum that indicate that this problem has been replicated by your experts and that you are working on a solution. I’m a looking forward to seeing this fixed in the very near future.

Could you link posts that you reference so that others might refer to them.

1 Like

My thread was split a few days ago. I think this is the link.

1 Like

Mine was one of them.

Is there an update from the Roon Team on the status of resolving this problem?

Hi @Steve_Kerns,

No update to share at this time, we are still working with Bluesound on this issue, hopefully we will have more details to share soon.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.