Roon Nucleus+ does not recognize the share folders of the QNAP storage

Hello Robert_Barry and nuwriyNuwriy,

I have the same problem,

my Roon Nucleus+ does not recognise the share folders of the QNAP storage,

on the Winsows 10 network all QNAP share folders are visible.

Robert_Barry,
can you please elaborate more on your solution?

Where did you make the SMB settings? In the QNAP?
How did you do that?
Is the IP address the same as your QNAP?

Thank you very much for your help.

Kind regards
Michael Strickrodt
.

Hello @Michael_Strickrodt, can you send me a screenshot of your folder settings?

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Hello Nuwriy Nienkirchen,

here my short explanation:

Roon Nucleus+ only for Music Play and QNAP-NAS only for Music Files Storage:

My Roon Nucleus+ currently has a 1TB Samsung SSD intern installed and a Samsung SSD connected externally via USB-A.

Both SSD’s are full, of DSD64, FLAC, AIFF, WAV file formats (no MP3).

I have decided to move the music files to an external separate storage system, QNAP 8 Bay, for future storage additions.

The idea is that

the Roon Nucleus+ is only intended to serve as a music player and music file manager.

This is nothing new, others do this from their PC.

10-Gigabit Ethernet internal Home network for Windows 10 Computers and audio devices:

2 x Netgear XS708T 10-Gigabit Ethernet Smart Managed Pro Switches,

these are connected with a 10-Gigabit Ethernet Cable, 25 m, between two locations:

1.-Netgear connected with

  • Windows 10 Computers 64 bit

1 x QNAP TVS-872XT, 10-Gigabit device, only for music files

(with 1 x Cache 1 TB M.2-SSD, 1 x Data 1 TB M.2-SSD, 16 GB, i5 CPU,

2 x 8 TB Samsung SSD only for music files,

connected with 2 x 10-Gigabit Ethernet Cable

2.-Netgear connected with

1 x Roon Nucleus+ Vers.B actual 1.7, no music files, only for music play and file management

  • several audio devices T+A MP 2500 R (Roon Ready), NAD M10 (Roon Ready),

Yamaha CX-A5200, McIntosh C53 (Roon USB proved), …

1 x Internet Rooter (DHCP)

Sorry,
how can I upload a pdf.file?
There are a lot of screen shots and declarations.
Can I send the pdf.file by pm?

Thank You very much for You Help.

Michael Strickrodt
.

Hello Nuwriy Nienkirchen,

here are some more aspects that I have elaborated / reviewed.

Regardless of what kind of device you’re using, you’ll want to make sure that the following is true
(I have got this helpfull link from QNAP Service:

FAQ: What’s the best way to configure my NAS for Roon? (roonlabs.com)

  1. A share folder has been set up -> Yes

  2. The folder is allowed to be accessed via SMB -> Yes

  3. Folder permission for everyone: read and write -> Yes

  4. Your username and password should not contain any special characters

  5. Use SMBv3 when possible. -> Yes

To Pos. 4: What is meant by special characters, please give some examples?

I checked the SMB3 connection of the share folders with the Windows 10 Powershell,
command line “Get-SmbConnection”,

The results are:

Qnap NAS Share Folder SSD-Vol_1 and SSD-Vol_2 comply with SMB3 protocol: Dialect 3.1.1

Thank You for Your Help

Michael Strickrodt
.

Some sample special characters (I hope they display well in your browser):
ä Ä ö Ö ü Ü à À ç é É è È ê Ê * @ ? ! _ ` ~ { [ ] }

AFAIK does Roon still require SMB v2. If SMB v3 is available it might use that instead or upgrade the connection (or whatever). Enable SMB v2 support in your QNAP and try again.

There were several user reports in the past that SMB v3 only support on the server side doesn’t work.

  • After SMB range setting, Roon Nucleus+ sees QNAP share folder and plays music from QNAP storage,

  • Music file copies from Windows 10 PC with interruptions and “0x8007003B Unexpected network error” .

Hello BlackJack,

thank you for your very valuable information.

After the QNAP NAS configuration with the fixed value setting to SMB3, about 3.63 TB music files could be stored on the QNAP in one copy process, about 11 h, without problems and without error messages.

Adding the network share of the Roon Nucleus+ to the QNAP share folder was not possible under SMB3 (QNAP setting).

Roon error message:

“An unexpected error has occurred: UnexpectedError”.

In the QNAP ControlPanel >>> Win/Mac/NFS > Advanced Options

SMB was set to highest SMB3 and lowest SMB2,

according to BlackJack’s suggestion

and the Roon Nucleus was able to log on to the QNAP share folder,

all ok so far.

Music playback over the 10 GB network is great,

without interruptions and without error messages,

absolutely great.

Music File Copy Problem:

when re-transferring smaller music file packages from the Windows 10 PC to the QNAP storage, approx. 30 GB to approx. 200 GB music files.

The copying process was interrupted with an error message

"0x8007003B Unexpected network error",

could be resumed after some time,

until the same network error occurred again and the copying process was interrupted again, and so on.

The copy operations from the Windows 10 PC to the QNAP NAS now have copy interruptions and network error messages.

Remark:

the music file copy process took place while the Roon Nucleus was playing music from QNAP storage, the QNAP fans were spinning up.

Questions:

  • Can the lowest SMB value be set to SMB2.1?

  • the asynchronous I/O is enabled, right?

Settings in QNAP menu Win/Mac/NFS:

  • File service for Microsoft networks is enabled, correct?

  • standalone server is enabled, correct?

  • NFS service: “NFS-v2/v3 service” is enabled, correct?

  • “NFS-v4 service” is not enabled, right?

What other settings are necessary

so that the music file copying works again without interruptions and without error messages?

Many thanks for your support

Michael Strickrodt
.

You should search the internet for that error message. It’s network related and therefore can have several sources - at least as many as network(ed) devices (and cables) are involved transferring the data.

Note: You wrote above that you connected the NAS with “2 x 10-Gigabit Ethernet Cable”. I read this as a bonded network device/connection. Such devices/connections have to be specifically created and setup - possibly on both ends (NAS and switch). Setup errors or incompatibilities between devices may lead to strange errors. If you’re unsure and because 10-Gigabit Ethernet is more than enough for common A/V needs, you can try removing one of the two cables.

I don’t know but you can try this easily yourself. :wink:

As you can see, I don’t have it enabled. There is also documentation from QNAP available:

Note: Samba will not wait until write requests are finished before returning the result to the client for files listed in this parameter. Instead, Samba will immediately return that the write request has been finished successfully, no matter if the operation will succeed or not. This might speed up clients without aio support, but is really dangerous, because data could be lost and files could be damaged.

This option enables/disables the SMB support in QTS - so YES.

If none of the other two options is applicable in your environment - you don’t use or don’t want to integrate the NAS in a Domain controlled network - then YES.

If you have a use for these network protocols then YES else NO.

See my advice at the top of this post. I would definitely try with a simplified network setup first (only one network cable between NAS and switch). As this seems to me to be unrelated to Roon, I assume that you see the error on your Windows PC when communicating with the NAS over a Netgear switch, you might want to ask Microsoft, Netgear and QNAP support if you can’t resolve the issue yourself.

Hallo BlackJack,

Thank You for your very interesting informations.

I have configurated the QNAP-NAS before music file coppying und before I conected the Roon Nucleus+ to the QNAP-NAS, all settings are done automaticaly by the QTS Software.

1. I have only changed this:
the “2 x 10-Gigabit Ethernet Cable” are a bonded network device/connection, configured in the QNAP, before 3,63 TB music file coppying and before «Roon to QNAP-NAS» network connection,
I don’t changed network settings by my selfe.

2. and I have changed that:
Min-Max SMB was set to SMB 3 ->

  • 3.63 TB music files were copied i.o., without any PC stops and error messages (via Windows 10 network)
  • Roon does not see the QNAP NAS.

Max SMB 3 and Min SMB 2 ->

  • 20 GB to 200 GB music file copying with PC stops and error messages.
  • Roon sees the QNAP NAS, Roon plays music from QNAP NAS very well.

Max SMB 3 and Min SMB 2.1 ->

  • music file copying has not yet been tested.
  • Roon plays music from the QNAP NAS very well

BlackJack Note:
«Samba will not wait until write requests are finished before returning the result to the client for files listed in this parameter. Instead, Samba will immediately return that the write request has been finished successfully, no matter if the operation will succeed or not. This might speed up clients without aio support, but is really dangerous, because data could be lost and files could be damaged.»

Sorry, I do not understand your note.

What should be done to avoid “data loss” and “file damage”?

The following was set automatically by the QTS software,
what do you recommend?
Is this necessary?

  • NFS service: “NFS-v2/v3 service” is enabled, correct? YES or NO?
  • “NFS-v4 service” is not enabled, right? YES or NO?

«If you have a use for these network protocols then YES else NO.» – Sorry, I don’t know!

QTS has configurated this item.

It is correct,
the “0x8007003B Unexpected network error” was shown on the Windows 10 PC,
during the copy process between PC and QNAP over the netgear switch,
this is not a Roon problem.

The error message occurred while the QNAP was simultaneously receiving music files from the PC and playing music files via the Roon.

I assume, that the M.2 cache memory becomes very hot (more than +70 °C, indicated by the QNAP control centre) and the QNAP stops the copy process with an error message;
the 3.63 TB copy process took place without the Roon function, the M.2 cache memory had a normal temperature of approx. +55 °C (displayed by the QNAP control centre). In normal Roon operation, the M.2 cache is only about 40 °C warm.

Thank You for Your help.

Michael Strickrodt
.

It seems that you have found the source of your error message. Congratulations!
In my opinion you should contact QNAP support about your issue, especially if the drives are on the compatibility list for your NAS.

I don’t know too. It’s a completely different way to access storage on a NAS. If you haven’t set this up for use on an other machine you should be safe turning it off. If unsure, just leave it on (doesn’t affect Windows/SMB file sharing).

The simple answer is: Don’t turn on “Asynchronous I/O”.

QNAP writes: To prevent power interruption, use a UPS when asynchronous I/O is enabled.

So your data is save (maybe) unless there is a power interruption during data transfers?
As I already wrote and can be seen from my screenshot, I have it turned off (typical household situation without UPS for multimedia and related devices and no need for additional potential problems) - but I also don’t have 20 Gigabits of theoretical network throughput connected to my NAS and expecting respective SMB transfer rate figures to be achieved. Again my advice is to talk about this with QNAP support.

QNAP support should be much better suited for answering your QNAP NAS / QTS related questions and may be able to help you resolve the issue with the overheating M.2 SSD chache drives.

@nuwriy please bring it to the team to rethink the information about the use of SMB v3 given to users in the above document as of my knowledge at least Linux based Roon Servers {includes Nucleus(+)} can’t connect to storage providers when only SMB v3 is available/allowed.

1 Like