Roon nucleus dropping off network


(Daniel Houghton) #1

Core Machine (Operating system/System info/Roon build number)

Core is on Nucleus 1.3
Serial #94C691A1F31E
OS Version 1.0 (build 174) stable
Roon Server software Version 1.6 (build 401) stable
Roon Labs software Version 1.0 (build 9) stable
TEXT GOES HERE

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NetComm VDSL/ADSL N300 Wifi modem router
d-link DGS108 switch that connects to modem/router and links Nucleus and Naim Uniti Nova via ethernet cable

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/ect.)

Naim Uniti Nova connected via ethernet cable to d-link DGS108 switch

Description Of Issue

Roon is dropping off the network intermittently but more frequently of late. It started happening during playback of Tidal but recently has been happening when playing back my library which is on a portable SSD drive and portable HDD plugged into the USB slots on the back of the nucleus. The only way to get connection back is by re-booting the nucleus, or re-booting my entire network. Other Tidal problems have been just stopping playing a track from Tidal. Can restart the album or track but sometimes it stops at the same spot it started at. This morning playback of a local FLAC file stopped as Roon had dropped off the network. Would not re-connect automatically (sometimes this occurs after a minute or so), so turned off the nucleus using power switch. Decided to reboot entire network and power off everything, restarted in this order, modem/router waited for internet connection, then turned on switches, then Roon nucleus then Naim Uniti Nova. Both Nova and Roon Nucleus didn’t connect to network. Unplugged them, restarted and they connected. Then playing Roon tidal and dropped off the network again. Rebooted nucleus for third time via switch at back and unplugging. Now playing a local FLAC file OK and Tidal worked OK again. Is this a router issue?


(Dylan Caudill) #3

Hi @Daniel_Houghton — Apologies for the trouble here!

When you’re unable to connect to the Nucleus, are you able to still access the Nucleus Web Administration Interface?

What remote devices are unable to connect to the Core? Does this occur with all remotes or just one in particular?


(Daniel Houghton) #4

Hi Dylan,

No. I tried to access the Core, by typing 192.168.20.X which I usually do, (X changes each time, usually 6 or 8), but the computer (HP i7 desktop) wouldn’t get me there and would open the page like it usually does. I obviously haven’t set up a static IP address yet!

None of the remotes I use will connect to the Core when it is disconnected from the LAN. The remotes I use include Samsung Galaxy Tab S3 running Android 8.0.0, HP computer running Windows 10 and sometimes Samsung Galaxy S8 phone running Android 9, One UI version 1.0. All three will show the same message that it is taking a long time to connect to the core which is disconnected from the network.


(Dylan Caudill) #5

Thanks for confirming that, @Daniel_Houghton.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

The next time this issue occurs, please make a note of the time that the remotes disconnect. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


(Fernando Pereira) #6

That would seem a first step to debug this. The interactions of long-lived but not always in use services like Roon’s and dynamic DHCP are hard to predict.


(Daniel Houghton) #7

Ok. Will do. Thanks.


(Daniel Houghton) #8

Yes. I seriously considered this. However, Roon Knowledge Base said this -

"Like most networked devices, Nucleus defaults to DHCP for the configuration of its network interface. Using a static IP for Nucleus is often not required and not recommended.

To configure the interface manually, change the IP Address Setup to ’ Static IP ", then manually enter IP Address , Netmask , Gateway , and DNS Server . Note: Incorrect static IP settings could render your Nucleus unreachable on your network. A thorough understanding of networking principles and familiarity with the host network are strongly recommended if you intend to configure your network interface manually.

If you accidentally enter an incorrect static IP and your machine is left unreachable, you can use a second network interface to help get out of this situation (because it will be configured by default to use DHCP).

I am not a gumby, but neither do I have a “thorough understanding of networking principles etc”
So, I got worried I would render my Nucleus unreachable and wait for explicit advice from Roon.


(Daniel Houghton) #9

Hi Dylan,

Roon Core just disconnected mid song DSF file that I was streaming from my SSD drive plugged into the back of the Nucleus. Had played about 5 or 6 songs from the album and suddenly skipped once or twice then stopped altogether. 30 seconds later all remotes said Core was disconnected. The Naim Uniti Nova remains connected and can play Tidal but my Nucleus with core


#10

Please leave your Nucleus on the DHCP setting. You should login to your router instead. There, under Advanced Setup > LAN at the bottom of the page you can set a static IP lease (take the MAC address from the Nucleus web page) for your Nucleus. Please reboot the Nucleus for the changes to take place.

If you want to delete the static IP lease for the Nucleus in the future, just login to your router, go to Advanced Setup > LAN again and delete the entry from the list.


(Fernando Pereira) #11

I configure static IPs for all my Roon devices (Core, endpoints) on my router (Ubiquiti EdgeRouter), not on the devices themselves – which indeed is error-prone.


#12

Just some considerations about your hardware:

Supports IGMP snooping which might be problematic.
Supports WMF which might prevent wireless devices to connect to the core.

This is an unmanaged switch with built in IGMP snooping which might be problematic.


(Daniel Houghton) #13

Hi Dylan,

the core remained disconnected for a couple of hours. I rebooted via the web administration interface but it didn’t seem to work, so I turned off via the switch and pulled out the power cord for 30 sec and it reconnected. Was streaming a Tidal album (Gordon Lightfoot, Sundown, MQA version) and 2.01 into the track The Watchman’s Gone it stopped playing. The Core disconnected for approximately 1-2minutes. Whilst I was typing this, it re-connected.


(Daniel Houghton) #14

Hi BlackJack,

Maybe I am a “gumby”. Sigh. When I log onto the modem, IGMP snooping is in blocking mode.
I see where I can enter a static IP lease on the modem webpage (which requires MAC address and IP address), but I can’t find a MAC address on the Nucleus web page. There is the IP address, Netmask, Gateway and DNS server but no MAC address.


#15

You’re correct. You can find the MAC on you router (Device Info > DHCP). If you’re unsure which line corresponds to your Nucleus, you can check the actual IP address on the Nucleus web page.

For IGMP snooping and other settings (see Networking Best Practices) there exist devices which need it enabled and such that need it disabled. :man_shrugging:
Unfortunately your specific router is not listed in the guide. Generally it turned out to be a good advice to have it disabled.
As your switch seems to have it built in, you maybe want to test with your Core and Naim connected to the router directly.


(Peter Lie) #16

This looks like a network infrastructure problem that requires hardware replacement. I suggest replacing the switch by a Netgear GS108 - that is easier and cheaper than replacing the router. If possible, buy from somewhere that allows you to return it.


(Noris) #17

Hi @Daniel_Houghton,

I took a look at the diagnostics at the DSD trace you mentioned and I see the following:

04/07 05:51:37 Trace: [Music Room] [Lossless, DSD64 DSF => DSD64] [100% buf] [PLAYING @ 0:22/3:29] Hustled Down in Texas - Johnny Winter
04/07 05:51:43 Warn: [Music Room] [zoneplayer/raat] long rtt sync Naim Audio Uniti Nova: realtime=870243227935 rtt=271000us offset=-6321886772us delta=-160585us drift=-89934us in 868.485s (-103.554ppm, -372.794ms/hr)
04/07 05:51:43 Trace: [Music Room] [Lossless, DSD64 DSF => DSD64] [49% buf] [PLAYING @ 0:27/3:29] Hustled Down in Texas - Johnny Winter
04/07 05:51:51 Trace: [tidal/storage] sync force=False
04/07 05:51:51 Trace: [tidal/storage] scan 2: starting
04/07 05:51:51 Trace: [Music Room] [Lossless, DSD64 DSF => DSD64] [47% buf] [PLAYING @ 0:28/3:29] Hustled Down in Texas - Johnny Winter
04/07 05:51:58 Trace: [Music Room] [Lossless, DSD64 DSF => DSD64] [41% buf] [PLAYING @ 0:28/3:29] Hustled Down in Texas - Johnny Winter
04/07 05:52:05 Trace: [Music Room] [Lossless, DSD64 DSF => DSD64] [37% buf] [PLAYING @ 0:28/3:29] Hustled Down in Texas - Johnny Winter
04/07 05:52:08 Trace: [Naim Audio Uniti Nova @ 192.168.20.7:35285] [raatclient] GOT [14] {"status":"Ended"}
04/07 05:52:09 Info: [stats] 5894mb Virtual, 3616mb Physical, 3269mb Managed, 0 Handles, 68 Threads
04/07 05:52:13 Trace: [Music Room] [Lossless, DSD64 DSF => DSD64] [35% buf] [PLAYING @ 0:28/3:29] Hustled Down in Texas - Johnny Winter
04/07 05:52:13 Debug: [prebuffer] sleeping in read -- this isn't good
04/07 05:52:17 Warn: [raat/tcpaudiosource] send failed: The socket has been shut down
04/07 05:52:19 Warn: [raat/tcpaudiosource] disconnecting + retrying
04/07 05:52:20 Debug: [raat/tcpaudiosource] disconnecting
04/07 05:52:32 Warn: [Music Room] [zoneplayer/raat] long rtt sync Naim Audio Uniti Nova: realtime=909270705775 rtt=10121000us offset=-6331660294us delta=-9773522us drift=-9863457us in 897.2135s (-10993.434ppm, -39576.361ms/hr)
04/07 05:52:37 Info: [stats] 5893mb Virtual, 3616mb Physical, 3269mb Managed, 0 Handles, 68 Threads

This indicates that your buffers stopped filling and that the music Roon zone disconnected around the same time. It is possible that this a hardware issue but just to be sure I have few more tests in mind to narrow it down further:

  1. Can you connect your Nucleus to the Router directly and see if the same behavior occurs?
  2. Are you able to temporarily use another PC to host the Roon Core to see if the same behavior occurs?

Thanks,
Noris


(Daniel Houghton) #18

I will do both of those and let you know when done and if any problems occur.
Cheers.


(Daniel Houghton) #19

OK. I have connected the Nucleus directly to the router last night (around 7.30pm) and it initially had a few disconnects whilst streaming Tidal. I had to reboot the modem for the Core to be seen, but the modem could see the nucleus at the time when I went to the modem/router website. It then has been stable since but I haven’t had a chance to test properly. Will try this out first then move onto suggestion 2.
Cheers.
Dan.


(Daniel Houghton) #20

Hi Noris,

I have started using another PC (rather than the Nucleus) to host the Roon Core. Initially this was connected via a Netgear GS105 switch into my modem/router. Then today I connected the PC hosting Roon Core directly into the modem/router. It has been solid and steady with no dropouts or disconnections. The only time things stopped were when the computer automatically went into sleep/shutdown mode or got hot and crashed. Other than that, everything is working a treat via the PC. I would prefer to be using the Nucleus to do this. So, what’s next? Reinstall the Core on the Nucleus? or something else?


(Noris) #21

Hi @Daniel_Houghton,

Just to be clear here, when you had the Nucleus connected to the router, were things still stable before moving on to the laptop-based setup? As-in, if you connected the Nucleus in the same way that the laptop was connected, are you still experiencing streaming issues?

You can try a reinstall although I’m not certain it will help. Before doing this, I would definitely make a Backup of your current database, and save it somewhere safe if you want to give this a go.

Thanks,
Noris