Roon Nucleus lost internet connection

Roon Server Machine

Nucleus

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I have a Roon Nucleus that is operation multiple Roon endpoints, recently it is not connecting to the internet anymore.

It doesn’t show up in an IP scan, it doesn’t show up on the Roon App.

I have rebooted it multiple times, tested the CAT6 cable, unplugged from the network switch and plugged directly into the router, nothing seems to give me an IP address.

The only thing I can think of is that the network port on the Nucleus went bad.

Can you attach a monitor or TV to the HDMI port and post a photo of any messages that are displayed?

Two further questions:

  • Is the unit still within the 2 year warranty period?
  • Did you buy it from a dealer or direct from Roon Labs?

Your answers will determine the next steps. Thanks.

Bought from Roon Labs and its been installed less than a year. I will try connecting to a monitor.

Its showing an IP on the OSD but if I try to go to that IP it doesn’t connect.

What IP address range does your router use for devices on your home network?

192.168.169.110-192.168.169.210 is the DHCP range

So the address of the Nucleus is within the DHCP range, and it should therefore be seen by Roon clients. Have you tried rebooting everything from the router outwards (wait for the router to be up and running before you reboot the rest of your Roon devices).

I have but I can try again for troubleshooting sake.

That didn’t work, I did notice when I see my laptop, but underneath it says “Configure Roon OS devices on your network” when I click on that it shows up but if I click on it it just takes me to the IP address and that doesn’t connect to anything.

Most odd - and clicking on that link (which presumably is showing the correct address of 192.168.169.121) does not open the Web Administration interface of your Nucleus in your web browser?

Can you describe in detail your network hardware and setup?

Fortinet router
Luxul switches
Ruckus Access Points
I am actually with Mr. Docter’s A/V company and we sold him this Roon. Is there anyway I can talk to anyone on the phone?

Everything was working for months until about a week ago. This is day 2 of me trying to figure out what’s going on with this, this is getting expensive for me and my client, there has to be a better way to figure this out that’s not posting to a forum and waiting for someone to respond.

I unplugged everything from the router except my laptop and the Roon Nucleus and I still can’t get it to show up in the app or on a network scan.

Hi @Alan_Docter, I’m a network engineer but I don’t work for Roon.

According to the video output, DHCP is working. This should be logged in the router. Make sure you actually see a new request / response to make sure Roon isn’t using a cached address (I don’t think it does but this is easy to check).

Next, get a “dumb” switch. Preferably something with a monitor port. Run your sniffer software of choice. You should see broadcast packets hitting the ethernet segment. You should see requests from the remote hitting the ethernet segment. If you don’t see any of these then this isn’t a Roon issue. Look to see if the router is blocking traffic to the Roon Server.

You cannot login to the Roon Server so a monitor port is the best you can do.

Of course, you can also plug a PC and Roon into the same “dumb” switch which should bypass any issues at the router.

Roon uses broadcast / multicast for discovery. Usually routers won’t block this. It uses TCP for the actual remote connection though. Routers can, and will, block this kind of connection if it considers it a threat. So, you can discover but not connect which is the experience you’re describing.

I brought the whole unit back to our shop and connected to our network and tried connecting directly to it and I’m not getting any IP or anything. I hate to say it but I think it needs replaced. It’s only a few months old so its still under warranty. What’s the process for getting a replacement?

Please repeat the process of attaching a monitor or TV to the HDMI connector on the Nucleus now that it is in your workshop, and posting a photo of what you see on the screen. Thanks.

I’m not there anymore I have other jobs to do. I can try when I get back but I really need to be able to talk to someone real time to figure this out, I can’t just post on this forum and wait for a response, is there any way I can talk to someone on the phone while I’m with the unit and get this solved?

Hi @Alan_Docter,

We’re sorry to hear that you’re having issues.

First off, I recommend using the remote network reset command on the Nucleus:

  1. Connect the Nucleus to a monitor or TV via HDMI
  2. Connect a USB keyboard to the Nucleus
  3. Press ENTER
  4. Type resetnetwork
  5. Press ENTER

If that doesn’t work, we’ll want to attempt to isolate the ethernet port output of the Nucleus. You’ll need a USB to ethernet dongle - try connecting it to the USB port of the Nucleus and then connecting to the upstream ethernet port. Are you able to locate the Nucleus on the network?

Lastly, we’ve noticed that the Nucleus’ last IP address is in a range commonly employed by large-scale, enterprise networks. Is this Nucleus connecting to corporate internet, like in a hotel or office building?

We’ll proceed from there. Thank you!