Roon Nucleus Plus stuck in "Enabling" mode with DCS Debussy

I just installed Roon Nucleus Plus, directly attached to DCS Debussy via first USB port and to LaCie 6TB USB drive via second USB port.

I also have a large number of Sonos devices on the network that the Core sees and connects to easily.

I powered the DCS off, reset it, reattached the cables and updated the Roon software. Still no go.

What am I doing wrong?


But with the Debussy, although it sees it, when I click “enable” it just stays in “enabling” mode.

Hi @Karl_Mills,

Did you also update the Nucleus Firmware? Can you share a screenshot of Settings > About?

Have you tried rebooting the Nucleus?

HI Dylan,

I did update the firmware and also swapped the USB cable that I had from my dealer with a newer one that said “high speed” (probably USB 2.0). In any case, one of the two things worked and now it sees the Debussy and plays. It actually let me name the device and provided a customization screen. I was not sure what settings to use, so let them as they were by default, but let me know if you recommend any changes. Thanks, KO Mills. IMG_9213|375x500

1 Like

Hi @Karl_Mills,

Glad to hear that things are working for you now! As for settings, the default settings should work, but if you ever want to read more about these settings, we have documentation here.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.