Roon Nucleus plus won’t boot up

Roon Core Machine

Roon Nucleus plus

Networking Gear & Setup Details

Att router

Connected Audio Devices

Directstream dac via Ethernet

Number of Tracks in Library


Description of Issue

My Nuclues won’t start up, the power button lights up but it won’t boot. Cannot see it on the network. Purchased Nov 2021.

Need to send it in for repair.

First, hook up a monitor at Nucleus boot time and see if you get a display.

I tried that, no display from either HDMI port.

Thanks for the quick response!

Ah, that’s a bad sign and probably a bad motherboard.

I’m just another user, but I’ll tag @support for this.

FWIW - If it is the motherboard and since it looks like you might be out of warranty, if you want to have a dedicated device to run Roon then it will probably be cheaper to get an Intel NUC and install ROCK, rather than getting the Nucleus repaired.

Thanks, not great for something a couple of weeks over warranty.

Ain’t that the way of it? Let’s see what Roon Support says.

Good luck.

Actually I think I have a two year warranty so I should be okay.

Thanks for you input, much appreciated.

1 Like

Yep, from the horse’s mouth -

Roon Core Machine

Roon Nucleus Plus purchased 11/22/21

Networking Gear & Setup Details

ATT router

Connected Audio Devices

PS Audio direct stream DAC

Number of Tracks in Library

104000 tracks

Description of Issue

My Roon core won’t start up. I have tried resetting the battery bit still no luck. The power button lights up but nothing else, it is not visible on the network.

I need to send it back for repair.

Hi @Peter_Goodier ,

Sorry to hear about the trouble with the Nucleus here. If there is no HDMI output, it is likely a sign of a motherboard issue. I’d be happy to get an RMA started for you so that we can resolve this issue, I’ve followed up via private message to gather purchase and shipping details, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.