Roon Nucleus: RAAT server connections trying to connect to router IP not Roon

Greetings! I have a completely bizarre situation running a Roon nucleus version 1.0 build 186 with Roon server software Version 1.7 (build 537).

My Roon server has a static IP address of.80 on the network.

When I attempt to connect to the server from either the mobile app or my desktop client it attempts to connect to .1 (router address). I’m very technically savvy and have been looking at the Roon server logs.

It appears as though the Roon server is identifying itself as .1 in the logs.

[Brokerserver] client connected
On start up there is a trace that says [SOOD] adding user IP

I can then see the individual connections to the RAAT server and it’s saying that my client is attempting to connect to

The connection says that it’s failed and then retrying and it does a push connection to

There are repeated attempts that all fail.

If I do a search for the actual IP of the Roon server as I have a signed it in the web GUI it doesn’t show up in the logs
If I do a search for the actual IP of the Roon server as I have a signed it in the web GUI it doesn’t show up in the logs.

I have also assigned a static IP to the ethernet Mac address of the Roon nucleus server and again no luck.

I have also enabled Wi-Fi and again no luck.

Throughout this all I can get to the web interface via the IP address that I have a signed however any RAAT connections keep going to the .1 IP address according to the logs and fail.

Additional debugging steps that I have done

  1. restarted Roon server
  2. Rebooted nucleus server
  3. powered down and restarted Roon Nucleus
  4. unplugged switch
  5. put Roon to DHCP
  6. stopped server, renamed database and let Roon create a new database.
  7. I tried using a different protocol such as SMB and was able to mount the Roon internal hard drive using the correctly assigned static IP address.
  8. I haven’t done any tests using Telnet to any of the ports indicated in the logs

All of these have no luck. When Roon reboots it goes green with the CORRECT IP address and gives me the button to connect for a split second and then fails

I can intermittently connect to the Roon server from my mobile app 1% of the time then nothing.

So those are the main logs. If I open up the RAAT logs it does indeed show me the correct IP address as I have said it and the RAAT services are resolving to localhost in other words

As far as I can tell the root of the problem appears to be that rune is broadcasting it self as a particular IP address that is incorrect and then when my client attempts to connect it’s connecting to the wrong IP address. As far as I can tell the root of the problem appears to be that rune is broadcasting itself as a particular IP address that is incorrect and then when my client attempts to connect it’s connecting to the wrong IP address

I have screenshots logs etc. etc. Please help

With ROCK this is an option to reinstall the OS. I don’t know if the Nucleas web interface gives this option but it’s worth a try if it does. It’s behaving like the host file is corrupt…or as if there is another DHCP server on the network.

Have you restarted the device (router) that provides network services like DHCP and DNS and is at

Yes. I’ve reinstalled the server software previously. I’ve rebooted my firewall (which provides DHCP server services).

There are no other DHCP or DNS servers on the network. I can also confirm the MAC address of the Wi-Fi and ethernet interfaces of the Nucleus on the firewall via their MAC addresses.

I am curious. What network mask are you using? Are you routing different subnets? And, from your endpoint (phone, desktop) do you have basic connectivity to the Nucleus IP?

It might be helpful if you provided a bit more information about your network?

It’s only a single network segment and Wi-Fi is bridged so I’m not routing between any subnets. I have the same problem whether I’m connecting clients via Wi-Fi or from a computer physically connected to the LAN.

Mind you this is not a new setup but a setup that I have had for over a year. This is a new gremlin that has crept up.

So you’re running a /24 on 192.168.168.x, and your Nucleus is assigned .1 which conflicts with your router? And you can’t change the Nucleus to something else statically?

The nucleus is assigned.80 but is presenting itself as .1 to the clients. That’s the strangest thing. When I restart the Roon server software the clients quickly see its correct IP address at. 80 and then everything changes to .1. If you look at the Roon server logs you see it that it is seeing it self as .1 with connections trying to hit .1 and if you look at the RAAT server logs you see that it is presenting itself as .80 via localhost.

.1 is obviously the router/gateway and .80 is the IP address I have physically assigned to the nucleus both at the DHCP server level and as a static IP on the networking interface.

Would you post a screenshot of the Nucleus IP configuration?

And for clarity, have you established basic connectivity between other devices and .80?

To emphasize how strange this is I can get to the web interface of the server at.80 and can mount the server via SMB with .80. It appears as though only RAAT connections / Roon endpoints are having the issue.

Hmm. I assume you have the subnet correct. I also assume that you have manually added the Roon IP as a test to your control devices.

Edit: not sure how to help further. Seems like a networking problem to me, though I have no evidence to support that claim. Sorry I don’t see the problem for you.

My network settings are correct so now look without me touching any IP addresses or the DHCP or DNS server it connects just fine. And Roon now sees itself as .80.

This is one of those situations were I wish I had a bit more insight into what’s happening on the network layer on the nucleus server. It’s totally bizarre looking at the nucleus server logs that it is identifying itself as

I’ve been trying to figure this out for hours and that’s why I came to post here as a last resort! Thanks a ton for all your double checks and insights. Very very strange.

And I have also checked my firewall and tested policy and rules to see if there have been any blocks or any alerts at.80 and there haven’t been.

One other item for development consideration I do wish that I could have the option of manually entering in the IP address of the Roon server as opposed to relying on the application to find the server on the network.

I’d love to have an “advanced” option where I could manually enter in the IP address of the Roon server in a future update for connecting clients.

In this scenario the default behavior would be to auto find the server and then advanced users could theoretically override it for debugging like this

Are you running a vpn on your client device?

Good question but no, there are no active VPN connections on my laptop, which won’t connect at all to Roon.

Greetings! This is a follow-up to my previous post here [Roon Nucleus: RAAT server connections trying to connect to router IP not Roon].

Bottom line is that I still cannot reliably connect to my Roon Nucleus.

Roon continues to take the wrong IP address. Please read my previous post to see the extensive debugging I have done including re-installation of Roon, Reinstallation of the OS, etc. I have both a static IP AND I have DHCP set to assign Roon .80 (yes, I’ve switched between the two and also used Wi-Fi).

Bottom line, Roon is serving up connection at .1 instead of .80. I can see this in the logs that Roon is booting up and serving connections as .1.

Moreover, I found on the Roon config files on the DATA drive that Roon has .1 as a config. I deleted those files, kept only the config file with .80 and still no luck.

My hunch is that something on the UNIX OS side has .1 as the IP address and isn’t releasing things even after an OS reinstallation—a rogue config file or something.

Any ideas or help on this?

If you go the web GUI page at the nucleus IP address what do you get? If you can’t get there then what does it show if you connect a monitor to the hdmi and boot up the nucleus what IP address is shown.

Support might ask you to reset the network interface. This will need a usb keyboard and a monitor too

Did you get the nucleus new or has it been setup with a static address incorrectly perhaps?

Here’s the dual personality nature in pics. I have had the Nucleus for quite a while and purchased it new.

Is there a KB to get under the hood onto the actual OS and reset the IP?

I can get to the Nucleus’ web OS no problem at .80.