Roon Nucleus Recognized my old Lampizator dac but not my new one

Roon Nucleus (Version 1.0 (build 12) stable.)

My simple setup: Roon Nucleus (internal ssd) > USB Cable > Lampizator Atlantic TRP Dac

My Nucleus worked fine with my old Lampizator dac. I just upgrade to a new Lampizator dac and it won’t show up.

The problem may be that the USB module changed from Amanero to JLSounds.

JL Sounds told me their system runs Linux and should be compatible but speculated that perhaps their device codes for PID/VID aren’t in Roon’s database.

Is there any way for me to help get my new dac recognized?

Many thanks.


Hi @Attila,

Do you have any other PCs around the house with Roon installed on it?

Could you please try connecting the Lampizator to the PC and verify if it works when not plugged into the Nucleus?

Thanks for your note.
Such a simple idea, I’d overlooked.
I tried my Mac and can’t get that going either.
Pursuing a solution on the dac side now.
Will follow up either way.
Many thanks.

1 Like

Try using a different, inexpensive USB cable (such as those for printers).

1 Like

Great idea.
It turns out the dac’s new usb section is very picky on which usb cables it will accept.
Have a few more cables coming in the mail.
Never had this problem before, will report back.
Thanks all.

The issue is the JL USB, which recentrly replaced Amanero in Lampizator DACs. I am also struggling with this now. Apperently it is not visible for Linux. Can I reach ROCK settings to solve it?

1 Like

I have already got in touch with Mr. Ficus and hope to get it solved soon.

1 Like

Is it visible on Windows or another computer?

Have you tried all the different USB ports in the computer?

Have you tried a different USB cable?

I use Nucleus. They say is is easier to fix with regular Linux than ROCK.

Many thanks for your note.
I’ve been emailing with Lucasz as well.
Great to connect here.
Lucasz told me the JL Sounds module rejects 40% of usb cables.
I’m trying a few new ones this weekend.
Looking forward to seeing this through, will keep you posted.
Love to hear your progress as well.

1 Like

Rejects 40 percent of USB cables… Ermmm

Perhaps they should sell it with a right cable…

That would be ideal.
If my none of the three new cables work this weekend, my desperation level will peak.

I’d be desperate if I’d bought such a flaky piece of equipment too.

Hi, will u let me know if you succeeded with any of the cables?

Three new cables arrived yest; none of them work.
I’m afraid there’s nothing else to be done.
Did you get any idea from Lucasz if it might be possible to fix remotely?

I am hoping to hear from his crew first thing Monday. I can still downgrade to Amanero but I believe this will not be the case.

Will let you know as soon as something happens.

Well, my usb input doesn’t work with anything so DAC is going back for a repair.
Any better luck on your end?

Following my conversation with Mr. Fikus, I believe it is not a hardware issue, so I give him a couple more days to work out a fix. I wonder if the Roon support and JLsounds are aware of the issue and have addressed it.