Roon Nucleus+ set up issue

I need some help with my new Roon Nucleus+ ( with the SanDisk Ultra 2TB installed ) set up on certain technical advice, being a novice to computer audiophile stuff at my age !
It is connected by Ethernet via my 5GNetwork
I am also using PSAudio DirectStream DAC which is also connected by Ethernet via the same 5GNetwork via Bridge 2 . I have a Tidal Hi Fi Subscription and the PSAudio DAC is MQA compatible and working fine on streaming currently using mconnect.
When I loaded up the new Roon OS app on my iPad Pro, it just displayed searching for devices but nothing happens .
I suppose I would need a hook up between the PSAudio DirectStream DAC via some link to the Roon Nucleus+ .
There is an I2S2 port on the DAC , the other I2S2 is connected to the PS Audio Memory Player .
I don’t see a HDMI for the PSAudio Direct Stream DAC but an optical analog output and a small square USB analog output only in the back panel which are quite different from the Roon HDMI or the Roon conventional USB port .
What would you suggest I should do to make this work ?
Thank you for your assistance !

Hey @Raymond_Tam – so you’re going to want everything connected to the network. That includes the Nucleus, the Directstream, and the iPad.

With the Nucleus and Directstream both connected over ethernet and turned on, you should see activity on the router. Are you seeing that?

Also, can you confirm what router or networking gear you’re using?

With that information, we can make sure we get this working for you. Thanks!

@support - My iPad Pro , the PSAudioDirectStream DAC and the Roon Nucleus+ are all connected via Ethernet for the latter two and Wi Fi on the iPad Pro .
It uses the Apple Extreme connected with HawaiiTel Modem ( PACE ) .
I just don’t get activity from Roon , see photo

I have a meeting and dinner to go to and unable to reply for the next several hours … FYI

I put in the IP Address for the PSAudioDirect Stream DAC to scan for the Roon and still nothing happens !

Hello @Raymond_Tam,

Can you please confirm that you have updated the Nucleus firmware before first use as per our Documentation?

Is the Nucleus powered on and connected via Ethernet? Are the lights on the network port flashing?


The light on the Ethernet is flashing .
I did not know I need to update the firmware as no instruction came with that when I bought from Moon .
I will see how I should do that tonight when I have time and may be that could be the hang up ? I certainly hope so ! Thanks

By the way , on the Roon OS app , that searching page and icon is all I can see . How do I get to the data base to get the firmware updated ??

At the bottom of that screen, do you see a link that says “Configure Roon OS devices on your network” ? That should find your Nucleus and take you to the web interface, where you can update the unit.

At the risk of asking the obvious, have you powered up the Nucleus? We’ve had a few instances where people missed this, so just mentioning it just in case.

You can also try following the instructions here, but let us know if you get stuck Raymond.


I do all that tonight and get back tomorrow to you , thanks !

1 Like

@Raymond_Tam you need to ensure that your network endpoints LAN and Wifi are on the same network segments…they should have the same IP address numbers for the first 3 numbers and unique for the last number … ie where xxx is anything from 1-254

if you use an app like FING or you should be able to see the iPad address and the addresses of the other devices. If you dont see the Core and PSA and you router then this is likely the issue - ie not using the same network segment.

Aloha Gentlemen ,
Success ! Got my Roon Nucleus+ working with my PSAudio Direct Stream working and all the network issues solved . Due to a Wi Fi signal booster I have added ( Netgear Orbi ) to my original HawaiiTel Pace Modem ; somehow I have two Wi Fi Addresses and if I did not set my iPad Pro to the correct selected Wi Fi address, Roon Core was searching in vain !
I did install the firmware upgrade also later on .
A few observations from experimenting with Roon Nucleus+

  1. I had to turn on all the Roon settings, including showing duplicate albums before I could see both the MQA and the non-MQA versions of the same album for selection and for audio comparison. Not as intuitive as mconnect Tidal Hi Fi displays after adding to my favorite albums .
  2. The Wi Fi Connection and system is clearly more stable then the mconnect app though
  3. There are a lot of things to get used to on searching and with the metadata display
  4. Roon Nucleus+ addition should technically “
    not impact “ adversely the sound quality in anyway versus direct mconnect control of the PS Audio DAC … Correct ???
    Now the 2 TB Question !
    I installed the SanDisk Ultra SSD 2 TB in the Roon Nucleus+ for the music server . I presume this is more useful for my use later when I download HD Tracks or hi res Quiboz files or moving computer music files over … am I Correct on this too ? The Tidal Hi Fi Streaming does not require this at all for my favorite albums collection .

Appreciate the advice and help and any more useful information to this novice !

1 Like

Hello @Raymond_Tam,

Glad to hear that you’re up and running! For your question #3, while the Nucleus itself doesn’t affect the sound quality, but our RAAT Protocol does operate a bit differently than typical audio streaming and there are some design decisions which help with audio delivery, you can review that article for the specifics.

For moving the files over to the SSD, you would want to make sure that you format the SSD first (if you have not done so already) using these instructions and then you would be able to copy your music files over by:

Using Windows - Opening Windows Explorer and then posting this in the address bar: \\NUCLEUSPLUS\Data\Storage\InternalStorage .

Using OSX - Pressing Go on in the Menu Bar -> Connect to Server -> Set the Server Address to
smb://NUCLEUS/Data/Storage/InternalStorage -> Connect as Guest. This link provides a visual guide.

You would want to drop your downloaded files there.


Thank you again for all the help . I am sure as I played around with the system , more intriguing questions might come up in future .
Actually , there is one already .
Why is the “ backup “ gets defaulted to Dropbox and not Apple iCloud instead . Is there any particular reason ?

Hey @Raymond_Tam,

Roon does not support Apple iCloud at the moment. You can read more about Backups in our KB Article. I would actually suggest that you give our User Guide (<- Clickable link) a read through as it is a comprehensive documentation guide that may answer most questions you have.

For any questions you may have regarding how the software works, this would be best posted in our Roon Software Section of Community (<- Clickable link) .

I see that you’re up and running regarding the Nucleus setup issue you had so I’m going to go ahead and mark this topic as [Solved] but anything else Roon-related that is a “how does this work” kind of question should be directed to the Software section.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.