Roon Nucleus "There was an error checking for Update" [Solved: Roon fix]

I can see the Nucleus on my network, and can access with Web Browser.

When I try to connect Roon App to new Nucleus, I get a message “an update is ready to be installed”…

When I click download and install, I get an error “There was an error checking for an update”.

I get the same error when I try and connect to Core from my Windows 10 Laptop or Android Phone…

I have updated the Roon OS on the Nucleus (via the web browser) and restarted the server. Shutdown the Nucleus and restarted. Reset the database on the Nucleus. No luck.

I just purchased the Nucleus from my local AD and haven’t been able to set this as my Core.

Operating System Version 1.0 Build 175 stable
Roon Server Version 1.6 Build 416
Roon Labs Software Version 1.0 Build 11

Any help is greatly appreciated!

Have you checked the network settings in the web page, to see what they are set to as that is an old version and does need an update.

If you have not already given it an IP address, set this setting to DHCP

You can try changing you’re DNS settings to and as a starter, just in case it’s not getting addresses

I have tried to update through the network web page and it seems like it just re-installs the old version. Thanks for the reply

Peter did you check the network settings part as well?

I am actually away on holiday at the moment so cannot get to my Rock server.

There is also a reinstall option from memory, and that pulls down an updated image and installs it.
Worth giving that a try as well.

Roon support do not work weekends, so hopefully someone will pick this up tomorrow

I did, with no luck. I’ll wait for Roon Support to respond. I found another recent thread with a few other people having the same issue. Hopefully there is an easy solution. Thanks!

1 Like

Good luck :crossed_fingers:

There seems to be an issue with new Nucleus units on older versions getting connected to the update servers or being able to find an update.

@Danny made some mention of this IIRC some time back, but wait for the @support guys to chime in…sometimes after a weekend it takes then a day or 2 to catch the queue up.

1 Like

Yes, that is my impression too, that it reinstalls the old version (cf my post in the other thread).

Network setting is DHCP. Tried it with static IP in order be able to set DNS to or, but that had no result either.

Really wish @support would chime in because I’m having this problem since Thursday and haven’t been able to use my Nucleus at all.

@support As requested in another discussion. Here is a link to the log from my Nucleus.
Dropbox - - Simplify your life

I don’t know what happened, but suddenly it worked? :slight_smile:

I was playing around trying to ping the Nucleus from outside my home network (wasn’t possible). Then when I reconnected my laptop to the home network, the Nucleus started downloading the 1.8 update and suddenly it worked.

So, hurrah!!! And thanks, whoever at support made this possible!


Hi @Peter_Brown2 ,

We made a change on our end, can you please confirm if you are still seeing this issue? Thanks!

@noris Just got home, reinstalled the OS and it works! Thank you very much!

1 Like

I think you misremember or misunderstood. No such issue existed or exists. This was just a small issue on our end and was fixed already. All updates were broken for a bit there, including Roon.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.