Roon nucleus won’t connect to iphone

Roon nucleus just stays red and says connecting on my iPhone. I can connect from my computer and my wife’s iPhone! My iphone is up to date. I have tried with both the new app and the arc app. I can’t get to the admin page from my iPhone either using chrome but don’t know if I ever could.

Using the admin page from the laptop, I made sure that Roon server etc are all up to date and all are running. Everything says “OK”

Anyone have any ideas?

Make sure WIFI is turned on in your iPhone and it’s connecting to your desired network. If it’s a 5 frequency, try 2.4. You could reboot your phone to see if that helps. If not delete Roon Remote and reinstall. Make sure you’re on the correct version of Roon Remote that is the same as your Roon core.

1 Like

WiFi is fine and I can see the device and it’s IP address in the app. It just won’t connect. Thanks for the reply

Hey @Michael_Fricklas,

Ben here with the support team, I wanted to check in on this thread to see if you’re still running into connection issues with your iPhone. If so, please provide the specific model and OS. With that, I would remove roon from the device, and power it down. From there, I would give your router and core a hard reboot as well. After that, boot up your iPhone and reinstall Roon :+1:

In addition to that, we’ll need a full breakdown on your system as well:

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

Hi. I’ve attached the page that shows up when i navigate to the Nucleus using Chrome. I’ve also attached the screenshot from the iphone. Roon server is up to date on the Nucleus; Iphone is up to date on OS (15.x) From my computer i am using an ethernet connection; my iphone is connected to wifi through eeros. The weirdest part is that Roon on the Nucleus works fine from the Roon app in windows 11; i can also get it to work on my wife’s iphone which is configured in an identical manner. I have tried rebooting Roon, rebooting router, uninstalling the app and reinstalling the app. I had no problems accessing roon Nucleuse from my iphone before the 2.0 upgrade. As you can see 2.0 is running on the Nucleus and the iphone remote “sees” the Nucleus - but it just won’t respond.



Hey @Michael_Fricklas,

Thanks for that information. After taking a deeper look into your account, I see both a Nucleus, as well as a Nucleus+ tied to your account. Can you provide more insight into this?

Does your iPhone connect to the Nucleus+? Since you only have 1 active license at this time, you’ll only be able to set up one active core under your account.

With that, I’m not able to connect to your account to enable diagnostics, could you please use the directions found here and send over a set of logs from your Nucleus to our File Uploader?

I’ll be on standby for your reply :pray:

The devices are at two different homes. The Nucleus+ works fine. Unfortunately, i won’t be at the other location for a couple of weeks, so i will have to try that when i am there. As to the license - i switch from one core to the other when i travel from place to place.

1 Like

benjamin - i just uploaded the logs. Every device can access the Nucleus but my iphone. (My wife’s iphone can access it just fine). Yes we have two networks, but your app always asks and we deauthorize one of them when we authorize the others. We are only at one place at one time, so this has always worked fine.

Hey @Michael_Fricklas,

Thank you for this information. Does this only happen when trying to connect via Roon Remote to the iPhone? Have you tried connecting via Arc at all?

Also, my apologies for any confusion here - we’ll need a set of logs from the iPhone as well. Steps below:

  1. First toggle “Save logs to Files on next startup” from your iOS Settings for the Roon App.
  2. Reproduce the issue.
  3. Access your Files App on the phone and upload the log file.

And to triple check, the iPhone in question is “iPhone” running iOS 15.7, not “mdf-iphone-x” running iOS 16.3?

Alas i am no longer at that location. It is the iphone (mdf-iphone-x) running 16.3 that is hitting the snag. ARC does not connect from where i am located now (i.e., outside the home network). I probably have to set something when I am at that location. The iphone running 15.7 is my wife’s and Roon Remote works fine from her phone. Roon remote also works fine from my surface pro (and hers).