Roon on Asustor AS5304T

I start roonserver and when open the app i see austor roon server is ready.
I push connect and nothing Moore happens except for roon logo is visible.
What to do?


Hi Kalle,

I also have an AS5304T (and a lot of difficulty installing Roon). I found it helps a lot if you insert an SSD or memorystick in the USB-port and install the database there. Suddenly everything worked. So it may be the AS5304T is just too slow for the database…

Kind Regards,


Thanks for reply.
It came a new adm version to asustor and i installed.
And after that it works. I did not do anything else so I guess it must be it?

I must say it works really really good.
Using roon with volumio. (Digione signature through Bryston BDA3)

The speed is ok
I don’t regret spend a lot of cash on the Nas as it’s working so good. I have 16 gig ram in mine.

But maybe i buy a USB SSD for the music anyway as you suggested.

Hi Kalle,

I only put the database on ssd (could be a memory stick) and use the music on the nas. But I will also increase the RAM, as it is only 4GB. I also have an older Asustor NAS (AS5004T, with 8GB RAM) and it seems to works better.

I use it with two Cocktail Audio players and a Sonos.

Great you have it working.

Aha. Ok
Now i understand.
Regarding to spec it can only do 8 gig but nascompare YouTubebchannel tried 16 gb.
Thanks for reply and marry Christmas to you.

Du auch gute Weihnachten und happy 2022!