Roon on bluesound node drops connection

Core Machine (Operating system/System info/Roon build number)

Mc mini 2012 I5 16gb fixed connection roon 1.7 build 528
Catalina 10.15.2

Only used as roon core

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

500mbps fixed connection using linksys velop with 3 nodes.
WHW03v2 firm

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound node on latest firmware connected via wifi
Mytek brooklyn bridge on fixed connection

Description Of Issue

When i stream music Qubuz and live radio on bluesound Node using roon it constantly droppes connection.
When streaming via bluesound app not using roon it works fine.
Not issues on the fixed endpoind (mytek)

Hi @Dirk-Jan_Westerink,

Welcome to the forum!

If you temporarily try connecting the Node via Ethernet to one of the nodes, do you see similar issues occurring? WiFi is more susceptible to interference, so this would be a good test to confirm if this is what’s going on here.

Hi today i listened the whole day to the bluesound Node connected to wifi not using the roon core but straight via the bluesound app without any issues. When I select the bluesound endpoint in the roon app it starts dropping the stream constantly,
Meaning its not the wifi connection.

Bluesound node on wifi via roon core stream drops
Bluesound node on wifi not using roon core stream Ok.
Bluesound node connected to ethernet no problem.
Bluesound node app says that wifi signal is Strong.

It is not logical that stream on bluesound node drops with roon core on wifi
While without core on wifi it does not.

@Dirk-Jan_Westerink -

When you play to the Node via the Bluesound app, the connection is direct between the stream -> Node. When you play via the Roon Core, the audio processing first happens on the Core and then the stream is sent via the WiFi connection. There are more “jumps” for the audio to make before it reaches the Node, so this certainly could be a WiFi issue if it doesn’t reach the Node fast enough.

Have you tried connecting the Node via Ethernet and verified if it’s able to play properly though Roon? Even as a temporary test this would tell you if the WiFi connection is the issue here.

The core is fixed via ethernet. So the wifi stream to the bluesound node is the same with or without the core. Could be that the stream to the bluesound using the Roon core is more data heavy, but that should not have to be an issue with the Wifi nodes I use. It is not the wifi signal dropping if so it should also happen without using the roon core. All wifi equipment in my office via wifi works fine, watching movies via netflix, working on my laptop and having video calls, only thing that that does not work is streaming via roon core over wifi ?
Sometimes it works fine for a day but mostly it does not.

Yes via ethernet no issue, so its the data stream via wifi not fixed.

Could a faster core help, the core is fast enough loads fast etc but don’t know if this issue could be related,

Update :

Live radio: stream stops message cannot play internetradio station. The adress is maybe changed or temporary not available.

Qobuz stream : steam stops skips to next song . qobuz media is loaded slow. This can point to network or connection issues.

Music on local HDD streamed via roon core to bluesound no issue

When stream to a fixed endpoint (my mytek) via the same roon core No issue.

Only when I stream Qubuz en live radio via wifi to bluesound i have an issue when
I stream files on HDD to bluesound via wifi no issue
And to fixed endpoint no issues.

Hi @Dirk-Jan_Westerink,

This sounds like you could be getting a general networking issue, however it’s strange that you mention that you don’t see this behavior on your Mytek zone.

If this is only affecting your Bluesound zone, have you confirmed you’re on the latest BluOS version?

My network is really ok, 500mbps fixed at home connection.
Bluesound has latest firmware.

Update : at the same location, when i use my Ipad via the roon app to stream and play via bluetooth to me speakers the radio and Qobuz streams also stops.
When I play via the same app using the qobuz app and using the local radio station app (same station I stream in Roon) the stream does not stop for Qobuz but occisionally stops and starts again for radio but much less than via Roon

And strange stream does not stop when i play with my fixed endpont (mytek.)
Is does happen occasionally for radio but never for Qobuz.
Could be related on how large the buffer size is in the roon core and app and maybe also in the bluesound node.

I also contacted bluesound, the wifi strenght in the bluesound diagnose file says -51DB connection. My ipad at the spot where the bluesound node is located shows 100mbps speed. My laptop at same location even. 200 mbps, I work from home now Since 6 weeks, video calls all day, never drops.

My conclusion : the qobuz stream and radio streams to the roon core can of course drop and that could be at the source (think that This is the case) depending on the size of the buffer in the roon core it drops toward the end point.
The question is when send over wifi to the roon app and bluesound node
How does that work with buffering. The radio signal does not restart, if that would be changed this would already help.
Another thing when using the bluesound Tunein for radio using the same radio station it plays all day. That also triigger me its buffering in the roon app and bluesound roon stream. On the bluesound node using the bluesound app no issues.

Hi @Dirk-Jan_Westerink,

It sounds like you might have a WiFi deadspot or some interference with WiFi in that particular area of your house if both Bluesound and the iPad is affected by the issue.

If the behavior occurs for the Mytek zone as well (even if it’s less frequent), it could point to a DNS issue on the Core.

We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS.

If you wish to give this a try can you let me know if it helps?

Again: Qobuz.
Works 98% ok on fixed endpoint via roon core drops sonetimes very little
Works 100% ok on Ipad and Iphone via qobuz app
Works 100% on bluesound not using roon
Does not work OK via wifi on bluesound via roon
Does not work OK via wifi roon app via ipad and Iphone via roon

All played on same location, if it would be related to wifi it would happen in all situations. It only happens when using the Roon core.

The radio channels works 100% ok in tunin via bluesound and tunein on ipad and iphone. It does stall on the local NPO 2 app on ipad, and iphone.
Radio NPO2 does stall on the Roon Myradio via ipad/iphone and Bluesound,
Also stalls via fixed roon endpoint but much less.

My fixed internet network is 100% ok, I use high end cat 7 cables, high-end switches. Incoming router of isp Is in bridge mode straight to linksys velop for wifi.
All power lines are separated from ethernet as much a possible.
All power cables and plugs are high end audio graden and schielded

All my devices at home in any location work 100% ok on wifi also at the location mentioned The only issue I have are with audio streams that stop when played via the Roon core. And only with sevices like qobuz and radio not with local files also not Local files over wifi. I have a dedicated macmini (late 2012 i5 16GB) as core fixed in my network with no other programs running.

Only when i use the roon core software and roon app software in relation with qobuz and myradio i have issues.

Today i played via my bluesound using tunein radio npo2 all day without any interruption. I tried 10 minutes via Roon on bluesound and it dropped all the time.
So i dont see any relation with wifi or network issues.

Any update ?

Hello @Dirk-Jan_Westerink,

Thank you for clarifying the behavior. Since local content works as expected, I believe this issue is from the External network -> Roon Core.

Even though the other native apps work properly, for Roon to work, all the audio processing must happen on the Core before being sent to your endpoints.

As for next steps, I’d like to take a look at your Roon logs to see if we can gather some more information that way.

Can I please ask that:

  1. You try starting playback to your iPhone or iPad zone and let me know the exact local time + date + track of the next issue and let me know this info here.

  2. Try starting playback to your System Output zone on the Mac (The Mac’s internal speakers) and verify if there are any issues when playing back to this zone. If there are issues please let me know the time + date + track here.

Once I have these two timestamps, I can enable diagnostics mode for your Core and what this action does is automatically generate a diagnostics report and upload it to our servers for analysis.

Thank you!

I am getting the exact same behavior with two different Bluesound Node 2i’s and one Pulse 2i. If on ethernet cable, all works perfectly. WiFi for Roon rarely works. WiFi with SiriusXM app via ApplePlay works all day, no issues. Bluesound app for other music services works fine wifi or wired.

The ONLY consistently problematic combination is WiFi with Roon. I got these devices specifically to use wirelessly with Roon. Very frustrating.

Hello @Ivor_Benjamin,

Please see my post here regarding this issue:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.