Roon on Debian Linux Problem

@danny is there any other way to move forward with this? is discussing the problem through this forum the fastest way to get the proper support from Roon?

@danny @noris why am I not receiving timely support again? I’ve been very cooperative but mentioning you guys over and over in this support thread and not receiving any replies is already something.

There was an OOM issue caused by a logging/debugging database that could get corrupted. It was fixed in recent Roon releases, but corrupted versions of the database could still stay around and continue to cause the issue. I suggest you stop RoonServer, go to …/roon/RoonServer/Database/Orbit, move out orbit_v3.db, and restart.

Ahh, so this was a known issue all along? Can you re-link me to that page that discusses this? The one you linked is not working.

Also, do you know which “recent releases” fixed this issue? If you backread above my latest test was from 6 days ago with the most recent Roon Core release at that time yet the issue is still present. That release at that time is pretty recent and I’m not sure if there are other releases after that.

Build 933 is the latest and greatest which was released Monday the 25th I believe.

2 Likes

I don’t know what other link to share, the one I included in my earlier post works for me. In any case, just try what I described in that post, it won’t affect anything else because orbit_v3.db is only used for error reporting.

Doesn’t work for me, either. The page appears to have been marked private. Maybe you have posted into that thread and therefore can still access it.

But I remember that thread and the proposed workaround by deleting the orbit_v3.db folder. That seems to have helped several people…

It’s also marked as private in my case. Was this an old thread? If it is, then I don’t know if that will help but I can certainly try. If you remember, I already deleted the whole /var/roon folder several times before reinstalling. That’s as fresh as it can get.

I fixed the link to something you should be able to see.

Yeah your last post there was 16days ago which you said at that time was supposedly fixed by the latest Roon Core version at that time. I’m sure I was on one of those versions when I was troublehshooting this and it didn’t fix the issue for me.

As a workaround, the Core is now running on my Windows machine temporarily until someone from Roon can help me fix the problem I’m having with my NUC.

Hi @Kevin_Mychal_Ong ,

Thanks for your patience here while we discussed your case further internally. There does still appear to be some kind of memory leak in the most recent logs you sent and there appears to be quite a bit of networking activity in the background.

In a similar case to yours, the issue ended up being due to IPv6, can you confirm if you have IPv6 enabled on your end? Is there any change in behavior if you disable IPv6? Also, is there any change in behavior if you try to reinstall RoonServer on the Debian and not use a backup, does the issue still occur?

2 Likes

@noris, thanks for the feedback. I do have ipv6 disabled on the router level of my network (pfsense) but it is still enabled on the NUC itself as that’s the default. Do you have any reference thread that discusses this ipv6 issue in detail? I can try disabling ipv6 and hopefully I don’t break anything.

And yes, if you backread again I’ve tried reinstalling the Roon Core several times and started fresh (no restoring from backup) and that did not make a difference.

Hi @Kevin_Mychal_Ong ,

Please see the following thread:

Do let us know what happens with this change, and hopefully most of your devices are on IPv4.

2 Likes

@noris I haven’t disabled IPv6 yet but I tried installing back the roon core on the NUC and it’s been running for about three days now without being stopped unexpectedly. However, the RAM usage is still very high! It is also filling up my swap space (which is only 1GB) constantly until I restart the service. Could this still be caused by IPv6? I don’t want to disable IPv6 unnecessarily.

Hi @Kevin_Mychal_Ong ,

That’s a promising sign, I hope it holds up.

I’d wait to see if issues crop up again and then consider disabling IPv6, if not then you can leave everything as-is.

I’m seeing the same problem all of a sudden. I reinstalled core (the easy shell script way) but still seeing the same issue. Is there a better way to do a clean re-install?

Exact same problem meaning the service stops unexpectedly after some time and you can’t restart it anymore unless you reinstall from scratch?

@Kevin_Mychal_Ong personally I don’t believe Zulu’s issue is the same as yours. Obviously I could be wrong, he started his own thread but his logs did not show any of the memory issues.

Andy might be right, whether my issue is the same OOM or not, I’m not sure yet. What I observe is that the roonserver service constantly comes up then dies pretty quickly afterwards. It was working fine for years. I do, as a matter of routine, keep upgrading roon on my server, and I can’t think of any other changes recently. And to answer your question, @Kevin_Mychal_Ong, a reinstall does not solve my problem, which is why I was asking whether there’s a better way to do a clean install from scratch.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.