Roon on external SSD via eSATA to Synology

Hi All
Can I run Roon Server on ext SSD connected to my DS411+ via eSATA?
It works via USB 2.0 but via eSATA failed to run Roon Server package.

Is your esata ssd listed in your shared folder settings?
It should appear there by default as “satashare1” (if I remember correctly)…

Exactly. And i can’t change the name to RoonServer.
However i changed it once connected by USB and reconnect to eSATA.
In that moment i have ‘RoonServer’ shared folder via eSATA. I can install Roon package, but i can’t run it. Log says that shared folder ‘RoonServer’ doesn’t exist.

I will check that scenario. I have not tested it yet. I am pretty sure we can sort this out.

I think I found the cause. Give me a little time and I will try to adjust one script in the RoonServer SPK file.

I just tried an external sata drive on my synology. I noticed, it is not possible to rename the share for esata-shares (also not possible on your device?).

This is an issue regarding how the current package locates the destination for the Roon database.
Technically it would be possible to use a esata share, but I have to think about it how to implement it.

The current package includes a script which checks the internal and usb volumes for a network share called “RoonServer” to get the database location. This won’t be possible with the esata share, as it seems it can’t be ranamed. I have to think about a different procedure to enable esata shares for RoonServer’s database location.

One idea I currently have is to use the “Description” box to identify the share for external devices… But I have to think this through…

Thank you Christopher
I did a trick. Connected SSD via USB than edit the name to RoonServer and reconnect via SATA.
Synology remember and keep the name RoonServer via SATA!!! But unfortunately package doesn’t see it!

Check if you have at least DSM 4.1 installed and check the read/write and owned user settings on the external drive then add it to the media index as well, hope that does the trick.

best regards,


Any solution to this problem yet? Here I am a year later trying to figure out how to install Roon on the DS1815+ with the library on eSATA SSD. I read through long threads about how easy it was with a USB SSD and couldn’t understand how people named their share “RoonServer” until I found this thread. My problem exactly - can’t rename eSATA share. Please mention this in your installation instructions.

The last post from @Marcin_Witkowski indicates that connecting the SSD through USB, renaming and connecting through eSATA didn’t work. I would try this but I need to find a USB enclosure. Is it worth trying? Can anyone else confirm whether it doesn’t work or the suggestions in the above post help resolve the issue?

eSata shares can’t be renamed on Synology. Use the description field in the share settings and enter “RoonServer” there.

Thanks for your prompt response. I changed the description field but it didn’t work. I got a message “Failed to run the package”. Here are screenshots of the log and the share settings:
ERROR: Shared folder “RoonServer” could not be found.

Any other suggestions?

I will check it later when I am home again…

Thanks. I will be waiting for your solution. Meanwhile, I found a workaround. I am not sure if it is good. I am just starting a Roon trial and can restart from scratch in a couple of days using your solution.

Also, I am a bit surprised that almost nobody uses eSATA for external SSD’s. It seemed to me natural to connect the SSD via eSATA, the native protocol for SSD, rather than going SATA-to-USB. I found the cable that plugs to SSD (or HDD) on one side, and on the other side has an eSATA plug for connectivity and a USB plug for power only. In case anyone is interested: I’ve seen various other cables like this on eBay, too.

Now, my workaround. I found this video on how to create a shared folder on an external drive in Synology, which isn’t possible without this “trick”:
The “trick” is to create a shared folder on the array and a folder on an external drive and “mount --bind” them. I removed the description from my eSATA share not to confuse your script just in case. Then I simplified the procedure by putting the mount command directly into the task scheduler to run on boot: mount --bind “/volumeSATA1/satashare1-1/RoonServer” “/volume1/RoonServer”
I had created a RoonServer folder on the SSD and a shared folder RoonServer. I SSH’d into my Synology to find the paths. After executing the above command I started the Roon Server and it started normally with all OK’s in the log. I also see folders created by Roon on the SSD.

Again, I am not sure if this workaround is good or I will run into problems in the future, maybe after updates. If you can fix your script where changing the satashare folder description to RoonServer will work I will revert my workaround. Meanwhile, I thought this post might be useful to people struggling with eSATA connected SSD’s.

I have to test this again. I actually added some lines in the script to find seat shares as well quite some time ago.
But unfortunately I gave my esata equipped case away to a friend. I just texted him and will report back as soon as could re-check…

I had a look at your helper script getsharelocation over at your github site. I am not fully competent to interpret the script but I can see that both sections querying dirnames volumeUSB and volumeSATA are identical. They both look for “display name” in “/usr/syno/etc/”. I think the volumeSATA part should look for “comment”. That’s the field that corresponds to Description in the folder properties.

I would have tried this little change but I don’t know how to modify the package. The helper script is inside another archive inside the package.

I’d like to report that I gave up on using an external SSD connected through eSATA with Synology. It’s buggy not only with Roon. I wanted to have a key manager store on the same SSD. Synology claims it can be on any external storage, not necessarily USB. It would let me initialize it but then simply wouldn’t accept my just defined passphrase without any error message. Once I tried it with a USB drive it worked. So, I bought a USB enclosure, reversed the above “trick” by simply deleting the scheduled task and rebooting. And reinstalled Roon server on the freshly formatted the same USB-connected SSD without any issues or “tricks”. I didn’t even have time to use Roon, so I didn’t care about the database.

I am posting the details primarily for people who want to go this way with an eSATA SSD. At this point of time my recommendation is: don’t do it, get a USB enclosure. It seems that eSATA on Synology is a rarely used interface that even Synology doesn’t care much about it leaving bugs in the system.

I think if @crieke fixes the script and Roon will install on eSATA SSD without workarounds it would be great, and it was my original intention to use it this way. But I also wanted to use the same SSD for other miscellaneous things and Synology wouldn’t let me.

I will definitely take a look at the script again, once I have my eSATA case back. I was actually testing all scenarios in my setup and it was working back then. Let’s see if I can find the cause…

1 Like

See my post two posts up. I am pretty sure it’s not working because the “getsharelocation” script is looking for “RoonServer” external device by name, not the description. It works for USB because it can be renamed, it doesn’t work for SATA because it can’t be renamed. Good luck and thank you for making it work on Synology.

It does both. First it parses the and reformat into a variable to make the content easily accessible in bash.

If it finds a “RoonServer” share, it will have priority. And variable is set/increased.

if there is no share with RoonServer in the “display name”, another check (for eSata devices) will run an additional check to look at the comment field (=Description).

The difference is what is put in the SHARE_ID array in line 32:

SHARE_ID=($(echo "${SHARE_CONF}" | egrep 'comment.*$' | grep "=${ROON_SHARE}$" | cut -d "[" -f2 | cut -d "]" -f1))

I see. I missed it. I can say that I definitely saw “comment=RoonServer” (don’t remember the exact syntax) for my eSATA share when I inspected my file. I hope you will find out why it didn’t work as expected, and I hope it’s not another Synology bug.