Roon on Fedora 24


I had a rush of blood and accepted an upgrade to Fedora 24 and Roon is not working anymore.

Has anyone else found this and/or found a workaround/fix?

Cheers, Nick

[42 RoonServer]$ sudo ./

Checking to see if RoonServer can run on this machine

Checking for Binary Compatibility                            [   OK   ]
Checking for ALSA Libraries                                  [   OK   ]
Checking for ffmpeg or avconv                                [   OK   ] which: no avconv in (/sbin:/bin:/usr/sbin:/usr/bin)
Checking for the mount.cifs command                          [   OK   ]
Testing ulimit -n 8192                                       [   OK   ]


Note: ulimit -n 8192 fails when is run as non superuser

[gy42 ~]$ systemctl status roonserver.service
● roonserver.service - RoonServer
Loaded: loaded (/etc/systemd/system/roonserver.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Tue 2016-08-09 22:35:42 AEST; 3min 40s ago
Process: 880 ExecStart=/opt/RoonServer/ (code=exited, status=203/EXEC)
Main PID: 880 (code=exited, status=203/EXEC)

Aug 09 22:35:42 gy42 systemd[1]: Started RoonServer.
Aug 09 22:35:42 gy42 systemd[1]: roonserver.service: Main process exited, code=exited, status=203/EXEC
Aug 09 22:35:42 gy42 systemd[1]: roonserver.service: Unit entered failed state.
Aug 09 22:35:42 gy42 systemd[1]: roonserver.service: Failed with result ‘exit-code’.

Roon Server seems to be running when you manually start it as root (or sudo) the script.
So I guess, there might be something not working with the roonserver.service script in combination with fedora 24.

I think SELinux is causing this issue.
I tried (as root) to disable it

setenforce 0

and afterwards I started the roonserver.service again:

systemctl start roonserver.service

This time it started properly. So I guess there needs to be some adjustments regarding SELinux.

Is there any news on this? I installed Fedora 25 today and installed Roon (after adding ffmpeg) which SELinux seems not let start, so i have to manually start the script as sudo, which works (thnx @crieke).

I would like to let Roonserver start as normal on other Distributions, soo the Roonfolks should please do something in the Installscript that gives RoonServer SuperPowers to overcome SELinux! Maybe in 1.3? Maybe before Christmas?



I just upgraded to FC 25 and Roon is running fine, apart from the high-res issue that has its own thread. Mind you, I have both SELinux and firewalld disabled.

I don’t use SELinux, so I’m not disappointed there. And this machine is behind another firewall, so that’s not too big an issue for me, either. That may be cold comfort for you, though.

I asked in another thread if anybody knows the parameters for a firewall rule to allow Roon and heard crickets in response.

Roon is running fine… Mind you, I have both SELinux and firewalld disabled.

I have neither disabled and I’m running RoonServer on Fedora 30, under a new user “roon” instead of as root. I initially installed the software manually to /home/roon but systemd couldn’t start it, giving roon.service: Failed at step EXEC spawning /home/roon/RoonServer/ Permission denied errors in journalctl. It turns out SELinux doesn’t like service code in home directories (look for avc errors in journalctl, not just roon service errors)… So I moved RoonServer to /opt/ , but it still didn’t work because I had to reset the security context of the files to avoid the taint of home with sudo restorecon -rv /opt/RoonServer. Then I could start RoonServer with sudo systemctl start roon and even run it as User=roon.

I asked in another thread if anybody knows the parameters for a firewall rule to allow Roon and heard crickets in response.

Someone posted here that in later Roon software, you need to enable UDP port 9103 and TCP ports 9100-9200. You can do this by adding these ports to the default zone (probably “public”) in the graphical Firewall Configuration tool. You can also create a roon-server.xml file for the firewall rule, and load it in with firewall-cmd --permanent --new-service-from-file=/path/to/my/roon.xml; I think you have to kill and restart the firewalld daemon to make this new service show up in Firewall Configuration, and then you can check the service roon-server to enable it.

Here’s the roon-server.xml firewall rule file I created:

<?xml version="1.0" encoding="utf-8"?>
  <short>Roon Server</short>
  <description>Roon Server from Roon Labs plays music per instructions from Roon Controllres</description>
  <!-- per -->
  <port protocol="tcp" port="9100-9200"/>
  <port protocol="udp" port="9103"/>

Once enabled I can see my Roon Core from Roon remote on my phone.

With these set up, I think I’ll have a RoonServer that starts automatically in Fedora. I haven’t got into RAAT and other devices, so maybe more needs to be tweaked for the service to work. And me not running roon as the root user will probably stop it from automatically mounting network drives.