Roon on iPhone sometimes does not show up as an audio zone

Thanks for your reply. I’ll open up the DAC issue in another thread.

1 Like

Hello @Sevenfeet,

I have a few follow-up questions as to help with the investigation, can you please let me know:

  • What is your network setup like? Please list the model/manufacturer of your router, any switches, range extenders, powerline adapters, ect.

  • We have the attempts that you noted on March 7th, but the March 13th attempts have not reached out diagnostics servers yet. Can you please open the Roon app on your phone and leave it open a few minutes so that this report also is included in the investigation?

  • Can you please reboot your Core + iOS device and reproduce this issue once more with everything in a fresh state? This will give us some additional traces to compare to the previous timestamps you noted.

Thanks,
Noris

OK, the Roon app for iOS is open and I’ll leave it open for a few minutes. Also, the problem is occurring now with it as the device in “Audio” is stuck on “Enabling…”. I launched it at 3:31 PM CDT, 4/1/19. I cannot reboot my phone right this second since I am on a long customer call right now. I did try it again at 3:58 PM CDT 4/1/19 and this time it did properly enable my iPhone as a Roon client.

My network backbone is a Netgear GS116 16 port gigabit switch sitting in my basement. There are a few downstream switches serving various functions. I have two Netgear GS108 gigabit switches, one on my desk serving my 2008 Mac Pro desktop machine and other nearby devices, and another serving the home theater rack (an Oppo 203 Roon client lives here). The Roon Core (which is another 2008 Mac Pro different from my desktop machine) is connected directly to the GS116 through a six foot Cat 6 cable in the basement. The only non-Netgear switch is a D-link DGS-2205 5-port gigabit switch serving our Sun Room/Kitchen where an elderly 2010 Mac Mini serves as a Roon client connected to a Denon X2000 receiver.

There are a number of wifi routers on the network, though some are just functioning as switches with wifi off. The main ground floor network wifi router is an Apple 6th gen Airport Extreme connected directly to the Netgear GS116 through a cat-6 cable (about 30ft).

Also on the ground floor is a Apple 2nd gen Airport Express 802.11n (hooked up to the home theater Netgear GS108), another Apple 2nd gen Airport Express 802.11n (sitting in the 2 channel room) hooked up to an old Apple 2nd gen Airport Extreme (which is connected directly to the GS116). This Airport Extreme is just operating as a switch since it was available. Wifi is off for both units in the 2 channel listening room. The function is the Airport Express is for Airplay 2 service for Apple Music as a backup to Roon/Tidal. The 2 channel room has an old 2008 iMac hacked to run Windows 10 which is solely a Roon music kiosk, as well as an Oppo 205 which can speak to Roon directly.

Upstairs in our house is a Netgear R8000 wifi router functioning as a wifi access point, hooked to the GS116 through a long cat 6 cable (probably 80+ ft). And finally there is an old Apple Airport Extreme in our bedroom, ,again just serving as a switch with wifi off. It is also connected to the GS116 through a long Cat 6 cable (not the same as the Netgear).

The local LAN has been very stable over the years with only a few bad actors causing problems over time. But right now, everything is stable. All devices that can be wired in my network are wired (desktop computers/servers, TVs, receivers/prepros, an Oppo 203 and 205 and a host of other things. Wifi devices include phones, iPads, laptops and IoT devices. WAN to the outside world is a Comcast gigabit ethernet connection (connected to the Apple 6th gen Airport Extreme at the center of the network, which then feeds the GS116. All long household network cables are either Cat 5e or Cat 6. I wired and terminated the entire network myself except for where I used a contractor to pull several Cat 6 wires between the basement and attic.

Hi @Sevenfeet,

I know it’s been a bit of time since we last spoke, but I just wanted to come back to you here and let you know that we still have some work in progress in trying to tackle this issue.

Our QA team has spent quite a good amount of time testing this behavior and verifying if locking the screen triggers this issue or if navigating out of the app triggers it, ect. but so far they have not found a way to consistently reproduce this behavior, it appears to occur randomly as far as we can tell.

Getting this behavior reproducible consistently would be something that is needed before we are able to file a bug report with the devs, otherwise any changes they make on the dev side of things will be very difficult to verify if it resolves the issue.

These kinds of issues are the trickiest to narrow down, since there could be a wide range of factors that trigger this – iOS internal “hibernation” features, a very temporary network disconnect between the Roon Remote and the Core, the iOS audio drivers themselves, and it is difficult to pinpoint at this present time.

With this in mind, I wanted to ask you here, is there any consistent set of steps that will place you into this state? Even if it is not every single time you use the app, any further feedback you have on what could cause this to occur will be useful. If you want to try some experiments here, the team has noted that simplifying the network to the bare minimum might allow us to get a good data point.

By this I mean, if you compare how often it occurs per week now and you then remove the switch from the equation and leave just the router, does the number of times that it occur go up or down? If you add more complexity in, is there any change in that way? That’s a good data point for us to know and would be useful, so do let me know how often you are still seeing this presently and then how often if you add/remove complexity.

We are going to keep trying to make this behavior reproducible in the lab but if you have any further suggestions as to what can trigger it, please do let us know.

Thanks,
Noris

A post was split to a new topic: iPhone - Audio Endpoint Missing

I’m wondering if there has been any resolution of this issue. It happens to me probably daily. I’ll be listening to Roon at home via my AirPods and iPhone. I’ll pause a track or stop playback. Later I’ll try to play something else and Roon won’t recognize my iPhone as a zone, only my DAC in another room

I’m not sure I answered support’s question from back in April. So if it helps, I still see this problem all the time, and no, I haven’t been able to come up with a consistent method for triggering the problem, just that it happens ALL THE TIME. In fact, I decided to try it now, right after I replaced the super slow hard drive in my Roon Server machine with an SSD. And the iOS app was still not showing itself as a Roon endpoint. In Settings->Audio, it’s frozen in the “Enabling” part, with no change. The only way to get past it is to disable the target, then re-enable and then most likely it will work. i say “most likely” since that still isn’t a guarantee.

Since this is an issue when it does try to enable the device as an active Roon endpoint and just sits there without resolving it, my initial guess is that there is a communication issue between the iOS device and the core. But as Noris pointed out, there could be other things going on here that is interrupting the process. And since I don’t have the code for a code review, I can’t offer any ideas that are better than pure speculation. I also haven’t seen a logging mechanism that users could turn on for more data to examine…that might be useful in a later version of Roon.

As to the suggestions about network complexity or latency, well while my household network is more complicated than the typical house, I can’t imagine anything I’m doing that would be all that unusual in terms of network hardware, outside of the age of some of the pieces. My Roon Server is a 2008 Mac Pro (8 core, 16 GB of RAM) which was running High Sierra (yes, hacked to do so) for years until I very recently upgraded it to Catalina and moved the boot drive to an SSD. Yes, everything is faster now, but I can’t say that Roon is any different. Main storage are several hard drives (four internal), one Drobo 4 bay (Firewire) and one Drobo 5D3 5 bay (USB 3 via a PCI card). Roon’s music targets are all on the older, slower Drobo 4 bay. I’ll move it to the Drobo 5D3 once I upgrade a hard drive for more storage.

As for my network, my house is all Cat 5e, Cat 6 and 6a Ethernet depending on when it was installed. All devices in the house that can be wired (smart TVs, Apple TVs, desktop computers, servers, etc) are wired. I use a Netgear GS116 (16 port gigabit) as the backbone with GS108 (8 port gigabit) and GS105 (5 port gigabit) around the house when i need more ports. There are two working wireless routers…an Apple Airport Extreme 6-gen which is directly connected to the GS116 (Cat 6a wire) and is the main household router. A Netgear R8000 handles the top floor, also directly connected to the GS116 via Cat 6 wire. Network latency is pretty nice all around the house. Wireless spectrum is reserved for devices that cannot connect wired…laptops, iPhones, iPads, IoT devices). it doesn’t seem to matter where in the house I am that triggers the problem with Roon; it doesn’t matter on the controlling router.

In order to accomplish what you want me to do, I’d have to bypass the GS116 switch and directly connect the Apple Airport to the Mac Pro server, which would disable the rest of the house…not easy to do with a family all at home due to COVID and often watching content. I was hoping that the new SSD might be a potential fix with reducing latency but that didn’t work.

I also have this happen periodically. Like the others said, after I have paused the music and possibly have walked away for a bit. Happens on my iPhone and iPad.

I have the same problem on an iPhone XS

I noticed that Roon on iPhone sometimes shows up in Zones list in Roon core and sometimes disappears from the list. The other times is not showing up at all. After looking at different zone options available on iPhone I found that iPhone zone was set to private. After making change, iPhone was visible to Roon core. The other issue is that pausing playback using pause/play button causes iPhone app to loose connection to core. Closing app and removing from memory (double tap and swipe) than reopening it fixes the problem. Interestingly, when playing through AirPods, when you remove one of them, playback pauses, but it continues playing when put both AirPods back. Lost connectivity is an issue and it is not LAN related but app related.

I’m experiencing this issue. iPhone XR.

Having this same issue now. Roon 1.8 not recognizing the iPhone it is open on. I’ve tried disabling and re-enabling. Restarting the phone. Restarting Roon Core.

Here’s a workaround that I’ve discovered seems to work.

Launch another music service like Apple Music or Tidal. Play something for a few seconds.

Leave the app and relaunch Roon. For some reason, Roon now will see the iPhone as a destination.

I’m experiencing the same issue on my iPad Pro. In 1.7 I was able to work around. Now with 1.8 it never shows up.

This seems to be as random as a very random thing. On my iPhone XS, 1.7 was intermittent, but so far 1.8 has showed up every time.

iPhone 12 here and it shows up under Audio, but no way to enable it. Any suggestions?

Hello All,

Thanks for the feedback here, we’re still looking into this one.
If you force quit and re-open the Roon app, this can help in some cases.

Hi,
It is now June 2022 and I have the exact same problem with my iPhone and iPad running the latest version of the Roon OS (Roon ROCK) and both my iPad and iPhone have the latest iOS and the Roon app is version 1.8 (build 1970). I think I was able to use the built in audio on my iPhone and iPad twice. All other times including now it is not found. This is definitely some kind of bug.
Should I submit a bug report or is this still a work in progress?
Thanks

Always start a new support thread for your own issues. Especially don’t tag on a two year old thread.

Got It…
Thanks…