Roon on NAS Loses Ability For All Remotes to Connect Constantly

I’m having a terrible time with Roon. Roon Loses Ability For All Remotes to Connect @support

I have a QNAP TS-453B, 8 Gigs Ram, Two 500GB M.2 Cache Drives, Two Drives in a Raid 1 with 6 TB, SSD of 500 GB for Roon Server. My Music is 2.85TB. Roon Server is 1.4(Build 310) . Firewalls disabled. (Kaspersky and Windows 10). The router is an ASUS AC5300.

My original install stayed functional for about a week. Now the connectivity disappears after a few days. The only way to get it to work is to do a fresh Roon Server install and to rebuild my library. If I use the back up and restore it the connectivity still fails to allow remotes to connect. This annoying and it takes forever to rebuild the library. I am getting very frustrated with these issues. When it resided on a Windows 10 Notebook it was flawless. When it is working it works well! I don’t know if this error is the culprit but:

Error in QNAP Command Line: Loading additional 64-bit Libs: false

One other thing. Up until today, Roon server was residing in System processes. As of today, it’s back to showing as a separate application with all related processes.

Hi @Watchdog507 ---- Thank you for the report and sharing your feedback with us. The insight is appreciated and sorry to hear of the troubles.

Moving forward, to help aide in our understanding of this behavior you are experiencing with your remote devices, may I very kindly ask you to please provide the following information:

  • From your screenshot it appears that the example is being provided from Win 10 device, is this the Notebook where the core had previously resided? Additionally, can you please provide the make and the models of the other remote devices that are experiencing the issue.

  • Please describe your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing (i.e router, switches, powerline adaptors, etc). I want to have a clear understanding as to how your various devices are communicating and all the “tools” involved with making those connections possible.

  • While it may seem elementary, since noticing this behavior have you tried power cycling not only the new core machine (i.e QNAP TS-453B) and remotes, but any relevant networking hardware as well (i.e router, switches, etc)? If so, what was the experience like?

  • Additionally, what is the experience like when the following tests are performed:

    TEST #1:

    1. Shut down your Core
    2. Open Roon on your Remote
      (Tip: If you are using a phone, make sure you keep it awake)
    3. Roon should be on the “Searching For Core” screen
    4. Start up the Core

    TEST #2:

    1. Start up your Core
    2. Open Roon on your Remote
      (Tip: If you are using a phone, make sure you keep it awake)
    3. Kill the Roon app
      (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
    4. Restart Roon on on your Remote

Something to consider with your setup…

The mentioned QNAP NAS is making use of an Intel Celeron J3455 quad-core 1.5GHz (benchmark) which has the potential to cause performance issues as it is falling below our recommended specs.

I want to be clear that I do not believe that the behavior you are experiencing with your remotes is related to the NAS. I am merely pointing out the above as a, “head up” because I want to make sure that you get the best experience possible while using Roon, and if there is an underpowered device driving the system you may encounter limitations moving froward.


Both the QNAP and the Router have been rebooted many times. Both hard and soft processes. This has no impact on the ability of the remotes to connect.
My Desktop is an ASUS Win 10 using ethernet. My Notebook is HP Spectre 360 Win 10 using ethernet, my phone is iOS 7+ using wireless. My desktop and my notebook are connected via ethernet directly to the router as is the QNAP. Although the notebook has to acquire signal through 2 switches. This has not proven to be the problem. Nor has the Celeron proven to be a problem. If QNAP paid attention to it’s base they would allow us to put an i7 in a 4 slot enclosure. When my system worked it was flawless. I doubt the processor has any effect on connectivity.

Test 1 Done: failed the remotes see the connect button when engaged you get the white screen with the pulsing orb and no connection.

Test 2 Failed ; Goes back to the amber circle and Initializing with a greyed out connect button… The remotes can see the Roon Server but cannot connect.


There is one more remote/end point a PS Audio DSD Bridge II for Roon. This is my primary listening device.

One more thing the Firewalls are disabled and the NAS has a static IP address configured in the router.

It seems like there is something at the Roon Server end blocking connections. The remotes see the Server but can’t connect.

I can acces the NAS directly from any remote device with browser/ IP Address

Hi @Watchdog507 — Thank you for the follow up and the continued feedback, but more importantly thank you for your patience here.

Continuing forward, I had a chance to discuss this issue with the tech team this afternoon in further detail and their advice here was to continue working to localize the problem. I mentioned to the team that the NAS is falling under our recommended spec and they have concerns that this maybe contributing to this behavior, but before we start to go down that road I would like to try to isolate some variables here.

  1. In you initial report you mentioned the following:

    " The only way to get it to work is to do a fresh Roon Server install and to rebuild my library."

    • My assumption is that you are starting with a fresh DB on QNAP each time you perform this action. Is this indeed the case OR are you restoring from one of the mentioned backups in your report? Can you let us know the exact steps you’re taking here?

    • If it is indeed the latter and you are restoring from a backup each time, would you kindly verify what the experience is like with a fresh DB in place. This will help us rule out any issues with the database. I would recommend making a backup of your current DB first before carrying out this test.

  2. Since experiencing this issue with the QNAP have you tried running the Core on the WIn10 Notebook again? If the remotes can successfully connect to that device, we can rule out a number of environmental factors, and localize the issue to the QNAP.

Looking forward to your feedback!


Thanks for getting back to me. In the past if I used the backup copy of the Roon Database the connectivity failed immediately. When I did a fresh install of the app and the database it worked.

Although the concern about the CPU is valid, If you look at the configuration that I have with Caching and SSD’s it should be fine. As I indicated it worked beautifully when it connected. The connectivity is different. As I said above, ROON Server was residing in System processes for some strange reason but the connectivity was there. Now it was back to a running app and the connectivity wasn’t there.

I have just set up Roon Core on my Notebook and it’s working fine and it’s ethernet connectivity about 100 feet back to the NAS Server for the music files.

I have a friend running Roon on a small 2 bay QNAP device with a non optimal processor and it works very well.

I was hoping to have this sorted out for the weekend. Do you have some ideas as to why the connectivity fails on the NAS Server. When roon worked, it was great. I would like the Roon connectivity issue resolved. I was going to move to Lifetime but flakey connectivity may make me weigh other options.

Someone pointed out that background processes can impact Roon. I was running a background process for library analysis. I’ve killed it and I’m going to try a NAS reinstall.

I’ve installed Roon Server on the NAS again. I’m streaming music and the Roon Appliance process is the most active process at 1.7 GB of memory and .12 - .25 of 1% so it’s not stressing the CPU in the least. Hopefully the closure of the background processes will alleviate the problem.

Roon is behaving for me now. I shut down every process in Roon that could possibly run in the background. I have to the app working correctly and it rarely breaks a minor sweat. CPU usage is a fraction of a percentage point. Even though they shouldn’t, my suspicion is that the background apps cause problems in the app. My advice is to kill all of them. Cleaning up the database or doing audio analysis is not important to hearing music.

I’ve added “on NAS” to the topic as this seems to be a specific part of the issue you are having. While it might appear to resolved too I will that to you and @eric to concur on.

As with most dual/multi purpose deployments on NAS or desktop systems that are not dedicated to running of roon only there can always be performance limits exceeded when other processes are running in the same system.

Similarly multiple simultaneous streams or significant DSP settings enabled can stretch the abilities of even the higher spec roon only systems.

The above quoted command line output:

is no error of the QNAP. It is just an indication that RoonServer is running on a QTS system (Version 4.3 or higher) that does not require additional 64-bit libraries. This is a totally expected behaviour and normal.

Hi @Watchdog507 ----- Thank you for the follow up(s) and my apologies for the delay. I saw the flags dropped by you and Wizardofoz, so I wanted to touch base.

First, have your remotes been stable since your last post? Are they connecting and staying connected to the core as expected?

Second, can you provide some insight into what process you had stopped that seemed to yield the change in behavior here. Was your library importing OR was Roon analyzing your files during this time period of instability with the mentioned remotes?


Hi Eric,

Thanks for the follow up. Yes the remotes have stabilized. The first time I lost all ability to connect was after I did a large addition to the music library. I have a large library and I was ripping cd’s that I had purchased. I added a total of 65 GB of music to a 2.85 TB music library and in the process of updating the Roon database, the remotes lost the ability to connect. The second time I lost connectivity was when the background processes for background analysis and on demand analysis were operating. Once I killed these processes, the Roon Server has been stable with respect to remotes connecting. These processes add nothing to the sound of the music so it’s not a loss to me.

These issues are most likely the fact that the cpu specs on a NAS are well below the minimum required by roon to support an ideal experience with the default settings…an under spec system is going to run up against more of these kinds of issues as your library and dsp demands grow.

@eric I think more needs to be done in the specs pages and maybe the troubleshooting pages to denote the kinds of issues that these under spec systems might exhibit when cpu’s can’t keep up, ram is not sufficient, disk speed is inadequate, network speed is degraded (wifi, EoP etc). Not just NAS in this regard but older spec PC/Mac/Linux machines where new users might be trialing Roon.

1 Like

Hi @Watchdog507 ---- I appreciate the update and am pleased to hear things have remained stable.

I agree with @wizardofoz’s comment about running a Roon core on an under spec’d device, and in my honest and humble opinion, I would consider hosting it elsewhere. As your database grows in size over time the likelihood or encountering performance related issues will increase. Again, just my opinion on the matter :innocent:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.