Roon on Nuc with windows 10 and Devialet dropout

Roon Core Machine

Intel NUC i7 16GB ram

Networking Gear & Setup Details

Unifi dream machine

Connected Audio Devices

Devilaet 250 pro expert

Number of Tracks in Library

22,000

Description of Issue

I have set up a NUC with windows 10 as core and I am experiencing dropout while playing on the devialet. This is with tracks that are on the hard drive, not streaming, I haven’t tried with streaming yet. The track keeps playing but the sound is gone for few seconds. I have been using the same exact setup with my iMac for the past 3-4 years without any issues and the network has not changed. As I read in the past that there are issues with the Devialet and giga ethernet I tried to insert a 10/100 switch and things got better but still there are dropouts. With the core on iMac using giga ethernet things were working fine. I have saved the logs but reproducing the issue is pretty easy, I just need to swap to giga ethernet and play a track.
I tried playing to another source like my iMac and it plays fine without dropouts. Just checked and it is also working fine on raspberryPi with IQ audioDAC pro using ropiee
Thanks

What bitrates are you playing…anything in the chain on wifi? Any DSP processing?

The Devialet gigabit problem was reportedly fixed in the last firmware, did you update? Depending on your router, it’s often possible to set port rate.

HI Mike,

yes I am running the last firmware available on Devialet website 13.2.0 Version2.2.6
As I said I also tried to add a switch that is only 10/100 before the Devialet but it still has the problem. The problem manifest itself as a 3-5 seconds of silence while the track progress and then the sound come back. I don’t exclude it could be something else. Like a wrong configuration on the NUC, It has been quite some time from when I had to dabble in Windows so I don’t exclude user error hence the support request.

Thanks for the help

You could try enablng it as a Devialet Air or even Airplay endpoint, though I use RAAT without issue. Perhaps just remove the audio device and re-add it in case some settings have changed…

I will try to delete and re-add and see if it works. I really would like to stick to RAAT as I can switch on/off the devialet and change the volume inside roon instead jumping apps.
Sorry but what do you mean with remove the audio device and re-add it? like disable it and re-enable it? Or there is some other way?

Ok I think something else is also going on Roon now keeps crashing, this is the event viewer log

Faulting application name: Roon.exe, version: 1.0.0.0, time stamp: 0x63188efb

Faulting module name: ucrtbase_clr0400.dll, version: 14.10.25028.0, time stamp: 0x5bac17b7

Exception code: 0xc00000fd

Fault offset: 0x000000000000f758

Faulting process id: 0x312c

Faulting application start time: 0x01d8c8109969912b

Faulting application path: C:\Users\Marco\AppData\Local\Roon\Application\Roon.exe

Faulting module path: C:\Windows\SYSTEM32\ucrtbase_clr0400.dll

Report Id: 7c913b6d-bde4-4fcd-9424-7117cfe3fb7b

Faulting package full name:

Faulting package-relative application ID:

what roon version are you running? is everything on B1105? The NUC is running Windows I gather, and Roon or RoonServer?

Roon build 1105, NUC running windows 10 pro. I am running Roon but I wonder if I should try RoonServer
I have done a backup of the database tomorrow I will uninstall roon, and install instead the RoonServer and see if there is any improvement.
unless in the mean time support has a different advice

I doubt that will change anything. Just asking so support has more specific info to work with.

You could try renaming the Roon library/database folder and start clean.

Look for database locations in the help / kb pages

I see, thanks for the help.
At this point I will hold until I don’t hear from support, weirdly enough this morning Roon started without a hitch. Just to recap, there are 2 issues in play.

The first issue manifested from the beginning and is the music stopping for several seconds on the Devialet while the track progress. A change of network port to 10/100 instead giga ethernet helps but doesn’t solve the issue. Streaming to a raspberryPie with Ropieee works fine, same streaming to an iMac.

The second issue started happening yesterday around 7pm NZ time when Roon started crashing repeatedly with the error I posted above. I tried to install .NET6 as suggested in an other post with the same .dll error but the crashes still happened. This morning I tried to start Roon again and it started without crashing. Also this morning I run sec /scannow and I got the report that some components were owned twice or had its security set twice. The final report was that the files were repaired. I am not sure how this could be the culprit but I have the logs saved in case they are needed.

While waiting for support. I will do a test trying using devialetAir instead than RoonReady and see if there are differences.

Few minutes after I wrote my last post Roon crashed again while streaming to my iPhone. I doubt I will try Devialet Air until roon is not more stable

Event viewer provide this

Faulting application name: Roon.exe, version: 1.0.0.0, time stamp: 0x63188efb

Faulting module name: mscorlib.ni.dll, version: 4.8.4515.0, time stamp: 0x624ce856

Exception code: 0xc00000fd

Fault offset: 0x0000000000566b65

Faulting process id: 0x1754

Faulting application start time: 0x01d8c87836dc6a13

Faulting application path: C:\Users\Marco\AppData\Local\Roon\Application\Roon.exe

Faulting module path: C:\Windows\assembly\NativeImages_v4.0.30319_64\mscorlib\b8493bec853ac702d2188091d76ccffa\mscorlib.ni.dll

Report Id: 158abcb9-bd34-4ec0-b1bf-b932f6828204

Faulting package full name:

Faulting package-relative application ID:

another update hoping that more info will help support.

I renamed the database and started from scratch, added only a couple of albums and the Devialet Roon ready.

Roon seems more stable, no crashes so far.

Streaming to the devialet works fine if at normal quality if I use sample rate conversion the long dropout start again straight away. I tried to limit the LAN speed of the ethernet port but Devialet complains that that audio is loading too slowly, so I tried to add the switch 10/100 between computer and router. I was able to play a couple of tracks without drops but that is consistent with putting the switch just before the Devialet, it works for 3-4 tracks and then issues start again.

I tried Devialet Air and, without adding the reduction switch, it played through a couple of songs without problems with Sample rate enabled. With RoonReady and no switch I can go barely through a track without drops. Only time the music stopped was when I got tired of listening to the 2 albums I moved over and added the whole Tidal library. The play paused during the import of ca 850 albums and started again when that was done.

Starting with a fresh database seems it helps with Roon stability but it means loosing all the tags I added to my library along the years. :cold_sweat:

My next steps from here:

I will sit on this for a bit, see how goes. If the stability remains before I commit to rebuilding my library from scratch I will try to uninstall roon, install the server version and start from my original back up from the mac version that I used at the beginning. The reason for this it is because when I started the whole thing, the only problem was the streaming to the Devialet. Roon instability came later and could be a product of me doing different tests to solve the issue (for example I installed the USB driver for devialet and then uninstalled them).
I am still curious why Devialet roonReady is not working as used to do with my core on iMac as I would prefer that option to Devialet AIR
BTW thanks for the help and suggestions that so far I received.

@support come to the rescue folks!

After creating a new database Roon so far hasn’t crashed so far.
My daughter listened to it for an hour streaming Tidal to Raspberry Pi with IQ audio Dac pro without any issue.
This evening I did some further tests with the Devialet. I used a 96 kHz album 24 bit so that at power of 2 I get to the maximum that Devialet supports (192 kHz).
I started with RoonReady with upsampling and straight out of the bat I got a 5-6 frame silence in the first 20 seconds.
I then tried without upsampling and it got a bit better but there were small crackles and drop out until at the second song where it really dropped for several seconds.
I then tried switching to DevialetAir with upsample and while it played without long silences there were some audible crackles, I then switched off the upsampling but the crackles were still audible.
Eventually I did use the 10/100 switch before the Devialet and with DevialetAir I managed to have continuous play without any crackle or small drop out. After 30 minutes it was still going fine.
I will let the NUC running tonight and will check tomorrow morning if Roon is still working.

This morning Roon was still up and the streaming to my iPhone was fine. Roon was also up for all day so I decided to take the plunge and try updating it.
I created a back up of the current working configuration just in case I need to revert back, closed roon and made a copy of the %localappdata%Roon/Database that is currently working. I also did a restore point on windows.
Then I proceeded to uninstall Roon and delete the empty folders in %localappdata%, then downloaded the server version at 64 bit and install it.
Then, I restored the back up of the database that I originally exported from my iMac core and then moved on changing the path of the music folders. The process was smooth, only issue I had was that some albums got split in 2, one album with the majority of the tracks and another album with only 2 or 3 tracks. Merging the albums sorted the issue, not sure what was the cause. Then I proceed to set up Windows auto login and Roon auto run. Tried to shut down the machine 3 or for 4 times and roon started as expected without crashes. All the zones now are set up and I enabled Devialet both as RoonReady and AIR.
Hopefully the stability issue is sorted, however the RoonReady problem for the Devialet still persist. I tried playing a couple of tracks and at the beginning there were very small drops, but eventually I got several seconds of silence. I briefly tried Devialet AIR and in a 5 minute track there were no dropout but I will need more tests to confirm this.
I still would be very grateful is @support could help to diagnose the Devialet - RoonReady issue.
Thanks

Will an update to Roon 2.0 help me to have some support? @Support

Hi @Marcor ,

Sorry for the slow response here. Yes, please update to Roon 2.0. After updating, can you please let us know the exact local time + date + track when you next experience this issue? Also, if it’s possible for you to record a short audio or video clip of the behavior, that may help us diagnose it. You can upload the clip here:

https://workdrive.zohoexternal.com/collection/nqcgjac23027d90a441bda2c314de49d7958a/external

Thanks!

thanks @noris for the help
I updated Roon to V2. Update run smoothly.
I just did a test now. 12:22pm New Zealand time. Roon Server playing to the Devialet using RoonReady without any switch to reduce the bandwidth so all on giga ethernet. (same setup as used to work with iMac as roon server).
I uploaded the logs for roon, Raat and a sound recording.

Hi @noris,
Did you have a chance to look at this?

Thanks
Marco