Roon on Nucleus does not see any RPi endpoint

Roon Core Machine

We have a number of RPi endpoints, some of which were stored whilst we had some construction work done. Each RPi is running DietPi with RoonBridge installed via DietPi’s software install. They have a variety of HATs, deadening on use case. ALL were running as expected before the construction. The RPis that were not decommissioned are running as expected.

I believe the last update took place whilst the RPis were offline, but it is unclear if that is connected.

When I reconnected the endpoint yesterday, Roon cannot see it in Audio settings.

I have:

Rebooted the PI and Core
Replaced the OS (DietPi) on a NEW sdcard, reinstalled RoonBridge.
Connected via both wireless AND wired network.
Connected the RPi to the same switch as the Core.
I can ssh into the RPi and can see RooNBridge running via stop (see screenshot).

Networking Gear & Setup Details

Eero wireless and wired network via Netgear and TPLink unmanaged switches.

NB the network is unchanged form the last time these systems ALL worked.

Connected Audio Devices

Many! Most endpoints are RPi based with a variety of IqaudIO and HifiBerry HATs.
Desktop Schiit Vali 2+ and Modi multbit are connected to Mac Retina 5K and worked as expected after connection and enabling in Roon Settings.
Ditto my wife’s Retina with Schiit Fulla.

Library Size

Not sure its material, but…

Description of Issue

See above and throughout. The only other issue which I will bug separately, is the inability to update a password for the user account for the connected file system(s). However as this is now resolved and working on the rest of the system, I don’t believe it to be material to this issue.

Hello @Graham_Bird,

Thank you for getting in touch and for your extremely thorough description of your setup and the issue you’ve ran into, and the steps you’ve already taking.

I was wondering if there are any devices that you can see in Roon, Settings → Audio?

I’ve looped in our technical team so they can share their insights and suggest next steps.

Please, sit tight :nerd:


I listed a few of the endpoints that ARE seen. I also added (or more accurately, reinstated) another RPi endpoint and that came up as expected and was seen by Roon immediately - in its existing configuration.

Thanks a whole lot, @Graham_Bird. Would you please share a screenshot of Settings → Audio as well? :pray:

Hi @Graham_Bird ,

Is the behavior the same if you try to temporarily use another Roon Core, are they still missing then? You can use these instructions to switch cores:

  • Create a Backup of your current database
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings → General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

In which of the switches are the non-working Pi’s plugged into? A switch reboot is a good test, and you may also want to try plugging them into the other switch to see if the behavior is the same there.

I think perhaps I’m not communicating clearly here.

I don’t use a PC, the core runs on ROCK.

There is a single Pi that is not seen. All other are working as expected.

The Pi and the core are on the same switch, sitting next to each other.

just to note that a cloned image will not work properly - roon bridge has to be installed on a clean image, you cant clone one SD card from another working unit.

is the missing unit seen as a roon bridge in the settings | about screen in roon?

if a USB DAC is connected to this unit then it must be turned on and (probably) set to USB input to show up in Roon Audio settings, or must have the active had as the ALSA device set IIRC

The OS is not cloned, it’s a fresh install.

No, it isn’t seen, that is the problem report.

It’s not a USB DAC, it’s an IQaudIO HAT. Alsa is installed and active.

I might suggest you try a ropieee install and see if that helps.

You can send a feedback packet to Harry and he can try and troubleshoot if it’s still not working.

Have you tried a usb dac on it?

I reply to this thread with the reddest of red faces.

Who knew that when an IQaudIO Hat is plugged into only one row of gpis pins, the green light comes on and the board appears to be functioning???



you would know something was up when you screwed it together - you did use screws yeah? perhaps not…we have all done it - surprised it indicated power.

It turns out that the ORIGINAL Pi/HAT/Dietpi did have a bug. The folks at DietPi are digging.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.