Roon on PC as remote gives authorization problem

I don’t get that option.

1 Like

@Kevin_ODonnell - That’s certainly strange… Just to confirm this is the “All-in-one” package you downloaded from our website? Does it give you the option to select a Core if you press “Logout”?


I downloaded the Roon Windows 64 bit file from your site. Right at the top of your downloads page. The downloaded file is RoonInstaller64.exe

If I press “Logout” I am taken to a page asking my to login or start a free trial. If I click on “Go Back” from that page I am then taken to a screen asking me to choose my Core. The options are WOPR (my Unraid server that runs Roon Core) or Use this PC. I always click on the WOPR connect button. It then asks me to login. Once I do I get the same Authorizations page I posted above.

Hi @Kevin_ODonnell ---- Thanks for the follow up and additional feedback, both are greatly appreciated!

In your first post you mentioned that you had uninstalled/reinstalled Roon a few times on the mentioned PC. When you performed this process were the “Roon” and “RAATServer” folders completely deleted from the PC acting as a Roon remote?

If not, I would recommend the following…

  1. Close Roon down completely on the PC.

  2. Locate the “Roon” folder on the PC using these instructions.

    • note: your “RaatServer” folder will be in the same directory as the “Roon” folder on the WinPC]
  1. Once you have located both the “Roon” and “RAATServer” folders on the WinPC, delete both.

  2. After both folders have been deleted and the “trash” bin has been emptied, please restart the Roon server process on the Unraid server.

  3. When Roon server comes back online please try launching Roon again on the mentioned PC.

Just a reminder that the above SHOULD ONLY be performed on the Roon remote


I just did that and I still have the same issue.

Hey @Kevin_ODonnell,

What do you see if you hit that “Logout” button? Do you by any chance see this screen?

If so, I would press the “Go Back” button in the top left and there you should be presented with a “Choose your Core” screen, I would not press “Use this PC” but instead select your desired Core. If you are not seeing that, please post a screenshot.


Yes I get the login screen and going back from there asks me to choose my Core. I never choose use this PC and always select my server. It then asks me login and when I do I get the same Authorizations page I posted earlier.

I just bought a new cell phone (Pixel 3) and installed Roon Control and it gives me the exact same Authorizations page? What the heck is going on here?

Must be a problem with my Core install on my server?

Here is the RoonServer log:!AjVnhushK5Vlgacxizx8rFGDbDWOiA

So I finally said screw it and told Roon to unauthorize WOPR (my server running Roon Core) and as soon as I did that the desktop app loaded right up showing my library. I checked settings and it is showing WOPR for the Core. IO then tried the app on my cell phone and it also works fine.

It must have somehow got 2 entries for the same Core and it choked on it?

That’s strange Kevin – glad to hear you’re up and running! Let us know if you have any additional issues and we can take another look at this.

Thanks and Happy New Year!

It’s back to doing it again. Same exact issue.

I have a feeling the Windows machine is somehow logged in, which is why you’re running out of authorizations – can you try the following:

  • On the Windows Remote machine, go to Settings > General and press “Disconnect”
  • Choose “This PC” when given the option
  • Log in if needed (I’m guessing this step won’t be needed, but mentioning just in case)
  • Go To Settings > Account and choose “Log Out”
  • Connect to the WOPR server and confirm you are seeing WOPR at the top of the Settings window and next to the Disconnect button

Hopefully that resolves the license issue but let us know if not, and apologies again for the trouble here!

I could only do this part way. I did step 1 and then chose “This PC” and I did need to login, but then it took me to the authorizations page except this time it include the option of “Oops I meant to make this PC a remote”. I think this was because WOPR was still authorized as my Core. Nonetheless, I chose this PC which proceeded to act like all the music was on my PC (which it isn’t). I skipped whatever I could and entered Roon settings and disconnected. I then logged back in with my WOPR server. Everything worked fine for a few hours but then in the middle of playing music via Roon, it popped up the Authorizations page.

This is becoming a major pain in the arse. Any ideas?

Around when did this happen? We can grab some logs and take another look.

I’m going to discuss this with our developers tomorrow, but at the moment I don’t have a working theory here – across tens of thousands of installs, I can’t recall an issue like this, so something is different in your setup.

Are you sure the PC was signed in and running your Core? I’m not seeing an authorization on our licensing server for anything other than the “WOPR” machine, which makes me wonder if the second Core if the license was moved over. Were you prompted to de-authorize the WOPR machine?

Later that night I last posted I selected unauthorize WOPR and it took me straight in to Roon with WOPR still showing as connected (like it usually does) and I hit disconnect again until Roon finally showed no Core selected. I then exited Roon and started it back up. Did the whole login and selected WOPR as my Core and it worked the rest of the night and is still working today.

To answer your question, I’m pretty sure my PC was running as Core. I no longer had any media and everything was needing set up.

We’ll see if it happens again. I think this is the longest I’ve seen it work since the problem began.

Ok – thanks for your patience again Kevin. Let us know how it goes.

Everything is still good so I guess that fixed it. Thanks for your help!

1 Like

2 posts were split to a new topic: Roon on QNAP gives authorization problem