Roon on ROCK crashes due to Linn devices with "CreateHandle: Assertion" error [Ticket In]

Hi @fschmeis ,

Thank you for your patience here! We checked with the dev team on this issue and it appears that your ROCK is running out of file handles, but the reason as to why is not entirely clear yet:

Feb  9 15:05:23 (none) user.notice roonserver/run: RoonAppliance: Os/Posix/Os.c:746: CreateHandle: Assertion `aSocket >= 0 && aSocket < 1024' failed.
Feb  9 15:05:24 (none) user.notice roonserver/run: Error

The team is inquiring what your broker2.db and Database folder sizes are, e.g:

Can you please share screenshots of this info? Thank you.

Hello @noris ,
thank you very much for coming back to my issue.

For sure, my Database:

and my broker_2.db:

below “core” is another folder (without a broker_2.db):

Hope this helps :wink:

1 Like

Thanks for the info @fschmeis , let me get this over to the team for further review!

Hello @noris ,

just installed 903, waited for the database to be updated, then started the first track “Odd Times” (album “Giulia” from “Triosence”) - immediate crash, 15th of February, 7:49 pm :frowning_face:

retried after restart of the core, now running … seems to be more stable than before … will report further on …

What did the QA people say?

Hello @noris ,

yesterday e.g. I couldn’t hear any music, couldn’t start a track from my iPAD, 23rd February, several tries between 10:48 pm and 11:03 pm, track “Tokyo Dance” from “Tingvall Trio”

PLEASE HELP

Hello @support,

after struggling for more than 3 years with Roon running on my QNAP TVS 671 NAS with i5 and 16 GByte RAM (refer to Roon stopping randomly) I spent in December 2021 another appr. 900 € and purchased a NUC10i7 with 32 GByte memory and installed Rock.

But unfortunately after ine week with the NUC things became even worse than with my NAS: Actually at 3 out of 4 evenings I am not able to listen to my music :frowning: :frowning: :frowning: As soon as I start a track - Roon core crashes immediately. This situation lasts already for two months now :disappointed_relieved: :disappointed_relieved: :disappointed_relieved:

PLEASE PLEASE PLEASE HELP

Just installed 901 - tried to start a track - immediate crash :sob: :sob: :sob: - Tuesday, 1st of March, 08:00 pm, CET

for some reason: could start to play music via my iPad yesterday evening, Roon was playing for something like 15 minutes, then in the middle of the track “dance” from “Tingvall Trio” the core crashed, I didn’t do anything (besides reading an article), happend 2nd of March, 10:42 pm CET

I just setup a NUC 10I7 32GB just like you However mine runs like clockwork.

My first thought would be to ensure the SSD and memory cards are seated properly , give them a wiggle.

It may be worth downloading a fresh copy of the ROCK OS and start from scratch.

Make a manual backup of your Roon library before starting

Mike’s suggestion is spot-on. This also strikes me as a hardware problem. Possibly the SSD or RAM are bad/somewhat bad. It’s super frustrating trying to troubleshoot ROCK for hardware issues, but, if you happen to have other SSD drives or RAM modules hanging around, you could try swapping them out.

Thx a lot for the fast replies

Indeen, occasional HW failures can be boring … but as the Roon Support already found issues within the log files I don’t expect the HW to be the reason:

I guess a combination of the size of my library (appr. 440.000 tracks) and a limitiation within Roon is causing the issues …

Hi @fschmeis ,

I checked with the team regarding the database size, but it doesn’t appear to be too large, so the cause of the issue is likely stemming from elsewhere. Looking over the logs from the latest Roon build (913), the issue appears to be the same as before, your ROCK Core is running out of file handles:

Line 10767: Mar  4 23:47:31 (none) user.notice roonserver/run: RoonAppliance: Os/Posix/Os.c:746: CreateHandle: Assertion `aSocket >= 0 && aSocket < 1024' failed.
	Line 10775: Mar  5 00:12:01 (none) user.notice roonserver/run: RoonAppliance: Os/Posix/Os.c:746: CreateHandle: Assertion `aSocket >= 0 && aSocket < 1024' failed.
	Line 10850: Mar  6 00:14:19 (none) user.notice roonserver/run: RoonAppliance: Os/Posix/Os.c:746: CreateHandle: Assertion `aSocket >= 0 && aSocket < 1024' failed.

I am checking with the team to see if they have any thoughts on what could be causing this, it also looks like there were a few days when this issue did not occur, I wonder what could be causing it, this is puzzling.

Please remind me, have we tried to eliminate these variables yet?

  1. Using the ROCK on a different network (or at least with no repeater)
  2. Running the ROCK Core with QNAP storage disabled

Hello @noris ,

thank you so much for coming back to this issue :smiley:

yes PLEASE

this is right, but unfourtunately this was due to not hearing music :frowning: … nevertheless e.g. on 2nd of March, I could hear for appr. 2 hours (in words: two :wink:) music before the next crash appreared at 10:42 pm CET, it was again in the middle of a track without any interaction with Roon, it was the album “Dance” from Tingvall Trio.

both the QNAP where the library is stored as well as the NUC where ROCK is installed are directly conntected via ethernet to the same switch, a Netgear ProSAFE JGS524PE; there is no repeater involved and no WIFI; I would be surprised if the reason is somewhere in the network …

please keep in mind that we are talking about appr. 440.000 tracks … something like 12 TByte of data volume …

Do you think this issue is caused by:

  • this particular QNAP (my primary NAS, a TVS 671 with i5 and 16 GByte RAM), or
  • storing the library on a NAS in principle?

The background of my question is:

  • I have a backup NAS QNAP TS-251D (low spec compared with the TVS 671, no RAID, with nightly incremental updates) which I could mount alternativly to the NUC, and
  • I have also a WD DUO Book which I could hook to the NUC via USB (both hold also the entire libary)

Please check this with the team as this will need some work and will take again 2 weeks of analysis of the library …

Hello @noris ,

I spent one more weekend with several tries to hear music with Roon, always immediate crash …

I thought about your recommendations and have the feeling, that network and NAS are unlikely to be the offending cause for the error “missing file handles”

I re-installed MinimServer (as media server) and used Kinsky (from LINN) at the weekend, so I will again be able to hear music at home in a stable way :slightly_smiling_face:.

Nevertheless: I really really really would prefer to use Roon :disappointed_relieved:!

PLEASE PLEASE HELP!

What else can I do? What can I contribute?

For some reason: Yesterday evening (Sunday or Monday) I could hear music with Roon Radio for 3 hours - what a pleasure after all that issues :+1:
nevertheless: this might be worse again today evening … :disappointed_relieved:

As expected, at another day, another fail: Installed yesterday (Tuesday) 918, after 5 minutes start up time tried to play a song - immediate crash … :frowning_face: :frowning_face: :frowning_face:

Ouch this is a very tough time you had over the course of time. What is the latest status you got from the Roon team?

nothing besides this threat

Hi @fschmeis ,

I wanted to check in with you here, we haven’t forgotten about your case. In fact, I have discussed your case several times with the team including today, and have opened up an investigation into some potentially-related cases. We will keep you updated when the investigation is complete or when there is new info to share, it looks like your case could be related.

1 Like

Hello @noris ,

very nice to read, thank you for the update

hopefully you will soon find the bug

Hello @noris ,

just restarted Roon and 16 min later started my remote in iPad, changed the volume (no track playing) and Roon crashed, Sunday, 1:15 pm CET.

should I try this also:

At least the directory which should be deleted exists:
grafik

Hi @fschmeis ,

Yes, can you please try the instructions from here to check to see if this is related to your orbit folder?

Thanks!

1 Like

Hello @noris ,

okay: stopped Roon core, mapped the drive, deleted the “orbit” sub directory, restarted Roon core, waited appr. 5 minutes until the core was up, opened Roon on iPad, started a track of album “Giulia” from “Triosence” - immediate crash :disappointed_relieved:, Wednesday evening, 10:13 pm CET

Waited 19 minutes until the core has restarted, started Roon Control on my Windows 10 Notebook, did nothing - 5 sec after launch CRASH :frowning_face:

Hi @fschmeis ,

Sorry to hear that removing the Orbit folder did not help. I have scheduled additional time for the team to look over your case for next week, I will let you know once I’ve discussed the new findings and Orbit not helping with them.