Roon on Synology NAS - Status of library is stuck as adding music to library

Roon Core Machine

Synology DS920+, RAM 20GB

Networking Gear & Setup Details

pfSense gateway
Ubiquiti 16 Poe Switch

Connected Audio Devices

Desktop PC, Chromecasts, RoPIee endpoint, Android Mobile

Number of Tracks in Library

95000

Description of Issue

Not only I have to manually update the library when I add new music by forcing a rescan but now I also get this error below.

Stop and restart the roon server.

1 Like

I’ve done this already. It will just do the same thing after a while.

That error is normally due to communication issues with the Roon servers. Roon support should be able to look at your logs and see if there are time out errors.

1 Like

That would be ideal. I previously used the same network setup with a Windows server and had not had any similar issues.
Ever since I moved my server to the Synology NAS it does this.

NAS can work very well with roon but on the other hand…

1 Like

It works fine other than this bug.

Everything loads instantly and it’s very snappy. No cut-outs or anything and the sound quality is as good as ever.

I just removed my NAS ip from VPN protection umbrella (my whole network is protected by PIA VPN) and now it seems to have loaded the library successfully. Your hint above led me to try this and seems to do the trick for the time being.

To the mods:
Please do not close this thread as I want to test it for a few days in case it does it again.

I also still experience the issue with the Core not autoscaning new tracks. I have to force manual rescan every time I add new music.

I dont think it will autoscan. If you have a search around the forum, i think, you have to do scheduled scans to get around the issue.
I might be misremembering though!

1 Like

Hi @gtj,

This might help …

2 Likes

Thank you very much. I’ll have a look.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.