Roon on tablet keeps looking for Roon Core

Core Machine (Operating system/System info/Roon build number)

Roon Rock OS v1.0 (build 1.75), Server software v 1.6 (build 4.16)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Rock >cable> TP-Link Archer C2300 >cable> Netgear GS105 >cable> PC with Win 10 and Roon Bridge (latest version)
Samsung SM-P600 Tablet with Android 5.1.1 and Roon Remote (latest version) >wifi> TP-Link Archer C2300

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PC with Win 10 and Roon Bridge (latest version) >spdif cable> Naim NDS

Description Of Issue

Every morning, the tablet cannot find the core. However, it does open the Rock webpage if I click ‘Configure Roon OS devices on your network’. Also, my laptop with Roon has no problems finding the core. Some days, restarting the tablet helps, but not always.

Hi @Arjen_Rinzema,

Can you share a screenshot of what you see on the Android tablet when it can’t find the Core?

Do you have any other Android device, or any device on WiFi? Do they exhibit the same issue or is it just this one device?

Hi Dylan,

Attached is the screen that I get (Roon error screen.jpg). If I click on 'Select a different core’, I get the screen on the second photo. If I then click on the link at the bottom, I get the webpage of my Rock.

Roon on my laptop never has problems to find the core, and the laptop is also connected by wifi to the same router as the tablet.

In many cases, if I restart the tablet when I get the error message, it does find the core after the restart, but not always.

This morning it was really weird: I left the Remote app open last night and this morning when I started the tablet, the app was (still) connected to the core. However, when I then closed the app and reopened it, I got the error message.

Regards, Arjen

Hi @Arjen_Rinzema,

Is the Android device and the PC connected to the same WiFi band (2.4 GHz vs 5 GHz)?

If you connect using the IP address is there any improvement?

Yes, both use 2.4 GHz.

Sorry, I do not understand what you mean with ‘connect using the IP address’.

Hi @Arjen_Rinzema,

After waiting on the connection screen for a minute or so, there should be a “help” option which allows you to enter the Core’s IP address. Can you give this a try and let us know if this helps?

I have tried this, but it does not work.

However, when I subsequently chose ‘Configure Roon OS devices on your network’, my Rock was there…

It is really reproducible:

  • as long as I keep the Remote app running, it stays connected
  • when I close the app and restart it, it cannot find the Rock
  • when I then restart the tablet, and start the app, it automatically connects. However, sometimes I have to restart the tablet several times before this works.

Thanks for giving that a try, @Arjen_Rinzema.

Moving forward, I was hoping that you could note the next time that it happens and respond here with that time in your local timezone. We can then enable diagnostics so the team can take a closer look.

Do you want me to know beforehand? I can plan a restart of the app. What is a good time for you guys?

Hi @Arjen_Rinzema,

No need to let us know before you do this — The next time you have this happen just make a note of the time it occurs and respond here with that time. The diagnostics report will include this information and the team will analyze the report for the time that you tell us.

I invoked the problem at 22:20 local time today.

Thanks, @Arjen_Rinzema.

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Hi Dylan,
Any news?

A post was merged into an existing topic: Slow Connection to ROON from my Android Tablet

Hi Dylan,
I’m curious to know whether you have a solution for me.

Hi @Arjen_Rinzema – Apologies for the delay here. I met with the team to discuss this and they’ve found some traces in the diagnostics report that appear to explain this issue. The connection on the tablet is being refused by the Core machine, so it looks like there may be some networking issues at play.

For our next step, we are escalating this to our senior development team — We will be bringing this to our meeting with the team later this week to discuss further and get their input. We’ll be sure to update you ASAP once we’ve received their feedback.

Hi @Arjen_Rinzema,

We spoke with the senior development team as noted above, and they gave us some direction for our troubleshooting.

In the diagnostics report, we are seeing the following:

10/16 20:20:24 Trace: [raatserver] [RaatServer SM-P600 @] client connection failed. Retrying in 1125ms
10/16 20:20:26 Trace: [raatserver] [RaatServer SM-P600 @] connecting (attempt 4)
10/16 20:20:26 Warn: [rnet/RnetJsonClient] failed to connect Connection refused

Essentially what this means is that Roon is able to contact the remote but the remote is refusing the connection before it even reaches the Roon app on the remote. So something on this tablet is causing Roon to not be able to communicate with the Roon app on the tablet.

Is this device connected to a mobile network or only WiFi? Do you have any VPNs running?

There may also be settings for Battery Optimization that you can disable for Roon on the tablet — If you do this is there any change?

Hi Dylan,

Thanks for the update.

The tablet is only connected to WiFi and does not use VPN.

I have been using my laptop as remote recently, but will try the tablet again and check the battery optimization settings.


Hi Dylan,

I could not find any settings on the tablet to change, but I made some changes in my router (IGMP snooping), which seem to help. And I installed the new 1.7 version on my rock and tablet, which also seems to help. When I start the tablet, the remote app needs some time to connect to the rock, but it always finds it.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.