Roon on Windows 10 2004 feeding RME -ADI-2 DAC fs -> BSOD - repeatable

HI @Milo_Boaden,

There is a new driver for the RME that seems to fix the issue.

-Steve

Hi Steve,
I saw just before so have been testing now… It’s working ok for me now so good result it seems!
Thanks for raising the issue with RME and Roon originally.
Also thanks to RME and also Roon for addressing the issue quickly.
Cheers,
Milo

Hi Milo,

Happy to help, I’m glad it worked for you.

-Steve

Hi @noris,

Is there an update on this issue or an ETA regarding when/if it might be addressed? That’s important to know because I am preparing to sell my RME because I can’t reliably use it with Roon.

That would be very unfortunate because the DAC is qualitatively superior to most others and it has features that are not available on any DAC.

Thanks,
-Steve

It remains broken for me also.

Hi @noris,

Let’s close this out as “unresolved” - its been 4 months since it was submitted, there is no resolution to date and things have changed - a short summary:

Recently, RME released another driver and firmware update. Unfortunately, the OS still crashes when using Roon and the RME, however now its not always a BSOD and core dumps are rarely captured (i.e., ->more rapid/severe crash). When coredumps are captured they show the kernel as the faulting module and one of the backboxes as the module w/in the kernel. I cannot reproduce them reliably - hence no point in submitting this changed behavior as a legitimate bug.

I started using Jriver to stream to the RME which eliminates the problem. Since I only use the RME with my Stax gear and has the necessary DSP tweaks, I’m good.

[Update@3:15 pm: coredump and docs removed and this am to softem]
I’ll pull down the links to the coredump, etc, today.

Thanks,
-Steve

Hi there,

I use an RME ADI 2 with a Lenovo Yopga Laptop, running Windows10 for my Roon bridge output.
I have also used this PC as a Core with a direct USB connection to the RME ADI 2.

Both ASIO and Wasapi both work fine.
I can switch the DAC on and off with Roon running, with absolutely no issues.

Have you tried a different PC?

Yes, please review the thread. I’m happy you’re not having problems.

Thanks for asking.

If you are not having issues with WASAPI, stick with WASAPI.

If you are running the latest RME firmware, your computer has full sampling rate control in WASAPI.
The ASIO driver is not required for bit perfect listening, DSD upsampling etc.

Just trying to help.
I suspect this is not a Roon issue.
Best of luck.

I would log the issue on the RME forum, and see whether other users are having issues.

If it helps, I am running a ADI 2 V1 dac.

1 Like

Hi @steve_smith1,

I wanted to let you know that we are still planning to look into your case. We are still tracking this report and have requested some testing time from the hardware team.

I can’t quite comment on when this testing will take place, but we’ll let you know of any new findings on our end, thanks for your patience!

1 Like

Hello @steve_smith1 & @Milo_Boaden,

We remain unable to reproduce this issue using an ADI-2 Pro FS with the following reproduction steps:

Exact steps to reproduce are:

  1. Start Roon,
  2. power on DAC,
  3. select DAC in Roon and
  4. start playback. After some period of time
  5. stop playback,
  6. power off DAC -> computer crashes with PFN_LIST_CORRUPT (4e) error message.

We used Windows 10 v2004 with the RME 0.9723 drivers.

What other audio drivers/software are you running on your computers? Would it be possible to try these reproduction steps on a Windows PC that doesn’t have potentially conflicting audio programs installed?

-John

Hi @john,
What you did would have worked with the previous driver version; I still have crashes, but it is not repeatable with the new drivers, yet. I did leave an earlier post to this effect.

The crashes with the new drivers are more severe in that the core dumps are incomplete most of the time and unfortunately do not include the user pages, so you only have kernel information, which would not contain the driver info you seek.

I do have one complete dump, and I will figure out the steps to reliably reproduce it. Sorry I did not know you were planning to work it today.

To your questions: I have other software/drivers, but have removed all of them and I could still reproduce the issue with just Roon and the RME ADI-2 DAC and driver.

Normally I have:

  • Jriver - used for multichannel only
  • Realtek audio drivers for the Asus MB.
  • Topping D90 driver
  • Hugo 2 Driver

I can work on reproducing it, but it will take about 2 days - can you hold of for that long?

Thanks,
-Steve

Hello @steve_smith1,

We have the device in-house, so we’re flexible. The most important aspect will be getting reliable steps, once we have that down we’ll be able to get this in front of the dev team.

One thing to note, we have seen the Realtek ASIO drivers cause serious issues with overall stability on Windows 10. At some point during your testing I recommend uninstalling the Realtek drivers and using the native Windows device drivers instead. Unless you’re using special features of the Realtek driver you won’t be missing out on anything.

-John

1 Like

Hi @john,

Great - I’ll get started and let you know when I have something.

I am aware that the Realtek drivers can cause an issue. I’ve removed them before w/out it helping. These are on a standalone system dedicated to Roon, so I have no use for them. I have been concerned that not using them may cause an issue - but will take your advice and remove them prior to testing.

Please note that Windows 10 20H2 ( the October update) is now installed. That did not seem to change anything - crashes still occur and I could not find any fixed or outstanding issues in the release notes that indicated changes that would affect this.

-Steve

Hi @john, @noris

This is an update. Let me know if this information is useful and/or if you need more.

The BSOD’s are still occurring and with the same error message.
PFN_LIST_CORRUPT (4e)
Typically caused by drivers passing bad memory descriptor lists (ie: calling MmUnlockPages twice with the same list, etc). If a kernel debugger is available get the stack trace.
Arguments:
Arg1: 000000000000009a,
Arg2: 0000000000298937
Arg3: 0000000000000006
Arg4: 0000000000000002

Frequency:
Between 10/19-11/13, ~3 weeks, I’ve had 11 BSODs and 5 black screen core dumps that are timed with state changes of the RME ADI-2 DAC. While I do not have a repeatable set of steps yet, the crashes occur when I pause playback and then not use the DAC for 1-3 hours and then power it off (most often) or resume playback (one time).

Details
During this time windows updates occurred and the kernel is now at 19042.630 from 19041.Too, RME has updated the driver twice and is now at version .09728. In each dump, across all builds and with the last 2 updates, there is one common factor: BLACKBOXPNP: 1 (!blackboxpnp) always contains the following:

3: kd> !blackboxpnp
PnpActivityId : {00000000-0000-0000-0000-000000000000}
PnpActivityTime : [variable]
PnpEventInformation: 3
PnpEventInProgress : 0
PnpProblemCode : 24
PnpVetoType : 0
DeviceId : USB\VID_2A39&PID_3FD3\C03A01B44E7C2C8

The device ID, USB\VID_2A39&PID_3FD3\C03A01B44E7C2C8, is the RME ADI-2 DAC’s “Device Instance Path” and is the ID that windows assigns to the DAC; it does not change across reboots (ref: https://docs.microsoft.com/en-us/windows-hardware/drivers/install/device-instance-ids), hence its a useful indicator across crashes: Of the 16 crashes the RME’s ID is found in all of them - and is the only thing present in any of the blackboxes.

The pnp blackbox data contains the RME driver instance id and the problem code 24: which means “This device is not present, is not working properly, or does not have all its drivers installed” Microsoft’s full explanation is:

This device is not present, is not working properly, or does not have all its drivers installed. (Code 24)

Cause

The device is installed incorrectly. The problem could be a hardware failure, or a new driver might be needed. Devices stay in this state if they have been prepared for removal. After you remove the device, this error disappears.

Recommended Resolution

Remove the device, and this error should be resolved.
(ref: https://support.microsoft.com/en-us/help/310123/error-codes-in-device-manager-in-windows)

I’ve done the recommended resolution more than once.

Debugging details were left out:

[…]
BLACKBOXBSD: 1 (!blackboxbsd)
BLACKBOXNTFS: 1 (!blackboxntfs)
BLACKBOXPNP: 1 (!blackboxpnp)
[…]
PROCESS_NAME: System
[…]

UPDATE:

The RME leaves “phantom” devices - only the first entry of each device is active:

No other DACs of mine do this.

Please close this out - windows has updated x 2 times and there have been 2 new updates to the RME drivers. I added another RME ADI-2 DAC to my system and it did not cause any crashes nor did the original DAC. I cannot say what “fixed” it, but it has not occurred for a few weeks and I am satisfied that it is resolved.

Thanks,
-Steve

@john and @noris ,

Well, its been a year and windows 11 just came out a couple of months ago. My RME ADI-DAC2 FS has not crashed one time, nor has Roon. Yay, the issue is resolved. This note puts closure on this long standing bug report of mine.

As an aside, I really enjoy the software updates - they have developed nicely.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.