Roon on Windows 11 crashes on start


I have Roon Core installed on my Synology NAS DS720+
(Intel Celeron 4-core, running the latest DSM 7.1).
Works fine.

The Roon app on my Android phone connects with no problem. I can play tracks, search, even stream to different machines.

The Roon app on my PC however has stopt working completely. It crashes on start and freezes, each and every time. I need to use Alt-Ctrl-Delete to end it.

I have tried the following:

  • Deinstalled the Roon app and reinstalled it, using the latest build from the Roon website (built 970).
  • Restarted the PC
  • Restarted the Synology NAS
  • Tried to install the latest .NET framework 4.8, but this was already installed.

My PC is a Windows 11 machine, with high specs.
Please help me to solve this issue.

Utrecht, the Netherlands

Probably won’t resolve the problem but it’s worth rebooting your router & then network devices and finally another reboot of the PC.
inexplicably this does work on occasions. Good luck. :crossed_fingers:t4:

1 Like

Removing the app also requires removal of the data in libraries on the pc.

Delete the folders here too

1 Like


Thanks for your awnser.
The Roon Core is on my NAS, not on my PC.
Should I remove folders on my PC? Which ones in case of Windows 11?

Thank you, but restarting my router didn’t help :frowning:

Hi everyone,

I have solved the problem!
It turns out that, when deleting the App in Windows, you have to check also the checkbox to delete all preferences and database. When I did this and reinstalled after, the app worked again.


1 Like

Yes…on your pc as you have since found

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.