Roon only partially scanning/adding files


I’ve moved a few folders with albums into my NAS, into one of the music folders that Roon watches. Normally, Roon would immediately find the new files, scan them, etc…
Now, it’ll only see one track, all but one track, or just partially “see” them (not read metadata, etc.)
The weird thing is that the files were actually “fixed” with metadata and put in proper folders by Roon itself, but locally on my Mac! So the files (AIFF and FLAC) are good…

NAS is a 6-bay QNAP, Core is running on Windows 10, and I’m remote controlling from my Mac (and copying to the NAS via the Mac as well)

Any clues? I’ve tried “Re-Scan Album”, but that didn’t do it…


Go into settings–> storage and try rescaling in Watched folder.

If that does not work, I recommend stopping the the Core and restart … (Roon perfora rescan on startup)

I’d rather not re-scan the entire folder, as it has 8Tb of stuff.

I’ll try the Core restart…

Hi again,

Rescan is quite fast … it’s just looking for files … it’s not the same as re running audio-analysis (which is very intensive.

Just FYI, stil not working properly. I have to “Force Rescan” the folder after copying the files, and Roon will take at least an hour to sort everything out…

Hi @Alexandre_Siufy ----- Thank you for the report and the feedback. Both are appreciated!

In your troubleshooting of this issue, at any point, have you tried moving the content that is struggling to be recognized up a “level” or two on the NAS? If so was the experience any different or was it the same as before?