Roon/OSX "losing" my DAC

Hi -

I’m on a Macbook Pro 2013 running OSX 10.11.6 and Roon 1.2 build 157. I am connecting my DAC (Schitt Yggy) via USB using exclusive mode, and I get constant drops: Roon ceases to “see” the Iggy as an output device, though relaunching Roon usually brings the audio device back in view for a few minutes, and then it drops again.

When this happens, the Yggy still shows up in OSX System Preferences/Sound as a potential output device - it never disappears there. Furthermore, if I select it as an output device and stream directly from Tidal via Chrome (e.g. bypassing Roon) the connection is completely stable and I can stream steadily.

I’ve tried 2 different USB cables, and tried connecting to both of my laptop’s USB ports.

My typical use scenario is running Roon Bridge on a Beaglebone Black connected via USB to the Yggy with the same USB cables that I tried with the MBP, and controlling that setup from Roon on the MBP. THAT setup works perfectly. I’m moving to a new apartment at the moment though, and in the interim was trying to use Roon as a Tidal streaming-only solution from the laptop, when I noticed this issue.

Any suggestions?

Thanks in advance,


@Eric: probably related to this?

Hi. I’m just using native Core Audio though - no external drivers.

So I hard reset the DAC, e.g. unplugged the power and all the connections, let it sit a bit, and then booted it all up freshly. Problem seems solved - no dropouts when using Roon. Weird, but apparently sorted!

1 Like