Roon play with Violectric V590

Currently I’m using a roon bridge device (Waversa Wstreamer), usb output to my v590pro, and the usb cable is the stock cable. The player software is roon.

But with this setup I can only play 44.1k music file, for higher resolution files like flac 96k, DSD64 etc. it just play the file very quickly, like one second, no error, no sound output. I change to another roon bridge device from other manufacter, it has same problem. I believe they are all using Linux system.

Tried MacBook Pro directly connect to v590, same use roon, everything works.
Tried WStreamer connect to Teac UD505, everything works too.

So the conlusion is v590 doesn’t support the Linux system player very well. Any one experience same problem? How can this be fixed? Thanks a lot!

Would connecting the bridge and DAC via the SPDIF coax connection rather than USB do the job?

Yes, the coaxial connection works well for other high res files except dsd, because v590 can only play dsd via usb.

So it could be the usb interface problem, v590 is using the amanaro combo 394 usb interface.