Roon playback gets stuck/stops

Core Machine (Operating system/System info/Roon build number)
Roon Rock Version 1.6 (build 416) stable
NUC8i7BEH housed in an Akasa Plato X8 fanless case
8GB RAM on one stick
250GB Samsung SSD 970 EVO PLUS

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon rock on gigabit switch. Wireless router Linksys wrt54gl.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Sonos connect (hard wired)
Blusound 2i wireless

Description Of Issue
While playing tidal, playback will briefly stop start a couple times throughout the day. two or 3 times this has required a reboot of roon rock server. A few times I have gotten roon has lost control of the audio device and other times roon just sits there for several minutes trying to load the song. Logging into the roon admin via web and restarting roon fixed it. I’m hoping that by looking at the logs you can see if it is a roon issue, home wireless/network issue, or a tidal issue.

Hi @Darin_Davis,

Just to verify, local content plays fine and you never experience these playback stoppages?

Does this happen for both the Sonos and the Bluesound? What about f you play to System Output of a remote device?

I generally play Tidal but do have some things local. Just now I had the following happen:

9:13 sep 25 lauren jenkins stopped playback of tidal
error: “roon lost control of the audio device”
With the same device (sonos) I tried to play a local file and it played fine.
Yes, earlier today it also happened on the bluesound node 2i.
If I remember correct it did happen when I was using roon to play on my ipad to headphones as well.
Let me know if you need any further info.

Hi @Darin_Davis,

What kind of switch are you using here, is it managed or un-managed?

Has this issue ever occurred when playing back local files or have you noticed it just when playing TIDAL?

Is your router up to date on newest firmware?

Hello and thanks for your reply. The wireless wireless router I believe is a wireless g, and needed replaced. As a first step I have replaced it with an Eero. And while it is still early, haven’t had any issues yet. Going to see if this fixes it. Will update in about a week to see if we can consider this fixed. Will keep our fingers crossed.

1 Like

Just wanted to report that upgrading the old wireless router appears to have fixed my issues. Upgraded router to eero pro with one of the extenders to cover the house. All is well as roon not only is now stable but more responsive on the UI from ipad, etc.


Hi @Darin_Davis,

Thanks for the update here and glad to hear you got the issue sorted out, hope you have a great continued Roon experience!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.