Roon playback keeps stopping

Roon core is an NUC running Rock.

Roon core is hardwired to an Asus RT-AX58U router.

The home network has another Asus RT-AX58U as a Mesh node.

I am streaming to an Arcam Solo Uno (Roon Ready) endpoint.

The playback keeps stopping for no apparent reason, sometimes several times in quick succession, other times it may last a few hours and then stop. It happens when the Arcam is being used over wifi, and also when it is hardwired to the Asus mesh node.

Interestingly, I sometimes also get the same problem with an Oppo UDP-205 that is hardwired to the router (so no wifi). When it happens with this device though, it usually happens in the first minute of playback.

So, I have tried updating the Asus routers, resetting to factory settings on those devices, and this has had no effect.

It happens whether I play from music stored on a hard drive, or stream from Tidal. It happens day and night, with no discernible difference. It happens no matter how far my Mesh node is from the main router.

I have followed the Roon guidance for my router and enabled multi-cast routing. No difference.

I have tried power cycling the equipment - no difference.

I have tried turning off the modem for 45 mins so that it can acquire a new IP address - no difference.

Anyway, I am very disappointed to be having these issues with a ‘Roon Ready’ device. I have spoken to Arcam support and they say ‘It should work, it’s been tested by Roon’. My thoughts exactly.

There is also a known issue with the Arcam Solo Uno’s volume control through Roon, which Arcam say they can’t reproduce, but it worked before the last Roon update…

There are 21877 tracks in my library.

Some help would be gratefully received. I don’t know what else to try. And no, I can’t wire a network from the router to my Arcam device - it’s too far away and too complicated a route (4 doorways).

I’m not Roon support…just another subscriber. But I wonder if the problem goes away when you remove the Asus RT-AX58U mesh node(s) from your network and configuration.

I’m not familiar with Asus’ AiMesh technology. The webpage is lite on technical details, but it could be that their implementation of mesh networking is incompatible with Roon or simply not sufficiently reliable and performant for real-time audio streaming between devices on the same network.

I would try powering off the mesh node and temporarily wiring the Arcam Solo Uno directly to the same RT-AX58U as your Core. If it works reliably, AiMesh may be the root cause of your issues rather than Arcam.

Thanks for your input. Yes, it works fine when wired to the router. The issue is definitely with wifi streaming. The asus mesh network is current wifi-6 technology, and has worked seamlessly over wifi with a variety of older and newer devices in my home since I installed it. I can stream Tidal from a web browser all day, no problem; likewise Zoom calls.

Hi @Vaughan_Barnacle

We’re sorry to hear that you’re having these issues. What you’re seeing is typically caused by networking issues. @David_Snyder’s recommendations and your tests seem to confirm this.

Please take a look at this article form our Help Center on Best Networking Practices for tips on optimizing your local network for your Roon Setup:

You may to try a few things.

  1. Please ensure that IPv6 hasn’t been activated on your router. We’ve seen this cause issues like the one you’re having.

  2. We have seen users have a better experience in the past if they change their Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS. Can you please give this a try and let me know if it helps?

1 Like

Hi Vaughan,

Another friendly user, but, if the other suggestions do not correct your issue… sometimes in mesh environments the device switches between mesh points (roams) and this can cause issues. Try and get the device locked onto a specific mesh point.

Thanks Daniel, but I have it wired to the Mesh node to eliminate that possibility, and to eliminate any potential wi-fi issues on the Arcam device itself. Still no joy though.

Thanks Jamie for coming back to me with some suggestions for things to try. I have confirmed that IPv6 is not activated on my router, and I have switched my DNS servers to Cloudflare. I am aware of the guidance from Roon on Networking Best Practices, and have implemented those suggestions. The problem persists, I’m sorry to say.

I am glad someone else has the Roon - Solo volume control issue. I agree it started after a recent Solo update. Arcam on the case but cannot reproduce it yet. It is a bit annoying.

Arcam support now saying they can replicate the volume issue and the software engineers are working on a fix. No timescale for that, though, so I have returned the product. Sad end to what was potentially a great little product. Roon support went quiet on this a while ago anyway.

I had the same stopping issues for a long time. Sometimes every 3rd or 4th track and sometimes bur rarely roon played for several hours. I checked with speedtests and these were fine. So I called my provider and the could see a rather low signal strength (german: “Pegel” I hope the translations is right!). A technician from the provider could solve this issue. I had now sessions with roon for several hours without problems!
I also had problems with volume control on naim Mu-sos 1st gen. This was solved with an update by naim. So I hope Arcam can also fix this.
Norbert