Roon plays for a few minutes & loses connection

I’m currently running my Roon core on an older MacBook Pro. I moved Roon here from a newer MacBook Pro to provide a dedicated server. I’m a lifetime Roon subscriber.

But now, I can play but a few minutes of music, and not only does Roon Remote quit working, but I can’t play music from the Roon source software either.

I’m running Roon 1.6 (build 475) Stable - 64-bit
My 17" MBP machine runs OS-X El Capitan, 10.11.6 (this is the most recent OS-X that this laptop can run due to its video card) The computer has a 2.8 GHz Intel Core Duo with 8 GB of RAM and a 2 Gig SSD drive
The music storage device is a 4TB USB external drive
The Roon computer connects to the network via Ethernet 10-100
The Roon destination is an Oppo UDP-205 with the latest software updates, and connected to the network via Ethernet
Both Roon and Roon Remote see the Oppo and recognize it as the active zone.
System control is done with Roon Remote on an Apple iPad with the latest updates
What happens when I start Roon Remote is that it instantly connects with Roon on the MBP and music of my choice will play for two or three minutes. Then the next track that I select in Roon Remote can be started (accepted) from the iPad, but no music plays, and Roon Remote then reports “nothing playing.”

Even when I go to Roon on the MBP and try to start a track (any), the selection appears to be accepted, but then no music plays and the Roon program itself reports “nothing playing.” Sometimes the Oppo is still identified as the active zone by both Roon and Roon Remote, but other times Roon no longer sees the Oppo.

To (normally) control this system, an Apple Airport Express (linked to the network via Ethernet, and serving as a 802.11n wireless hub to connect the AirPort Express with Roon Remote to the rest of the system.

I’ve tried troubleshooting using the following ploys:
Restart everything after checking to ensure that the latest software and hardware updates are installed.
Going to Security & Privacy in the OS-X settings and adding Roon to the devices allowed to control the MBP.
Verifying that the Oppo zone is recognized and active on both the Roon server and the RoonRemote on the iPad
Trying a wide variety of music
Running Disk Repair from the MBP on both the boot disc and the data disc

I’m running out of ideas, ladies and gents. Any suggestions? Thanks!

Firstly I have moved this to support as you had it under nucleus support. You’re welcome :slightly_smiling_face:

Your MacBook pro is very old now (mid 2009) and likely will not run roon well. Even if it now has an ssd it’s still not likely to give ideal results. WiFi connections for a core machine are also not recommended, but you are on Ethernet.

Why not consider a more recent under 6yrs old macmini or ROCK running on a NUC

Why not a newer machine? Because I already own the MBP, and it’s available for this service without additional capital outlay. The machine has been upgraded with 8 GB RAM and the SSD drive. I’ve used it before as a Roon host and it worked perfectly. Unless Roon has suddenly become far more resource intensive, it should run the same as it did before.

I strongly suspect that the current problem is not the MBP, but rather a software issue (either in the Mac OS or in Roon itself) that needs to be set correctly.

However, if I get no suggestions, I can test your theory by moving Roon to a newer machine (I have three available - two Macs & a PC) to see if the problem cures itself.

Thank you for the thread move and the suggestions.

How big is your library and has it finished importing and music analysis completed…this will slow Roon down even on a capable machine. 4TB if its full is still a lot of music.

Hi Wiz -

My data drive shows 2.9 TB of music files. Roon says 4,710 albums. Every time I start Roon, it spends about two or three minutes checking the data drive for new music, and then, finding none, it is ready to play.

is there a spinning icon in the top right area of the roon window? if so its probably still analysing your collection.

you can also check under settings library

Anyway if its working well on a better spec’d machine then its quite likely to be a performance issue.

The spinning icon indicates that Roon is analyzing the data disc, looking for additional data. The delay is caused by the speed and size of the data disc. After two or three minutes, the scan finishes, and the spinning icon disappears. This has always happened, regardless of the computer that the data disc is hooked to. I’m aware that Roon is “busy” during this process and never try to play anything until the data disc is finished with its initial scan.

did you check under Settings then Library to see if anything going on there?

Yes - Initially both the “Background Audio Analysis Speed” and “On-Demand Audio Analysis Speed” settings were turned to “slow” and both were churning along through the data drive. I set them both to “off,” and tried again - no difference - Roon stlll choked.

So as of right now, I’ve set the background one to high speed. When it’s done, I’ll throttle it back and try the on-demand one at high speed. When they’re both done, I’ll try Roon again.


Roon is also doing much in the background with metadata retrieving from the internet. Roon is a processor heavy app when all this is going on so an under spec cpu will make things slower. Once it’s all done and most of the metadata is there you might see things improve.

Hi @Glenn_Young,

I have a few remarks based on the information you have provided above.

As @wizardofoz noted, this PC does not meet our Minimum Requirements and may be contributing to the issue. I would verify if the behavior is the same on a properly spec’d machine or if you use a fresh database on the Macbook (by reinstalling the app).

We have often seen sub-par performance from Airport Express routers, as mentioned in our Networking Best Practices Guide. If you can temporarily bypass the additional Airport Express node and have the PC connected to the primary router, the behavior might be different so it’s worth a check.

Does this behavior only impact the Oppo zone? If you try to play to other zones (such as System Output), do you experience the same issue?

I’m moving Roon to a newer machine that exceeds all Roon requirements. I’ll see what happens there.

1 Like

The “your machine is too slow” theory is disproved. I’ve got Roon authorized on a different MBP that exceeds all Roon requirements, and the same situation occurs. Either the Roon core can’t see the Oppo at all, or when it does, music will play for a few minutes and then everything stops.

Looks like the Apple router is a possible culprit - it has been noted elsewhere that the Apple APE’s are not the greatest for networking…ditched all mine many years ago and never looked back. While Apple is a great ecosystem, their networking hardware leaves a lot to be desired.

That said some info in the KB’s here on networking

“Finally, we strongly recommend against using Apple network devices such as the Apple Airport Extreme and Airport Express (note: it’s fine to use the Airport Express as an Airplay device). To ensure the best performance, we recommend against using these devices.”

Hi @Glenn_Young,

Thanks for checking the Core. I would agree that the Apple Express is a likely candidate for the source of the issue but before you go ahead and start replacing any network parts, can you confirm if the behavior is limited to just Oppo zone? Do any other zones exhibit this behavior, such as “System Output” for example?

I’m doubting that the AirPort has anything to do with this problem. Why? Because once Roon-Remote “locks up,” the computer with Roon core on it won’t play either.

My system is as shown below, with all Gigabit-Ethernet connections except for the final link between the AirPort Express and the iPad with Roon-remote:

I also found a recommendation on the internet to reset the Oppo UDP-205 to its factory settings (which I’ve just done). In the morning, when Roon is finished indexing my data drive for “Background Audio Analysis,” I’ll see if the Oppo is now recognized.

Thanks - Glenn

So Glenn…now with this image we are seeing you have more networking components than you identified before.

Please detail your network setup in full - models and makes so we can make some more detailed troubleshooting that could find the issue.

MacBook Pro (Retina, 15-inch, Late 2013)
2.3 GHz Quad-Core Intel Core i7
16 GB 1600 MHz DDR3 RAM
NVIDIA GeForce GT 750M 2GB + Intel Iris Pro 1536MB
OS-X Catalina 10.15.1
Apple SSD SM0512F (ALL solid-state)

External 4TB 7200RPM Seagate USB HDD via USB3

TP-Link 16-Port Gigabit Ethernet (computer room) Switch

Netgear (?) 8-Port Gigabit Ethernet (listening room) Switch

Oppo UDP-205 player with latest updates (listening room, used as Roon endpoint)

Recent model AirPort Express 802.11n

iPad Mini with Roon-Remote

The Cable-modem / router is supplied by Cox Cable, and is NOT in the signal path unless internet access is required.

Hi Glenn,
I noticed the Oppo UDP-205 player is Roon Ready and has an ethernet port. If you have an ethernet connection between the computer room and listening room, have you tried connecting the Oppo to the Listening room switch? What is the Airport Express used for?

@Sunrise I think the Oppo if connected as above should be OK

@Glenn_Young how are the 2 switches connected? not over EoP network I hope. What are the models of these 2 switches. there could also be settings in your Router that can impact device discovery that need to be determined.

again in the lower parts of the page there are things to be checked like IGMP etc