Roon>QNAP NAS as Core

Have selected my QNAP NAS to be used as a Core.

after clicking “connect” it just seems stuck while displaying “initializing”

Hello @thomas_clark1,

Can you please try rebooting your Core and Roon Remote as the first troubleshooting step here? What kind of Roon Remote are you using, and iOS or Android device? Please provide the exact model/manufacturer.


Thanks for your quick reply.

this is my 1st time suing roon. IN the 2 week trial phase.

I have been unable to create a core but will reboot my NAS and see what happens.

Was going to use my QNAP was for the core and my IMAC desktop as the remote.

Model Name: iMac
Model Identifier: iMac17,1
Processor Name: Intel Core i5
Processor Speed: 3.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 24 GB
Boot ROM Version:
SMC Version (system): 2.33f10
Serial Number (system): C02QM8EXGG7J
Hardware UUID: 6860165B-63FB-539E-B57E-E705038FD6E2

Hello @thomas_clark1,

Do you by any chance have an active firewall on the iMac? I would check using these instructions from Apple to make sure that Roon is listed as an exception.


I rebooted NAS and when I restarted ROON it was fine…then it said it lost connection and is now initializing again

I do have ROON as an exception in firewall.

tried to reconnect and it failed.

I did get it going for a few minutes and it was cataloging my music collection.

looked cool for that 2 minutes

rebooted NAS again and got it working…was scanning drives for music…i trend to play something and it disconnected again and can’t seem to reconnect.
thinking this does not bode well for me to use

if i reboot the NAS it always connects but then disconnects and can’t reconnect.

Any thoughts?

Would much rather go with Roon than Plex but unfortunately Plex works fine.

Hello @thomas_clark1,

What is your network setup like? Please list the model/manufacturer for your router, model/manufacturer for any switches/range extenders/powerline adapter/ect. How is your iMac and QNAP connected here? Are they both connected via Ethernet to the router? I am thinking that something is going wrong in the multicast settings for your router causing this issue as we use multicast for Core discovery. Any other firewalls on the network or antivirus applications on the iMac?


-when i try and designate the QNAP NAS as the core the software continuously displays “initializing”

-when i reboot the NAS it connects fine. It begins to catalogue my music and then disconnects after about 2 minutes.

-It then is unable to reconnect.

Im trying to us my IMAC as the controller.

Did a NAS firmware update today.

My plex server is working fine with the NAS.

Thx for any advice

Hello @thomas_clark1,

I have replied to your post above, please try to refrain from making multiple posts regarding the same issue, it clutters the support section. I look forward to your reply.


Thank you -
will do my best…terribly ignorant re: tech

Router: TP-LINK Archer C5

My QNAP is connected to the router via network cable.

IMAC connected wirelessly over network

So only QNAP connected to router via network cable.

No virus protection

just basic firewall that lists Roon as allowed.

Weird (prob only to me) that the Plex server works fine—wish I liked Plex more than I do.

Sorry about the multi thread replies …will stay in this lane

Hello @thomas_clark1,

Thanks for letting me know that information. Does the same behavior occur if you temporarily connect your iMac via Ethernet to the router?

Plex does not work in the same way that Roon does, it is like comparing apples to oranges, but no worries, I have also gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

I will take a look at the diagnostics to see if there is anything that jumps out as the reason why the Core is disconnecting and let you know, but in the meantime please try connecting the iMac via Ethernet to verify if the same behavior occurs.


will be a challenge to connect my computer to the router because out is on another floor of the house.

If i did do it and it worked I wouldn’t be able to keep the CPU in that room.

If i do that would the fact it worked help you figure out how to get it working wirelessly.

If yes then i may do it.

thanks for the the diagnostic thing…i will reboot my NAS again and the connect to the core with hopes it will give you some useful info

sorry for whining in last reply.

will move CPU and connect to router this weekend.Understand it’s diagnostic value

just restarted NAS again and was able to get Roon to work…it gets to 900 tracks each time and then disconnects.


Hello @thomas_clark1,

I am taking a look at the diagnostics and I am seeing that Roon is hanging on a few tracks:

/Users/tomclark/Music/Phish/Live Bait Vol. 10/phlb10d1_08_The_Mango_Song.mp3
/Users/tomclark/Music/Phish/Live Bait Vol. 10/phlb10d1_06_Bathtub_Gin 3.mp3
/Users/tomclark/Music/Phish/Live Bait 04 - Past Summers/phlb04d1_01_Scent_Of_A_Mule 2.mp3
/Users/tomclark/Music/Phish/Live Bait Vol. 14/phlb14d1_03_Wolfmans_Brother.mp3
/Users/tomclark/Music/Phish/Live Bait 04 - Past Summers/phlb04d1_06_N02 4.mp3

Can you please try moving these Phish folders (Live Bait Vol. 10/Live Bait 04/Live Bait Vol. 14 - Past Summers) out of your watched storage locations, reboot your QNAP and iMac and try again?



those tracks must be from iTunes or something.

I don’t use them or listen to MP3’s.

not sure what you mean by watched storage but i can get rid of them

Nothing to worry. It looks like a similar problem I had when I trialed Roon. When Roon analyzed my local music, which can last hours, for the first time I had a track that had an error in the audio RIP and made Roon crash. So, in the log files one could see that the analysis always stopped at that file. After removing the file and restarting the Core all went smoothly and I have no crashes since then having added about 300 purchased hires albums from Qobuz. Roon is very stable, but I experienced as you a very painful first week of trying to get it working and almost gave up. The Roon support was also very helpful in my case and prolonged my trial period. Now I’m a lifetimer and so far do not regret it.

i deleted them but no change…i also rebooted everything.

weird those files come up as they were not in the folder i selected for Roon to use as my audio database.

I do think you are on to something about a bad track/data.
It always hangs up at track 877…freezes…and then disconnects

Hello @thomas_clark1,

Thanks for letting me know. I have just checked our diagnostics server and I am not seeing any new reports for your account. Is your Core and iMac still powered on with Roon active and connected to the internet? In the interest of saving time you can also manually send us the logs from your machine using these instructions, I will PM you on how to upload it to our servers.