Roon>QNAP NAS as Core

will be a challenge to connect my computer to the router because out is on another floor of the house.

If i did do it and it worked I wouldn’t be able to keep the CPU in that room.

If i do that would the fact it worked help you figure out how to get it working wirelessly.

If yes then i may do it.

thanks for the the diagnostic thing…i will reboot my NAS again and the connect to the core with hopes it will give you some useful info

sorry for whining in last reply.

will move CPU and connect to router this weekend.Understand it’s diagnostic value

just restarted NAS again and was able to get Roon to work…it gets to 900 tracks each time and then disconnects.


Hello @thomas_clark1,

I am taking a look at the diagnostics and I am seeing that Roon is hanging on a few tracks:

/Users/tomclark/Music/Phish/Live Bait Vol. 10/phlb10d1_08_The_Mango_Song.mp3
/Users/tomclark/Music/Phish/Live Bait Vol. 10/phlb10d1_06_Bathtub_Gin 3.mp3
/Users/tomclark/Music/Phish/Live Bait 04 - Past Summers/phlb04d1_01_Scent_Of_A_Mule 2.mp3
/Users/tomclark/Music/Phish/Live Bait Vol. 14/phlb14d1_03_Wolfmans_Brother.mp3
/Users/tomclark/Music/Phish/Live Bait 04 - Past Summers/phlb04d1_06_N02 4.mp3

Can you please try moving these Phish folders (Live Bait Vol. 10/Live Bait 04/Live Bait Vol. 14 - Past Summers) out of your watched storage locations, reboot your QNAP and iMac and try again?



those tracks must be from iTunes or something.

I don’t use them or listen to MP3’s.

not sure what you mean by watched storage but i can get rid of them

Nothing to worry. It looks like a similar problem I had when I trialed Roon. When Roon analyzed my local music, which can last hours, for the first time I had a track that had an error in the audio RIP and made Roon crash. So, in the log files one could see that the analysis always stopped at that file. After removing the file and restarting the Core all went smoothly and I have no crashes since then having added about 300 purchased hires albums from Qobuz. Roon is very stable, but I experienced as you a very painful first week of trying to get it working and almost gave up. The Roon support was also very helpful in my case and prolonged my trial period. Now I’m a lifetimer and so far do not regret it.

i deleted them but no change…i also rebooted everything.

weird those files come up as they were not in the folder i selected for Roon to use as my audio database.

I do think you are on to something about a bad track/data.
It always hangs up at track 877…freezes…and then disconnects

Hello @thomas_clark1,

Thanks for letting me know. I have just checked our diagnostics server and I am not seeing any new reports for your account. Is your Core and iMac still powered on with Roon active and connected to the internet? In the interest of saving time you can also manually send us the logs from your machine using these instructions, I will PM you on how to upload it to our servers.


roon has not been active as it just scans and freezes but i will turn it on now

Hello @thomas_clark1,

Thanks for sending us the zip file over but unfortunately it is not exactly what we’re looking for. The live logs page should be something similar to this screenshot but it is possible that it has changed:

I’m going to go ahead and loop in our resident QNAP expert @crieke to see if he can provide the method of getting the Roon logs from your QNAP Core. If you can provide the exact model of your QANP and a screenshot of what you’re seeing that would be good as it is possible that they are located in a different place. Chris, I would like to get the RoonServer logs from his machine here, if you can assist it would be much appreciated.


Will do so soon

QNAP TS453BT3[Uploading…]

Hi @thomas_clark1,
I noticed on your screenshot, that you’ve set /home as your database path. I am not sure if this happened by mistake. The /home directory has just 16 MB of space available as indicated in your screenshot and the space seems to be totally in use…
Could you use the change database location button to choose a different location with more space?
Probably this might have caused issues of downloading the logs, as the web interface is looking for the log files there and there might be no space that the log files were created at all.

Also take a look with the QNAP FileStation in the /home directory to remove or move RoonServer, RAATServer and RoonGoer folders to a different place to free up space there again.

In general the Logs can be downloaded from the QNAP web interface by hitting the ambulance button:

But please check Roon Server’s database location first. I could imagine, it could have caused the whole issue.
I also just adjusted the web interface for the next update to not being able to select the /home folder anymore.


You Sir are a Freaking Genius!

I really appreciate. I can’t wait to check this service out.

I really really appreciate it!

I close this email completely stunned.

Instead of a “MIC drop” you should do a keyboard drop.


Im Just learning about all this and hope I can ask you one last question>>>

I was thinking about buying an external SSD HD to use roon with my NAS.

I planned on connecting it via thunderbolt or USB.

I have about 7 TB’s of audio data (FLAC & FLAC HD).

Would you advise this is a better solution than storing Database on NAS?

And finally what size SSD would I need to handle 7 TB’S of info.

Cant thank you enuff

A SSD for Roon’s database will speed up the overall performance. I use an SSD which is connected by USB to my QNAP NAS. I have not looked into Thunderbolt SSDs yet. (My model is not equipped with it). The SSD does not need to be very big. My ssd is just 128 GB and only 3% is used.

PS: Don’t mix up a ssd with a usb thumb drive… Just bringing this up, as other users got confused about it. :wink:

Hello @thomas_clark1 & @crieke,

I just got around to checking these messages and absolutely glad to hear that Chris has managed to narrow down the issue due to that screenshot, great work Chris!

Would you mind if I moved a few of these posts over to the public thread (starting from when I invited Chris) so that other users who have not updated their QNAP and have similar issues by trying to install to /home can locate this critical piece of information?

Either way, glad that we have been able to resolve the issue here and thanks again for working with us here!

– Noris

No problem from my side… :slight_smile:

1 Like

Of course not. Please do
Thank you also Noris

1 Like