Roon, Qobuz and Roon metadata improver issues [Resolved - Google DNS]

Roon Core Machine

Core running on Arch Linux. i7Core machine with 16MB of ram. Running build 814.

Networking Gear & Setup Details

Running ethernet on Lyncsys E2500 router

Connected Audio Devices

USB input to Auralic DAC

Library Size

2168 albums

Description of Issue

No problem logging into Tidal or Qobuz. Can ping from the unit running the Core with no problem. Small red triangle on the top right of the Roon screen says Roon metadata server is paused due to connectivity issues.

Yesterday I could not play Qobuz or Tidal tracks. Today, Qobuz is working but Tidal reports “Track is not currently available from Tidal” and “Too many failures. Stopping playback.”

Since I have no trouble logging into Tidal & Qobuz and can ping successfully, I assume it is not a network issue. I can also stream radio stations with no issues.

  • Jim

This could be the problem…

Worth the couple of minutes to try it I think.

Hi @Jim_Salk

Can you take a look at our article on this here:

If you’re still seeing issues after trying those steps please let us know!

Closed down the Core and deleted my Tidal account. I re-set it and logged in successfully. Now neither Tidal or Qobuz will list or play files. Roon Metadata improver is still paused. In addition, I found that while I can select a live radio stream, it will not play either.

I also changed my nameserver to I can ping this address successfully from a Linux terminal on the Core machine.

All of this worked before upgrading to build 814. Something is obviously amiss with networking.

Thanks for the update, @Jim_Salk. Is the Core connected directly to the router? Any other devices involved?

Can you use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

Rather than sort through logs, I thought is would be worth removing Roon and re-installing from scratch. All seems to be working how.

Thanks for your help.

  • Jim

I spoke too soon. Metadata improver solved. Qobuz now works. But Tidal does not. I’ll try and get you the logs.

  • Jim

Thanks, Jim. I’ll take a look once you have them for me and see what’s happening. Any specific errors when trying to play Tidal content?

The messages I get are “Track is not available currently available from Tidal” and “Too many errors. Stopping playback.”

I shared the Log files with drop box. Let me know if you do not get them. (Haven’t shared files with Dropbox in the past and don’t know if I got it right.)

  • Jim

Hi @Jim_Salk, I sent you a PM.


We’ve discussed over PM and, after looking at logs, I could see that the DNS being used was failing. After updating to Google DNS, things are now working.