Roon quits on startup after new install on macbook pro

I just downloaded a Roon trial copy and installed it on my Mac Mini with no problem. However, when I attempt to install it on my Macbook Pro Retina, Mid 2012 running Yosemite 10.10.3, it immediately quits. The console log shows these messages:

5/22/15 5:53:54.957 PM Finder[573]: LSExceptions [0x6180002b38c0] loaded
5/22/15 5:53:55.023 PM taskgated[114]: no system signature for unsigned /Applications/[3800]
5/22/15 5:53:55.628 PM Roon[3800]: LSExceptions [0x7c0416e0] loaded
5/22/15 5:53:55.000 PM root[-1]: Application Launched: bundle_id: com.roon.Roon version: 1.0 path: /Applications/
5/22/15 5:53:55.767 PM CoreServicesUIAgent[641]: unexpected message <OS_xpc_error: <error: 0x7fff724ddc60> { count = 1, contents =
“XPCErrorDescription” => <string: 0x7fff724ddf70> { length = 18, contents = “Connection invalid” }
5/22/15 5:53:55.000 PM kernel[0]: Over-release of kernel-internal importance assertions for pid 90 (launchservicesd), dropping 1 assertion(s) but task only has 0 remaining (0 external).
5/22/15 5:53:55.774 PM[1]: (com.roon.Roon.85800[3800]) Service exited with abnormal code: 1
5/22/15 5:53:55.000 PM root[-1]: Application Quit: bundle_id: com.roon.Roon version: 1.0 path: /Applications/
5/22/15 5:54:05.032 PM Finder[573]: LSExceptions [0x6180002b38c0] unloaded

Note that I have set my System setting “Allow apps downloaded from:” to Anywhere.

It looks like your binary is corrupt. Could you try reinstalling?

Hi Danny,

I downloaded again and reinstalled. Got the same problem:

5/22/15 8:36:18.103 PM Finder[573]: LSExceptions [0x6000002ae460] loaded
5/22/15 8:36:18.169 PM taskgated[114]: no system signature for unsigned /Applications/[6948]
5/22/15 8:36:18.786 PM Roon[6948]: LSExceptions [0x79fa9060] loaded
5/22/15 8:36:18.000 PM root[-1]: Application Launched: bundle_id: com.roon.Roon version: 1.0 path: /Applications/
5/22/15 8:36:18.917 PM CoreServicesUIAgent[641]: unexpected message <OS_xpc_error: <error: 0x7fff724ddc60> { count = 1, contents =
“XPCErrorDescription” => <string: 0x7fff724ddf70> { length = 18, contents = “Connection invalid” }
5/22/15 8:36:18.923 PM[1]: (com.roon.Roon.87220[6948]) Service exited with abnormal code: 1
5/22/15 8:36:19.000 PM root[-1]: Application Quit: bundle_id: com.roon.Roon version: 1.0 path: /Applications/
5/22/15 8:36:22.458 PM Google Chrome Helper[6947]: LSExceptions [0x7ff290516480] unloaded

Hi @warrensomebody – sorry for the slow response here.

We’re discussing what could be causing this issue, so expect to hear from us soon with next steps. Also, if you’re on a trial, we’ll make sure to extend it so you have time to try out Roon.

Thanks and sorry for the inconvenience!

Thanks Mike. Please let me know if you figure something out. Also, I’d be happy to test a new version for you if that would help. (I’m a software developer myself.) However, there are a number of issues that would need to be addressed for me to continue with a purchase:

  • Since my media server Mac Mini is headless, I connect to it with Screen Sharing. When running Roon the performance becomes unusable. Maybe Roon is somehow causing too many screen updates?

  • Roon crashed twice on the Mac Mini while using it.

  • Roon takes a very long time to start up, cranking the cpu up to 90% for a minute or longer. (I have ~40k tracks in my local library.)

  • I (accidentally) added a group of Tidal albums to my library, and I’m baffled as to how to remove them.


I am experiencing similar problem as the OP … when I click on the Roon app on my Macbook … my screen flash twice quickly … though Roon does not open at all.

I have downloaded and installed… and have this problem.
Then re-installed Roon … issue still exists.

Details of my Macbook are below … it is a late 2011 Macbook 17 inch with SATA3 SSD’s (Samsung 840 Pro) inside … 16GB RAM… so it is not the latest & greatest … though still pretty powerful for a laptop…

Model Name: MacBook Pro
Model Identifier: MacBookPro8,3
Processor Name: Intel Core i7
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB

System Software Overview:

System Version: OS X 10.10.3 (14D136) Yosemite
Kernel Version: Darwin 14.3.0
Boot Volume: MACBOOK
Boot Mode: Normal
Secure Virtual Memory: Enabled
Time since boot: 45 minutes

I opened the MAC OS App “Console”.
Went to the section … “Diagnositc and Usage Messages”
noticed a number of entries such as the one below …

1/06/2015 5:03:40.958 am syspolicyd[11884]: assessment granted for Roon.dmg and overridden bundle:UNBUNDLED Roon.dmg UNKNOWN 3 override:_XProtect

1/06/2015 5:04:04.233 am syspolicyd[11884]: assessment denied for .app but overridden bundle:com.roon.Roon .app UNKNOWN 1 defeated:Developer ID

In the “System Preferences”

  • “Security & Privacy” section on my Macbook which is running Yosemite
    -“Allow Apps Downloaded From” section … well I have tried changing it to
  • “Anywhere” and “MAC App Store & Identified Developers”… neither option seems to help.

It looks like this issue was first reported 9 Days ago
… I hope a fix will come soon … if their is a solution already, then please advise.



That should explain how to remove your accidentally added tidal music.

@warrensomebody – im confused. you say it wont run, but then you said it is causing screensharing to be slow, crashing, and you are able to do some tidal stuff. so which is it? can you run or not?

@Duke, are you seeing the same error @warrensomebody was seeing?

Hi Danny,

I have a Mac Mini that I connect to via Screen Sharing. When Roon is running on the Mini, the cpu load is very high. This affects Screen Sharing performance, among other things.

I also have a Macbook Pro, and Roon won’t run on that at all. It just gives the log messages I mentioned previously. I’d like to use it as a remote to control Roon on the Mini, but both things would need to be fixed before I can do this.

Re. Deleting albums added from Tidal – Whenever I would right-click on an album I wouldn’t get a menu, but instead be taking to the album details page. So the instructions given seemed out of date. I finally managed to delete the albums by using the Tidal web interface.


you can long press if right click is not working for you… both will select the album from the browser. the instructions actually talk about finding the tags and selecting all, dont they?

ok, i get your macbookpro vs mac mini situation.

Roon updates at 60fps, like a video game (or least it tries to!). So if you have an animation going on the screen, screensharing is probably going to be bad. i am shocked that some people can use it, but i would use the remote instead, and long term, use the headless mac build (later this month!).

Now, i wish you could use the macbookpro as your remote, but clearly something is going on there.

We were so focused on the first part of your logs, which seem to just be OSX whining, but not really messing up stuff. the real error is here:

5/22/15 5:53:55.774 PM[1]: (com.roon.Roon.85800[3800]) Service exited with abnormal code: 1

How technical are you? Can you get around a Terminal? at least run a command and cut and paste what you see? I ask because I want to send you some command to poke around.

Otherwise, if you are open to it, we could do a remote TeamViewer session where I can come do a temporary screen sharing thing and you can observe me.

Hi @Duke

I’m going to send you a PM to get some additional info from you. Sorry for the inconvenience!


@mike Thank you … just replied to your PM. I appreciate your help, that is great.

@danny Yes … I have a Macbook Pro and Roon has never opened … it looks to be the same type of error that warrensomebody is seeing … anyway, thanks for your PM, it is great that this issue is getting more attention … as I am really really keen to try Roon.

@duke, @warrensomebody – did either of you upgrade your OSX instead of a fresh install?

Hi Danny,

I tried your suggestion of running Roon from a terminal on my MBP to see what logs it might spit out, and to my surprise it actually started up this time:

$ /Applications/
00:00:00.002 Trace: [broo/imagecache] loaded 0 cache entries from /Users/warrenharris/Library/Roon/Cache/brooimages/index.db, current: 512mb / 0mb
00:00:00.019 Info: CurrentUICulture locale name: en-US
Calling _exit

It ran and was able to connect to Roon running on the Mini (the exit message is probably from when I finally quit the app). After this, I was able to double-click the app icon to start it too. This seems strange since I haven’t done anything with the MBP since (no s/w updates, or other changes).

As for Roon on the Mini “running like a video game” and taking up cpu cycles (it runs at almost 100% constantly now), that’s completely unacceptable. There is nothing visually happening when nothing is playing, and there’s only the update of the play position progress bar otherwise. My Mini (which is inside a cabinet) is starting to get quite hot and overheat. Also odd is that on the MBP, there’s virtually no cpu load, so maybe it’s an interaction with screen sharing?


@danny @mike Fresh install of OSX Yosemite.

I always do a fresh install of OSX … then restore my data … as I have been previously caught out before when doing OS upgrades, rather than fresh OS installs. So I just do a fresh install of OSX in November every year (about a month or so after the newest OSX is released).

@warrensomebody – can you run:

% /Applications/ -colorconsole

and paste me the output?

I think you are on to something…

@danny @mike @vova Thank you all for checking with how I was going with Roon … anyway you should all have the output from me running the console command via PM.

I also tried the new release of Roon that was released today … still no good.

Also tried “Repair Permissions” in OSX Disk Utility (I was clutching at straws, but hey, you never know :smile: ) , also no good.


Thank You to Danny !!! , Mike & Vova for helping to get this resolved (I had a permission problem with my home directory).

Thanks for your assistance in helping us figure this out @Duke – we are going to add an error when permissions on your Mac don’t allow us to create critical directories and files we need. That error should explains exactly what’s going on instead of silently die.