Roon Radio fails when started from a Genre [Resolved]

I have the same issue, roon radio stopped working for genre

Why, when starting Radio by genre, it does not write enough matches and starts Radio limited by the library. Although noted in the media library a huge number of artists in the genre. Both Qobuz and Tidal are connected. And this applies to Pop / Rock, even R & B, which is simply a huge number.

same issue here from Genre…

Update on genre radio issue please?

Last update was was days ago. Any info on the genre radio issue?

1 Like

Hi @enordee1 — I’ve requested an update from the team on the current status on this. Based on our internal tracker it looks like this is still with our development team. I’ll be sure to follow up as soon as I have a better idea of what the timeline is for a fix. Apologies for the trouble!


Core Machine Windows 10. Roon1.7 64 Bit

I’m trying to start Roon Radio on some pretty generic genres and I keep getting the message “Nothing Similar found. Limiting Roon Radio to Library” I understand that If the radio station I’m starting is too esoteric then I’m not going to get many results, but I get this messege when trying to engage Roon Radio with broad genres such as “Experimental” or “Heavy Metal”

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Connection is via Wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB connection to a Modi 3 DAC

Description Of Issue


I have a tidal subscription that I’m hoping Roon Radio will be using for the radio source.

Hi @Calum_Fewster,

Thanks for reaching out! I’ve merged your report into an existing thread, we are aware of this behavior and looking into it, please see @dylan’s reply for the latest status:

Same issue here…

Core Machine (Operating system/System info/Roon build number)
Windows 10 PC

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Not relevant, network works ok

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Not relevant, audio works

Description Of Issue

Steps : Navigate to genres -> click on arrow near “Shuffle” -> “Roon Radio”

Result : I always get “Nothing similar found : limiting Roon Radio to library”. The radio proceeds to play both (but ONLY) locally stored files and Qoubuz files that I’ve previously added to the Roon library

This sucks. I love using Roon Radio for discovering music

I Think I’ve been having this issue for a few weeks, so there had been updates & restarts

Hi @Christopher_Rowe,

I’ve moved your post into the existing thread regarding this topic, we are aware and working on this issue, please see above:

It is almost six weeks since this issue was first reported. Doesn’t that seem wrong even to you guys at Roon?

1 Like

This is the main way I use Roon so I can hear new artists. Very disappointed that this has not been resolved yet.


It’s been over months now but Roon Radio for genres is still not working. When could it be fixed? :frowning:

1 Like

Hi @KaiChong_Wong, I just looked at your posting history and could not see a support request from you on this.

Thus I moved it over to the #support section for you.

Multiple users have reported this issue. All with different systems. It has been acknowledged by Roon and they have been “working on it” for 6 weeks. Let’s not start all over again. Just give us an update.

Your right, I’ve merged into that topic … so all feedback and questions are together.

1 Like

Still not working… but we now have a sleep timer…


Dylan…why was the genre radio issue not addressed in the latest update?